Foros del Web » Creando para Internet » HTML »

Extraños errores según Navegador

Estas en el tema de Extraños errores según Navegador en el foro de HTML en Foros del Web. Hola! Estoy diseñando un sitio web, únicamente por placer en XHTML 1.0, y he encontrado que hay algo que se ve distinto en Internet Explorer ...
  #1 (permalink)  
Antiguo 18/12/2004, 13:05
 
Fecha de Ingreso: diciembre-2003
Ubicación: Córdoba, Argentina
Mensajes: 249
Antigüedad: 14 años
Puntos: 0
Extraños errores según Navegador

Hola!

Estoy diseñando un sitio web, únicamente por placer en XHTML 1.0, y he encontrado que hay algo que se ve distinto en Internet Explorer y en Mozilla Firefox 1.0, querría que alguien les diese un vistazo si tiene tiempo, ya que con internet explorer, me aparece debajo del menú repetidas las últimas 2 letras "on":

http://dotgeek.org/~mesarpe/prueba.html
http://dotgeek.org/~mesarpe/prueba.css

Desde ya, muchas gracias
  #2 (permalink)  
Antiguo 19/12/2004, 16:00
 
Fecha de Ingreso: diciembre-2004
Mensajes: 163
Antigüedad: 13 años
Puntos: 2
La verdad es que si es muy curioso lo que sucede, es extraño que en mozilla corra bien y en explorer tenga problemas, casi siempre se da el caso contrario. ¿Lo que tu buscabas era crear una web compatible unicamente con mozilla? si no es el caso por favor te pediria que pusieras el codigo de tu pagina para asi analizarlo y salir de esta gran duda. xauuuuuuuuu
  #3 (permalink)  
Antiguo 19/12/2004, 18:48
 
Fecha de Ingreso: diciembre-2003
Ubicación: Córdoba, Argentina
Mensajes: 249
Antigüedad: 14 años
Puntos: 0
Revisalo al código con el navegador, para eso lo dejé... Fíante en ver código de fuente en tu navegador :)
  #4 (permalink)  
Antiguo 20/12/2004, 11:58
 
Fecha de Ingreso: diciembre-2004
Mensajes: 163
Antigüedad: 13 años
Puntos: 2
Gracias no me habia dado cuenta. Bueno en fin estuve revisando el codigo y veo todo completamente normal, no se me ocurre que pueda estar pasando. pero haciendo un analisis me pregunto que pasaria si agregaras un salto de linea a la ultima etiqueta que dice section :
<!-- menu -->
<div id="menu">
<div class="title">Title 1</div>
<p>Section 1<br />
Section 2<br />
Section 3</p>

<div class="title">Title 2</div>
<p>Section 1<br />
Section 2<br />
Section</p>
</div>
</div>

O sea quedaria algo así:
<!-- menu -->
<div id="menu">
<div class="title">Title 1</div>
<p>Section 1<br />
Section 2<br />
Section 3</p>

<div class="title">Title 2</div>
<p>Section 1<br />
Section 2<br />
Section<br /></p>
</div>
</div>

Es solo por curiosidad, si es que te funciona por favor avisame. xau
  #5 (permalink)  
Antiguo 20/12/2004, 20:09
 
Fecha de Ingreso: agosto-2003
Mensajes: 499
Antigüedad: 14 años, 3 meses
Puntos: 1
es un bug de display fantasma de IE, creo que este :
http://www.positioniseverything.net/...haracters.html

codigo mas correcto que ademas resolve tu bug :
<div id="menu">
<h3>Title 1</h3>
<ul>
<li>Section 1</li>
<li>Section 2</li>
<li>Section 3</li>
</ul>
<h3>Title 2</h3>
<ul>
<li>Section 1</li>
<li>Section 2</li>
<li>Section 3</li>
</ul>
</div>
__________________
Plaza Mozilla
http://www.chevrel.org/es/noticias/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:28.