Foros del Web » Creando para Internet » HTML »

Formulario multipart/form-data

Estas en el tema de Formulario multipart/form-data en el foro de HTML en Foros del Web. Hola, tengo un formulario con un par de campos file y unos cuanto campos hidden. En la página que recibe los datos del formulario me ...
  #1 (permalink)  
Antiguo 04/01/2005, 09:59
 
Fecha de Ingreso: enero-2002
Mensajes: 153
Antigüedad: 15 años, 10 meses
Puntos: 0
Formulario multipart/form-data

Hola,
tengo un formulario con un par de campos file y unos cuanto campos hidden. En la página que recibe los datos del formulario me llegan los campos hidden únicamente cuando no uso enctype="multipart/form-data", pero entonces no me llegan los ficheros de los campos file.
Y cuando uso enctype="multipart/form-data" me llegan los fichero de los campos file, pero no me llegan los campos hidden.
¿Alguien puede echarme una mano?
Gracias
  #2 (permalink)  
Antiguo 04/01/2005, 12:18
Avatar de monoswim
$moderador{'Esteban'}
 
Fecha de Ingreso: febrero-2002
Ubicación: Buenos Aires - Argentina
Mensajes: 8.762
Antigüedad: 15 años, 10 meses
Puntos: 90
...mmm...Seguramente tienes un problema en el script que usas para enviar los datos...

En que lenguaje tienes el script ? PERL, PHP, ASP...

Saludos
__________________
Esteban Quintana
  #3 (permalink)  
Antiguo 05/01/2005, 02:23
 
Fecha de Ingreso: enero-2002
Mensajes: 153
Antigüedad: 15 años, 10 meses
Puntos: 0
Para enviar los datos utilizo el metodo POST de los formularios de HTML. Y para recibir los datos del formulario utilizo ColdFusion, pero creo que no tiene nada que ver el lenguaje que utilice para recibir los datos, ya que el problema es que no llegan.
  #4 (permalink)  
Antiguo 05/01/2005, 05:19
Avatar de monoswim
$moderador{'Esteban'}
 
Fecha de Ingreso: febrero-2002
Ubicación: Buenos Aires - Argentina
Mensajes: 8.762
Antigüedad: 15 años, 10 meses
Puntos: 90
Mira, para mi que el problema lo tienes en el script de Cold Fusion, porque el formulario seguramente está mandando la info, sería casi imposible que un simple form en HTML se valla a colgar al enviarse.

Lo que pasa es que los formularios envían la información al script de distinta manera si es Multipart/Form-Data que si es un form comunacho, y la entrada de info la debes hacer de distinta manera...No se si en ColdFusion haces la entrada manualmente como en PERL...Checkea bien eso.

Si no es ese el problema no tendría idea de que puede llegar a ser...

Saludos y suerte !!!
__________________
Esteban Quintana
  #5 (permalink)  
Antiguo 10/01/2005, 12:02
 
Fecha de Ingreso: enero-2002
Mensajes: 153
Antigüedad: 15 años, 10 meses
Puntos: 0
Gracias por tu tiempo y esfuerzo.
Cada vez veo más claro que el problema es ColdFusion.
Muchas gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:50.