Foros del Web » Creando para Internet » HTML »

Frames en IE

Estas en el tema de Frames en IE en el foro de HTML en Foros del Web. Buenas de nuevo! Estoy intentando hacer una web en html utilizando frames, ya he leído por ahí que no es lo más apropiado pero dicha ...
  #1 (permalink)  
Antiguo 27/12/2006, 08:04
Avatar de jabi  
Fecha de Ingreso: noviembre-2006
Mensajes: 120
Antigüedad: 11 años, 1 mes
Puntos: 1
Frames en IE

Buenas de nuevo!

Estoy intentando hacer una web en html utilizando frames, ya he leído por ahí que no es lo más apropiado pero dicha web es parte de un trabajo que nos han mandado en clase y debemos utilizar lo visto hasta el momento (incluyendo los frames)... Lo que quería saber es si hay alguna forma de impedir que se puedan "redimensionar", es decir, aunque le pongo al FRAMESET la propiedad border=0 y consigo que no aparezcan las divisiones de la página, he comprobado que se puede estirar lo que quiera pinchando justo en la división... pero sólo en IE, con FF no se puede, como debe ser

Otra cosita, estoy utilizando también una lista no numerada <UL> y siempre que pongo en un <LI> dos palabras separadas por un espacio, la 2ª se baja un renglón más abajo... ¿cómo puedo evitar que se baje a otra línea? Os pongo una imagen para aclararlo por si no se me ha entendido:



A ver si me podéis echar un cable con ambos "problemas", gracias de antemano
  #2 (permalink)  
Antiguo 27/12/2006, 09:18
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Re: Frames en IE

Hola jabi

Para que no se redimensione el marco:

<frame name="algo" src="tupagina.html" frameborder="0" noresize>

Lo de la listas no sé qué puede ser Pon el código que estás usando a ver si damos con el error.

Saludos,
  #3 (permalink)  
Antiguo 27/12/2006, 11:41
Avatar de jabi  
Fecha de Ingreso: noviembre-2006
Mensajes: 120
Antigüedad: 11 años, 1 mes
Puntos: 1
Re: Frames en IE

Muchas gracias tocayo, noresize me ha solucionado el problema, y luego mirando y remirando creo que ya he arreglado lo de las listas, tenía este estilo para el body:

Código:
body{
font-family: "CurlZ MT";
margin: 20px 500px 20px 0px;
}
Ni idea de por qué me dio por poner 500px de margin-right, lo he puesto a 0 y problema solucionado, lo que no entiendo es por qué separaba únicamente ese <LI>, el de "Más Datos" habiendo otros de más caracteres ("Monumentos"), supongo que al encontrar el espacio se pasaba al siguiente renglón a la fuerza...

Si me lo aclaras tú o alguien mejor que mejor

Un saludo y muchas gracias de nuevo
__________________
No estoy aquí de vacaciones, creéme.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:12.