Foros del Web » Creando para Internet » HTML »

funcion include me deforma el site

Estas en el tema de funcion include me deforma el site en el foro de HTML en Foros del Web. Hola cmo va? bue tengo un problemita cuando pongo el encabezado y el menu del site con un include me lo deforma, a alguien le ...
  #1 (permalink)  
Antiguo 03/09/2007, 16:17
 
Fecha de Ingreso: julio-2007
Mensajes: 8
Antigüedad: 10 años, 4 meses
Puntos: 0
funcion include me deforma el site

Hola cmo va? bue tengo un problemita cuando pongo el encabezado y el menu del site con un include me lo deforma, a alguien le paso algo asi?
ah en Opera lo veo perfecto , pero el IExplorer se deforma mal.
desde ya gracias!!!

les copio el codigo, gracias!!

Código HTML:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Untitled Document</title>
<style type="text/css">
<!--
body {
	margin-left: 0px;
	margin-top: 0px;
	margin-right: 0px;
	margin-bottom: 0px;
	background-color: #dbdada;
}
-->
</style></head>

<body>
<table width="100%" height="100%" border="0" cellpadding="0" cellspacing="0">
  <tr>
    <td valign="top"  scope="col"><table width="746" border="0" align="center" cellpadding="0" cellspacing="0">
      <tr>
        <th width="746" scope="col"><table width="746" border="0" align="center" cellpadding="0" cellspacing="0">
          <tr>
            <td colspan="10" scope="col"><?php include ("encabezado.php") ?></td>
            </tr>
          <tr bgcolor="#FFFFFF">
            <td width="746" height="5" colspan="10" nowrap="nowrap"></td>
            </tr>

          <tr>
            <td height="11"  width="138" colspan="3" nowrap="nowrap"background="img/fondo/images/menu_sup.jpg" bgcolor="#CCCCCC"></td>
            <td height="11"  colspan="7"  nowrap="nowrap" background="img/fondo/images/conte_sup.jpg"></td>
            </tr>
          <tr>
            <td width="11" height="27" bgcolor="#C2A64E"></td>
            <td width="121" height="400" rowspan="2" align="left" valign="top" bgcolor="#C2A64E">
			<?php include ("menu.php") ?></td>
            <td width="6" height="27" align="right" bgcolor="#C2A64E"></td>
            <td width="15" height="27" rowspan="2" nowrap="nowrap" background="img/fondo/images/menu_borde.jpg">&nbsp;</td>
            <td colspan="5" rowspan="2" nowrap="nowrap"  width="585" bgcolor="DACE90"></td>
            <td  width="8" height="27" rowspan="2" nowrap="nowrap" background="img/fondo/images/conte_borde.jpg">&nbsp;</td>
          </tr>
          <tr>
            <td bgcolor="#C2A64E"></td>
            <td bgcolor="#C2A64E"></td>
            </tr>  
          <tr>
            <td width="11" height="9" background="img/fondo/images/pie_izq.jpg"></td>
            <td height="9"colspan="8" background="img/fondo/images/pie_fondo.jpg"></td>
            <td width="8" height="9" nowrap="nowrap" background="img/fondo/images/pie_dcho.jpg"></td>
          </tr>
          <tr>
            <td height="13" colspan="9" rowspan="2" bgcolor="#C2A64E">&nbsp;</td>
            <td width="8" height="17" background="img/fondo/images/pie_dchoarriba.jpg"></td>
          </tr>
          <tr>
            <td width="8" nowrap="nowrap" background="img/fondo/images/conte_borde.jpg">&nbsp;</td>
          </tr>
          <tr>
            <td width="11" height="9" background="img/fondo/images/pie_izq.jpg" bgcolor="#FFFFFF"></td>
            <td height="9" colspan="8" background="img/fondo/images/pie_fondo.jpg"></td>
            <td width="8" height="9" nowrap="nowrap" background="img/fondo/images/pie_dcho.jpg"></td>
          </tr>
          <tr>
            <td colspan="10"></td>
            </tr>
          
        </table></th>
      </tr>
    </table></td>
  </tr>
</table>
</body>
</html> 
  #2 (permalink)  
Antiguo 03/09/2007, 16:21
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 6 meses
Puntos: 2122
Re: funcion include me deforma el site

Tema trasladado a HTML.

Porfavor publica en los foros correctos.
  #3 (permalink)  
Antiguo 05/09/2007, 07:12
Avatar de bookmaster  
Fecha de Ingreso: febrero-2002
Ubicación: Toledo
Mensajes: 976
Antigüedad: 15 años, 10 meses
Puntos: 67
Re: funcion include me deforma el site

Habria que ver que contenido tienen los archivos que pones con el include, ya que si hs puesto de nuevo la parte del <head> <body> y esas cosas, estas rompiendo la estructura básica del HTML, por lo que hará que se te descuadre todo.
__________________
Decir si te a funcionado la respuesta es ¡GRATIS!. Por favor indicarlo.
http://www.lohacemosweb.net
http://tutoriales.lohacemosweb.net
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:45.