Foros del Web » Creando para Internet » HTML »

Un iFrame que no funciona

Estas en el tema de Un iFrame que no funciona en el foro de HTML en Foros del Web. Saludos, amigos y vecinos... Me acabo de embarcar en un nuevo proyecto para mi web: en la creación de una wikipedia, que ahora están tan ...
  #1 (permalink)  
Antiguo 08/12/2006, 12:12
Avatar de Xusqui  
Fecha de Ingreso: febrero-2004
Ubicación: Málaga
Mensajes: 154
Antigüedad: 13 años, 9 meses
Puntos: 0
Un iFrame que no funciona

Saludos, amigos y vecinos...

Me acabo de embarcar en un nuevo proyecto para mi web: en la creación de una wikipedia, que ahora están tan de moda, para sustituir la "Knowledge Base" que tantos bugs de seguridad tiene (de phpBB hablo)

Nunca he usado iFrames, así que no sé cómo van.

1.- Mi dominio principal es www.ka-tet-corp.com
2.- El dominio de la wikipedia es wiki.ka-tet-corp.com

Yo lo que quería es que se mostrara la wikipedia en un iframe dentro del portal principal. Para ello puse lo siguiente en el archivo correspondiente:

Código:
<iframe src="http://wiki.ka-tet-corp.com/index.php/" name="Stephen King wikipedia" height="1000" width="800">
El problema es que cuando quiero abrir la página, la wikipedia, en lugar de abrirse en el iframe se abre en todo el navegador, como si hubiera llamado directamente a la web.

Podéis ver a qué me refiero si la visitáis: www.ka-tet-corp.com/portal2.0/wikipedia.php

¿Alguna idea de qué pasa y de si tiene solución?

Gracias!!
__________________
Portal y Foro sobre Stephen King

Foros, noticias, imágenes, juegos, música... El paraíso del Friki de Stephen King.
  #2 (permalink)  
Antiguo 08/12/2006, 12:25
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Re: Un iFrame que no funciona

Hola Xusqui

La página que quieres abrir tiene un código JavaScript para que no se abra dentro de un frame o un iframe:

Código:
if( window.top != window ) window.top.location = window.location;
Que yo sepa no hay forma de solucionarlo.

Saludos,
  #3 (permalink)  
Antiguo 08/12/2006, 13:18
Avatar de Xusqui  
Fecha de Ingreso: febrero-2004
Ubicación: Málaga
Mensajes: 154
Antigüedad: 13 años, 9 meses
Puntos: 0
Re: Un iFrame que no funciona

Muchísimas gracias, Javier...

Entonces quitando ese código de ahí debería de poder abrirse, verdad?

Voy a probarlo!

Gracias de nuevo!!
--Edito--

Efectivamente ahora funciona al 100%... Lo que pasa es que estéticamente no me termina de convencer...

Muchísimas gracias... Uno nunca acaba de aprender!!
__________________
Portal y Foro sobre Stephen King

Foros, noticias, imágenes, juegos, música... El paraíso del Friki de Stephen King.

Última edición por Xusqui; 08/12/2006 a las 13:24
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:19.