Foros del Web » Creando para Internet » HTML »

iframes y barras de desplazamiento

Estas en el tema de iframes y barras de desplazamiento en el foro de HTML en Foros del Web. Hola, estaba intentando hacer un tagboard.. en el que coloco un iframe donde tiene q ssalir el contenido... y hay mediante php repito una tabla ...
  #1 (permalink)  
Antiguo 09/09/2005, 15:28
 
Fecha de Ingreso: agosto-2005
Mensajes: 79
Antigüedad: 12 años, 4 meses
Puntos: 0
iframes y barras de desplazamiento

Hola, estaba intentando hacer un tagboard.. en el que coloco un iframe donde tiene q ssalir el contenido... y hay mediante php repito una tabla para q salga los mensajes...

el problema es q me sale una barra de desplazamiento horizonal.. y el ancho de la tabla es mejor q el del iframe... no se porque sale.. he intentao ponerle menos ancho y aun sigue saliendo... ademas es minimo el desplazamiento que tiene... he mirao tb el ancho al poner la barra vertical.. y nada sigue saliendo la dichosa barra horizontal... he probao quitandole los margenes a la pagina que tiene q salir en el iframe.. pero nada... sale :S ya no se que hacer
  #2 (permalink)  
Antiguo 10/09/2005, 05:37
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
Estas cosas tocan mucho las narices....

recuerdo hará un par de meses alguien tenía un problema similar, pero creo que el documento que cargaba el iframe estaba dentro de un frameset. Le dí unas cuantas vueltas y no logré solucionarlo ni entender por qué sucedía. En cambio si cargaba el documento con el iframe fuera del frameset no aparecía esa barra de scroll.

¿es tu caso? ¿estás usando además una estructura de frames?
  #3 (permalink)  
Antiguo 10/09/2005, 05:52
 
Fecha de Ingreso: agosto-2005
Mensajes: 79
Antigüedad: 12 años, 4 meses
Puntos: 0
Código HTML:
<td width="315" height="300"><iframe src="mostrar_noticia.php" width="315" height="300" marginheight="0" marginwidth="0" ></iframe></td> 
asi lo tengo puesto... despues la pagina que carga... es solo una tabla q tiene de ancho 290... y q se va repitiendo hasta un numero de noticias.... pero no se porque me sale la barra horizontal.. si todo lo que hay a la izquierda esta en blanco...
  #4 (permalink)  
Antiguo 14/09/2005, 01:56
Avatar de mariogl84  
Fecha de Ingreso: noviembre-2002
Ubicación: Barcelona
Mensajes: 433
Antigüedad: 15 años
Puntos: 20
Hola, Daveee.

Edita mostrar_noticia.php y elimina la línea <!DOCTYPE HTML PUBLIC ... que va antes del html.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:46.