Foros del Web » Creando para Internet » HTML »

Jeraquía de las capas

Estas en el tema de Jeraquía de las capas en el foro de HTML en Foros del Web. Hola a [email protected] Estoy haciendo una web con un menú desplegable. Todo funciona perfectamente en los navegadores que los he probado. El problema surge cuando ...
  #1 (permalink)  
Antiguo 17/05/2004, 17:23
 
Fecha de Ingreso: febrero-2003
Ubicación: Madrid, España
Mensajes: 29
Antigüedad: 14 años, 10 meses
Puntos: 0
Jeraquía de las capas

Hola a [email protected]

Estoy haciendo una web con un menú desplegable. Todo funciona perfectamente en los navegadores que los he probado. El problema surge cuando incluyo una página dentro de la que tiene el menú con el siguiente código en el body:

<table width="100%" height="" border="0" cellpadding="0" cellspacing="0">
<tr>
<td>
<TD width=100% rowSpan=3><IFRAME name=top
src="Libro1.htm" frameBorder=0
width=100% height=100%></IFRAME></TD></td>
</tr>
</table>



...resulta que el menú se despliega por encima pero cuando el ratón pasa por donde empieza la página insertada interpreta que ya no estoy encima de las opciones del menú y se vuelve a plegar.

¿cómo puedo solucionar esto? Supongo que será un problema de jerarquías y algo deberé incluir para que respete la capa del menú antes que la de la web insertada....

Si no queda muy claro... el ejemplo con el que estoy trabajando está en http://www.imagina-web.net/pruebas/pagina.htm . Ahí funciona con iExplorer pero con el resto de navegadores surge el problema que os comento.

Gracias de antemano por vuestra ayuda.
__________________
Madrid...
te quiero:corazon:
  #2 (permalink)  
Antiguo 18/05/2004, 04:34
Avatar de kemie  
Fecha de Ingreso: junio-2003
Ubicación: estocolmo<-->mexico
Mensajes: 1.627
Antigüedad: 14 años, 5 meses
Puntos: 1
No veo el problema... tanto en IE como en Mozilla me funciona como debe,...
__________________
::::::::::::::::::::::::::::: WebHostNinja | diseñorama.com::::::::::::::::::::::::::::::
  #3 (permalink)  
Antiguo 18/05/2004, 08:52
Avatar de PatomaS
Colaborador
 
Fecha de Ingreso: marzo-2004
Ubicación: En alguna otra parte
Mensajes: 4.656
Antigüedad: 13 años, 9 meses
Puntos: 63
Hola

Pues yo tengo un comportamiento por cada navegador:

Firefox 0.8:

Aparece todo el contenido de la página, pero cuando muevo el ratón en el desplegable, a cierta altura se desaparece. por ejemplo en componente > discos duros.

Explorer 6 sp1
Aparece todo el contenido y puedo llegar al final de los desplegables.

Netscape 7.0
No aparece todo el contenido, me falta el contenido del iframe y cuando me desplazo por los desplegables, estos me desaparecen a la misma altura que en el firefox.

Opera 7.23
Aparece todo el contenido pero los desplegables se ocultan tras el iframe, por lo que obviamente, no es posible seleccionar casi nada.

Bueno, por lo que veo, aun te queda mucho trabajo por delante...

:)

Pero divertido si que es...



Felicidad
__________________
¡ hey, hou, hou, hey !
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:09.