Foros del Web » Creando para Internet » HTML »

Links en Imágenes

Estas en el tema de Links en Imágenes en el foro de HTML en Foros del Web. Hola Gente. Estoy teniendo un problema para poner links en imágenes. Tengo un sitio, armado en php. En el llamado single.php tiene un menú llamado ...
  #1 (permalink)  
Antiguo 31/07/2010, 17:37
 
Fecha de Ingreso: julio-2010
Mensajes: 5
Antigüedad: 7 años, 4 meses
Puntos: 0
Links en Imágenes

Hola Gente.
Estoy teniendo un problema para poner links en imágenes.

Tengo un sitio, armado en php.
En el llamado single.php tiene un menú llamado "navigation" en donde quiero poner los Bookmarks (facebook, twitter, etcetera)

El navigation me toma las imagenes (el tag html <img src=...>). Sin embargo, cuando les agrego el link que debe conducir cada imagen (el tag html <a href="http://...><img src=...></a>), las imágenes desaparecen.

Alguien tiene idea de por qué puede estar ocurriendo eso??

Adjunto una imagen de cómo es el llamado single.php con las imágenes (pero sin los links)



Agradezco sugerencias.

Sol
  #2 (permalink)  
Antiguo 31/07/2010, 19:08
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Links en Imágenes

sabes, en el momento que mas los necesitamos, los adivinos se fueron de vacaciones sin fecha de regreso. o sea, sin codigo o un enlace al documento que presente el problema no hay forma que alguien te pueda ayudar. dicen que una imagen dice mas que mil palabras, pero eso no aplica aqui. en todo caso, lo unico que te puedo decir es que revises los css aplicado al documento.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #3 (permalink)  
Antiguo 01/08/2010, 00:57
 
Fecha de Ingreso: julio-2010
Mensajes: 5
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Links en Imágenes

jajajajajajjajajjaaj pues si!!!! tienes razón!!!
Te pido mil disculpas por ser tan ingenua!!!
Soy muy nueva empleando foros pidiendo soluciones. DIscúlpame por mi ingenuidad.

El link al sitio (está en un servidor de prueba gratutito, esta semana debo migrarlo. Estoy esperando a que se propaguen los dens del .com del hosting pago que le asigné) es esté:

[UR]http://haciaexlibris.com.ar/paris/oh-paris-paris-paris[/URL]

El código:


Cita:
<?php get_header(); ?>

<?php if (have_posts()) : while (have_posts()) : the_post(); ?>

<div class="grid_16 alpha"> <h2 class="single"><?php the_title(); ?></h2></div>
<div class="grid_4 alpha">

<p class="post_meta"><span class="comments"><a href="#respond">Leave a comment</a></span></p>
<div style="clear:both;height:20px;border-bottom:1px solid #eee;margin-bottom: 20px;"></div>

<h4 class="tags">Tags</h4>
<?php the_tags('', ', ', '<br />'); ?>

<div style="clear:both;height:10px;border-bottom:1px solid #eee;margin-bottom: 20px;"></div>

<div class="navigation">
<div class="previous">
<h4>Cuaderno Anterior</h4>
<p><?php previous_post_link('%link') ?></p>
</div>
<div class="next">
<h4>Próximo Cuaderno</h4>
<p><?php next_post_link('%link') ?></p>
</div>

<div style="clear:both;height:10px;border-bottom:1px solid #eee;margin-bottom: 20px;"></div>


<h4 class="tags">Bookmarks</h4>

<img src="http://img.photobucket.com/albums/v293/solciii/facebook.png" border="0" title="Seguinos en Facebook">

<img src="http://img.photobucket.com/albums/v293/solciii/twitter1.png" border="0" title="Seguinos en Twitter">

<img src="http://img.photobucket.com/albums/v293/solciii/rss_logo.png" border="0" title="Suscribite via RSS">

<img src="http://img.photobucket.com/albums/v293/solciii/email.png" border="0" title="Suscribite a nuestro Newsletter">
(Aquí es donde no me toma lo links)


</div>





<div style="clear:both;height:10px;border-bottom:1px solid #eee;margin-bottom: 20px;"></div>

</div>
<div id="main" class="grid_12 omega">

<div class="entry">

<?php woo_get_image('image','700'); ?>

<?php the_content(); ?>

<?php edit_post_link(__('Edit this post.'), ' - ', ''); ?>

</div>

<?php comments_template(); ?>

<?php endwhile; endif; ?>

</div><!-- / #main -->

<?php get_footer(); ?>

El sitio corre bajo wordpress.

Y te pido mil disculpas por haber pecado de tan naif!!
Me perdonas?
  #4 (permalink)  
Antiguo 01/08/2010, 00:58
 
Fecha de Ingreso: julio-2010
Mensajes: 5
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Links en Imágenes

jajajajajajjajajjaaj pues si!!!! tienes razón!!!
Te pido mil disculpas por ser tan ingenua!!!
Soy muy nueva empleando foros pidiendo soluciones. DIscúlpame por mi ingenuidad.

El link al sitio (está en un servidor de prueba gratutito, esta semana debo migrarlo. Estoy esperando a que se propaguen los dens del .com del hosting pago que le asigné) es esté:

[URL]http://haciaexlibris.com.ar/paris/oh-paris-paris-paris[/URL]

El código:


Cita:
<?php get_header(); ?>

<?php if (have_posts()) : while (have_posts()) : the_post(); ?>

<div class="grid_16 alpha"> <h2 class="single"><?php the_title(); ?></h2></div>
<div class="grid_4 alpha">

<p class="post_meta"><span class="comments"><a href="#respond">Leave a comment</a></span></p>
<div style="clear:both;height:20px;border-bottom:1px solid #eee;margin-bottom: 20px;"></div>

<h4 class="tags">Tags</h4>
<?php the_tags('', ', ', '<br />'); ?>

<div style="clear:both;height:10px;border-bottom:1px solid #eee;margin-bottom: 20px;"></div>

<div class="navigation">
<div class="previous">
<h4>Cuaderno Anterior</h4>
<p><?php previous_post_link('%link') ?></p>
</div>
<div class="next">
<h4>Próximo Cuaderno</h4>
<p><?php next_post_link('%link') ?></p>
</div>

<div style="clear:both;height:10px;border-bottom:1px solid #eee;margin-bottom: 20px;"></div>


<h4 class="tags">Bookmarks</h4>

<img src="http://img.photobucket.com/albums/v293/solciii/facebook.png" border="0" title="Seguinos en Facebook">

<img src="http://img.photobucket.com/albums/v293/solciii/twitter1.png" border="0" title="Seguinos en Twitter">

<img src="http://img.photobucket.com/albums/v293/solciii/rss_logo.png" border="0" title="Suscribite via RSS">

<img src="http://img.photobucket.com/albums/v293/solciii/email.png" border="0" title="Suscribite a nuestro Newsletter">
(Aquí es donde no me toma lo links)


</div>





<div style="clear:both;height:10px;border-bottom:1px solid #eee;margin-bottom: 20px;"></div>

</div>
<div id="main" class="grid_12 omega">

<div class="entry">

<?php woo_get_image('image','700'); ?>

<?php the_content(); ?>

<?php edit_post_link(__('Edit this post.'), ' - ', ''); ?>

</div>

<?php comments_template(); ?>

<?php endwhile; endif; ?>

</div><!-- / #main -->

<?php get_footer(); ?>

El sitio corre bajo wordpress.

Y te pido mil disculpas por haber pecado de tan naif!!
Me perdonas?
  #5 (permalink)  
Antiguo 01/08/2010, 01:18
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Links en Imágenes

solciii:

Hay algo que se me escapa, o me estoy poniendo viejo... quizás las dos cosas

Cita:
<img src="http://img.photobucket.com/albums/v293/solciii/facebook.png" border="0" title="Seguinos en Facebook">

<img src="http://img.photobucket.com/albums/v293/solciii/twitter1.png" border="0" title="Seguinos en Twitter">

<img src="http://img.photobucket.com/albums/v293/solciii/rss_logo.png" border="0" title="Suscribite via RSS">

<img src="http://img.photobucket.com/albums/v293/solciii/email.png" border="0" title="Suscribite a nuestro Newsletter"> (Aquí es donde no me toma lo links)

NO sé que links debería tomarte, porque yo en ese fragmento no veo ningún link, solo cuatro imágenes, a las que, por otro lado, si declaras xhtml en tu Doctype, cosa que has hecho, deberías cerrar con /> y definirles el atributo alt=""


Saludos
  #6 (permalink)  
Antiguo 01/08/2010, 03:19
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: Links en Imágenes

Hola:

Ya te lo ha indicado emprear, faltan los links. Cambialos por esto:

Código HTML:
Ver original
  1. <a href="link_que_corresponda"><img src="http://img.photobucket.com/albums/v293/solciii/facebook.png" border="0" title="Seguinos en Facebook"></a>

Saludos.

  #7 (permalink)  
Antiguo 01/08/2010, 05:21
 
Fecha de Ingreso: julio-2010
Mensajes: 5
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Links en Imágenes

Gente: ante todos les agradezco su ayuda.

Les comento: cuando estaba programando, puse las imágenes con sus respectivos links. Vi que no aparecía nada en la barra lateral. Empecé a probar qué demonios lo podía estar causando.
Entonces scanado y poniendo cosas, descubrí que las imágenes aparecían sólo cuando no estaban los links puestos.

Porque tengo que mostrarle al cliente mañana -lunes- una segunda versión del sitio dejé las imágenes. No puse los links, porque ya sé que no funcionan (pero les juro que lo he intentado <a href="http://..."><img src="..."></a>

Lo que necesito descifrar es por qué cuando agrego un link en las imágenes, éstas simplemente desaparecen...

Última edición por solciii; 01/08/2010 a las 05:30
  #8 (permalink)  
Antiguo 01/08/2010, 07:50
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Links en Imágenes

he hecho una prueba agregando los enlaces desde el DOM y no veo ningun problema. deberias presentarnos el documento con el problema.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #9 (permalink)  
Antiguo 01/08/2010, 09:59
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: Links en Imágenes

Hola:

Yo he hecho la prueba con el firebug de Firefox y he visto las imágenes perfectamente.

Saludos.

  #10 (permalink)  
Antiguo 01/08/2010, 15:56
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Links en Imágenes

solciii:

Para mi tu problema tiene que ver con el WordPress, dónde estas modificando la plantilla? en el código, estas modificando desde el mismo wordPress? Tenés algun servidor local para previsualizar los cambios?

Saludos
  #11 (permalink)  
Antiguo 01/08/2010, 18:42
 
Fecha de Ingreso: julio-2010
Mensajes: 5
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Links en Imágenes

Cita:
Iniciado por emprear Ver Mensaje
solciii:

Para mi tu problema tiene que ver con el WordPress, dónde estas modificando la plantilla? en el código, estas modificando desde el mismo wordPress? Tenés algun servidor local para previsualizar los cambios?

Saludos
Ese era el problema!!!!!

Graciaasssss!!!

Estaba editando lo que quedaba desde el mismo wordpress de fiaca-vaga-haragana.
No sabía que el wordpress traía problemas.
Que sabios que resultaron mis muchachos. Gracias por su grandilocuente conocimiento!!!

Niles y miles de gracias, esta fiel servidora!

Etiquetas: links
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:44.