Foros del Web » Creando para Internet » HTML »

mailto: ???No va!

Estas en el tema de mailto: ???No va! en el foro de HTML en Foros del Web. Hola foro. Una consulta: Tengo un link con mailto:[email protected] En general funciona según lo previsto, se abre el Outlook con la dirección como destinatario. El ...
  #1 (permalink)  
Antiguo 28/07/2003, 10:48
 
Fecha de Ingreso: mayo-2003
Mensajes: 91
Antigüedad: 14 años, 6 meses
Puntos: 0
Exclamación mailto: ???No va!

Hola foro.

Una consulta: Tengo un link con mailto:[email protected] En general funciona según lo previsto, se abre el Outlook con la dirección como destinatario.

El problema es que tengo un cliente cuya empresa trabaja con otro gestor de correo (un tal "notes" o algo así) y no funciona el mailto. ¿Alguien me puede ayudar?

No pretendo hacer un envío automático, para eso utilizaría una cgi, simplemente que se abra el correo con el destinatario.

Un saludo.
Isaac
__________________
Isaac González
http://twitter.com/IsaacGonzalez
  #2 (permalink)  
Antiguo 28/07/2003, 11:28
Avatar de mifune  
Fecha de Ingreso: junio-2003
Ubicación: BCNeta
Mensajes: 466
Antigüedad: 14 años, 6 meses
Puntos: 0
¿Te refieres a Lotus Notes? Bueno, puede que el problema sea de tu cliente y que no tenga bien configurado su cliente (valga la redundancia) de correo como predeterminado. Yo utilizo The Bat! y me abre todos los mailto sin problemas, incluso los que llevan subject y el cuerpo del mensaje. De igual forma, los otros programas de correo que he usado también lo hacían.

Saludos.
  #3 (permalink)  
Antiguo 28/07/2003, 11:32
 
Fecha de Ingreso: mayo-2003
Mensajes: 91
Antigüedad: 14 años, 6 meses
Puntos: 0
Hola Mifune.

Supongo que se trata de Lotus Notes. Varios coinciden en la configuración del explorador y creo que será ese el motivo del fallo.

Pero...¿se puede evitar que el cliente tenga que cofigurar el Lotus como predeterminado en el Explorer?

Gracias.
Isaac
__________________
Isaac González
http://twitter.com/IsaacGonzalez
  #4 (permalink)  
Antiguo 28/07/2003, 11:38
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
Hola Wino

de todas formas hay que tener en cuenta que si no le funciona el mailto a tu cliente (no el de correo, si no el que paga) en su cliente (haciendo eco a mifune reitero que valga la redondolla) el mismo problema lo va a tener con todas las páginas de internet que usen el mailto.

Es decir... no puedes hacer nada en la página, salvo usar una aplicación externa.

Más vale que el cliente (el que paga) configure su programa de correo como predeterminado y que pueda navegar tranquilamente enviando emails ¿no?
  #5 (permalink)  
Antiguo 28/07/2003, 11:42
 
Fecha de Ingreso: mayo-2003
Mensajes: 91
Antigüedad: 14 años, 6 meses
Puntos: 0
Tunait

Tienes razón pero el Cliente pretende tener algo lo suficientemente estandar como para que todos sus usuarios puedan visitar la web y entiéndeme...si al primero que le falla es a él...muy seguro de su prodcuto no va a estar.

Por eso pregunto si existe alguna forma de evitar modificar la configuración del Explorer
__________________
Isaac González
http://twitter.com/IsaacGonzalez
  #6 (permalink)  
Antiguo 28/07/2003, 11:45
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
Usar una aplicación externa para enviar el correo (asp, php, jsp, cgi....) y hacerlo desde un formulario.
  #7 (permalink)  
Antiguo 28/07/2003, 11:52
 
Fecha de Ingreso: mayo-2003
Mensajes: 91
Antigüedad: 14 años, 6 meses
Puntos: 0
Tunait.

No puedo hacer eso, la web ya cuenta con un formulario, este botón de mailto es un extra.

Un saludo
__________________
Isaac González
http://twitter.com/IsaacGonzalez
  #8 (permalink)  
Antiguo 28/07/2003, 11:57
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
Entonces dudo que puedas hacer otra cosa.

Un mailto lo que lo hace es preguntar al sistema operativo cuál es la aplicación predeterminada de correo electrónico.

Si no está especificada no reaccionará.

El problema está en el ordenador del cliente, desde página web no`puedes hacer más.

Por cierto, el tema no es configurar el explorer. Si usara Netscape le abriría el mismo cliente de correo. No es cuestión de configuración del navegador, si no del propio sistema operativo.
  #9 (permalink)  
Antiguo 28/07/2003, 22:57
 
Fecha de Ingreso: julio-2003
Mensajes: 17
Antigüedad: 14 años, 4 meses
Puntos: 0
Implementa un formulario

Creo que no tendras más opción que implementar un formulario.
Puedes hacer uno para que desde el link se abra, pero como popup, incluso lo puedes configurar para que aparezca a la vista el email del destinatario de modo que de la impresión del mailto.

Eso es lo más conveniente que se me ocurre que hagas en este caso.
El problema es que mailto no te puede cambiar la configuración de tu sistema con respecto a esto, pero en cambio un formulario del mismo sitio si puedes controlarlo para que sea más estandar en los sistemas no importa su configuración.

De todos modos si encuentras algún truco mejor sería bueno que lo postearas para saber como lo has solucionado.

Saludos
__________________
Paco Revilla
Espacio Linux
El mundo linux en un sólo espacio...
http://www.espaciolinux.com
  #10 (permalink)  
Antiguo 29/07/2003, 02:19
 
Fecha de Ingreso: mayo-2003
Mensajes: 91
Antigüedad: 14 años, 6 meses
Puntos: 0
Muchas gracias a todos.

Seguiré peleándome y si consigo alguna solución decente os digo algo.

Un saludo.
__________________
Isaac González
http://twitter.com/IsaacGonzalez
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:57.