Foros del Web » Creando para Internet » HTML »

mailto no funciona en explorer

Estas en el tema de mailto no funciona en explorer en el foro de HTML en Foros del Web. Hola a todos, Necesito hacer un formulario sencillo en html (sin usar php ni asp) y el Internet explorer no me acepta el método actio="mailto:..." ...
  #1 (permalink)  
Antiguo 11/05/2009, 03:41
 
Fecha de Ingreso: diciembre-2003
Mensajes: 435
Antigüedad: 14 años
Puntos: 5
Sonrisa mailto no funciona en explorer

Hola a todos,
Necesito hacer un formulario sencillo en html (sin usar php ni asp) y el Internet explorer no me acepta el método actio="mailto:...".
Me saca una página que dice que no se puede mostrar la página y en la barra de direcciones me pone mailto:[email protected]

Alguien me ayuda por favor????
  #2 (permalink)  
Antiguo 11/05/2009, 04:02
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.547
Antigüedad: 15 años, 8 meses
Puntos: 1262
Respuesta: mailto no funciona en explorer

Hola:

Suponiendo que tengas bien escrito el código (action="mailto:[email protected]") es raro lo que comentas, porque explorer reconoce muy bien el protocolo...

Tal vez exista algún error por otro lado que dé problemas... o tengas alguna mayúscula, o... en fin, si pones el tag form tal cual lo tienes en tu página, será mejor para buscar el problemm...

Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
  #3 (permalink)  
Antiguo 11/05/2009, 04:11
 
Fecha de Ingreso: diciembre-2003
Mensajes: 435
Antigüedad: 14 años
Puntos: 5
Respuesta: mailto no funciona en explorer

Os pongo el código para ver si podéis decirme algo:

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Documento sin t&iacute;tulo</title>
</head>

<body>


</HEAD>
<BODY>
<form action="mailto:[email protected]" method="post" name="Ejemplo">
Nombre: <input type="text" name="Nombre" maxlength="150" /><br />
<input type="submit" value="Enviar" name"boton" id="boton" />
</form>
</body>
</html>
Gracias otra vez
  #4 (permalink)  
Antiguo 11/05/2009, 04:17
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.547
Antigüedad: 15 años, 8 meses
Puntos: 1262
Respuesta: mailto no funciona en explorer

Hola:

En principio te sobra el método (no solo eso, sino que el método de los mailto es get)

Para mejorar el formulario, deberías quitar el atributo name del botón submit, porque es un parámetro que no tiene sentido, y para que sea más profesional, podrías poner un campo name="subject" con el asunto del formulario (verás que se autorellena en el gestor de correos el campo asunto...)

Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
  #5 (permalink)  
Antiguo 12/05/2009, 12:09
 
Fecha de Ingreso: diciembre-2003
Mensajes: 435
Antigüedad: 14 años
Puntos: 5
Respuesta: mailto no funciona en explorer

Cita:
Iniciado por caricatos Ver Mensaje
Hola:

En principio te sobra el método (no solo eso, sino que el método de los mailto es get)

Para mejorar el formulario, deberías quitar el atributo name del botón submit, porque es un parámetro que no tiene sentido, y para que sea más profesional, podrías poner un campo name="subject" con el asunto del formulario (verás que se autorellena en el gestor de correos el campo asunto...)

Saludos
sigo sin que el explorer me envíe el formulario ¿Nadie me puede ayudar?
form action="mailto:[email protected]" method="post" enctype="text/plain" name="miform">
<input type="Button" name="boton" value="pulsame">
</form>
  #6 (permalink)  
Antiguo 13/05/2009, 00:50
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.547
Antigüedad: 15 años, 8 meses
Puntos: 1262
Respuesta: mailto no funciona en explorer

Hola:

Sigues usando post, y el botón debería ser tipo submit:

Código:
<form action="mailto:[email protected]" name="miform">
<input type="submit" value="pulsame" />
<input type="hidden" name="subject" value="probamdo" />
</form>
Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:08.