Foros del Web » Creando para Internet » HTML »

Me muestra mal las palabras que tienen acento!

Estas en el tema de Me muestra mal las palabras que tienen acento! en el foro de HTML en Foros del Web. Hola, tengo una pagina que es puro html, css y jquery. Cuando no la subo al server se muestra perfecto, pero despues me muestra mal ...
  #1 (permalink)  
Antiguo 26/08/2010, 13:09
 
Fecha de Ingreso: febrero-2010
Mensajes: 36
Antigüedad: 7 años, 10 meses
Puntos: 0
Me muestra mal las palabras que tienen acento!

Hola, tengo una pagina que es puro html, css y jquery. Cuando no la subo al server se muestra perfecto, pero despues me muestra mal acentos y todo.
por ejemplo me pone: estratégico, o Inversión

les dejo parte del codigo html por si sirve para algo:
<code><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="es">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /></code>

Que esta pasando? que tengo que cambiar?
gracias
  #2 (permalink)  
Antiguo 26/08/2010, 13:17
Avatar de Omura
Colaborador
 
Fecha de Ingreso: julio-2006
Ubicación: Peru
Mensajes: 3.491
Antigüedad: 11 años, 5 meses
Puntos: 185
Respuesta: Me muestra mal las palabras que tienen acento!

puede que estés definiendo en la web el charset UTF-8 pero que las paginas estén con otro formato, prueba usando el Notepad++ y grabar las paginas como UTF-8.
__________________
Mi error era de código... pero de código genético.
  #3 (permalink)  
Antiguo 26/08/2010, 13:18
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Me muestra mal las palabras que tienen acento!

Cita:
Iniciado por shiolo10 Ver Mensaje
Hola, tengo una pagina que es puro html, css y jquery. Cuando no la subo al server se muestra perfecto, pero despues me muestra mal acentos y todo.
por ejemplo me pone: estratégico, o Inversión

les dejo parte del codigo html por si sirve para algo:
<code><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="es">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /></code>

Que esta pasando? que tengo que cambiar?
gracias
Verifique que en todo momento hay concordancia en el charset utilizado. Esto es, que utiliza el mismo tanto en la recogida de datos, su guardado en la bd y en la página donde los muestra posteriormente.

En este mismo foro tiene información más extensa y precisa sobre el particular. Ya se han abierto innumerables temas al respecto.

Atentamente
  #4 (permalink)  
Antiguo 26/08/2010, 13:23
 
Fecha de Ingreso: febrero-2010
Mensajes: 36
Antigüedad: 7 años, 10 meses
Puntos: 0
Respuesta: Me muestra mal las palabras que tienen acento!

no tengo bases de datos, donde puede no coincidir?
  #5 (permalink)  
Antiguo 26/08/2010, 13:31
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Me muestra mal las palabras que tienen acento!

Con lo de la base de datos me refería a una situación general y para ejemplificar lo de guardar la concordancia.

Ahora, que si el problema radica que en local lo ve bien y en el servidor mal (el mismo archivo), verifique con su hospedaje que tengan habilitada la codificación que usa, descartado que no se haya corrompido el archivo en el proceso de subida.

Atentamente

Por cierto, buen encuentro en la respuesta anterior, Omura.

Etiquetas: mal, muestra, palabras, acentos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:44.