Foros del Web » Creando para Internet » HTML »

No coge bien la ruta del header y del css en algunas paginas

Estas en el tema de No coge bien la ruta del header y del css en algunas paginas en el foro de HTML en Foros del Web. Hola. Estoy haciendo una página con joomla, la página lleva una cabecera en flash. Al abrir la página todo se ve bien, el flash se ...
  #1 (permalink)  
Antiguo 25/02/2009, 04:27
 
Fecha de Ingreso: junio-2008
Mensajes: 13
Antigüedad: 9 años, 5 meses
Puntos: 0
No coge bien la ruta del header y del css en algunas paginas

Hola.

Estoy haciendo una página con joomla, la página lleva una cabecera en flash.
Al abrir la página todo se ve bien, el flash se carga y también se carga el css, pero en cambio al abrir otra sección de la página ni se carga el flash, ni el css.

Tengo la página principal con una información y luego he creado artículos sin sección ni categoría y los he enlazado al menú principal y al pinchar en el articulo en el menú principal es cuando falla.

La página principal se queda mipagina.com, pero al entrar en un articulo se queda mipagina.com/index.php/empresa

He estado mirando el código fuente una vez se ha cargado la pagina y el problema esta en la ruta que coge cada página:

En la página principal lo coge correctamente:
<link rel="stylesheet" href="/templates/theme192/css/template.css" type="text/css" />
<object data="/templates/theme192/flash/header_v8.swf"

En la página del articulo lo coge así:
<link rel="stylesheet" href="/index.php/templates/theme192/css/template.css" type="text/css" />
<object data="/index.php/templates/theme192/flash/header_v8.swf"

El código del archivo en index.php es:

<object data="<?php echo $path ?>/flash/header_v8.swf"

Por lo que no entiendo a que se debe el que en una página cargue bien y en otra no, si se le ocurre a alguien que puede ser.

Gracias
  #2 (permalink)  
Antiguo 25/02/2009, 04:52
 
Fecha de Ingreso: junio-2008
Mensajes: 13
Antigüedad: 9 años, 5 meses
Puntos: 0
Respuesta: No coge bien la ruta del header y del css en algunas paginas

Cita:
Iniciado por poxito Ver Mensaje
Hola.

Estoy haciendo una página con joomla, la página lleva una cabecera en flash.
Al abrir la página todo se ve bien, el flash se carga y también se carga el css, pero en cambio al abrir otra sección de la página ni se carga el flash, ni el css.

Tengo la página principal con una información y luego he creado artículos sin sección ni categoría y los he enlazado al menú principal y al pinchar en el articulo en el menú principal es cuando falla.

La página principal se queda mipagina.com, pero al entrar en un articulo se queda mipagina.com/index.php/empresa

He estado mirando el código fuente una vez se ha cargado la pagina y el problema esta en la ruta que coge cada página:

En la página principal lo coge correctamente:
<link rel="stylesheet" href="/templates/theme192/css/template.css" type="text/css" />
<object data="/templates/theme192/flash/header_v8.swf"

En la página del articulo lo coge así:
<link rel="stylesheet" href="/index.php/templates/theme192/css/template.css" type="text/css" />
<object data="/index.php/templates/theme192/flash/header_v8.swf"

El código del archivo en index.php es:

<object data="<?php echo $path ?>/flash/header_v8.swf"

Por lo que no entiendo a que se debe el que en una página cargue bien y en otra no, si se le ocurre a alguien que puede ser.

Gracias
Ya lo he solucionado, desactivando en configuración del sitio url amigables para motores de búsqueda, lo único que no se porque en la página principal me busca header_v8 y en las demás header1_v8, pero bueno eso no es problema, la única duda que me queda, la única forma de que funcione bien es así? Lo digo porque al ser una pagina de una empresa, no es lo mismo que se quede mipagina.com/empresa que mi pagina.com/index.php?option=com_content&view=article&id=2&Ite mid=2.
Hay alguna forma de cambiar eso y que funcione bien o mejor me estoy quieto?
Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:45.