Foros del Web » Creando para Internet » HTML »

No funciona hipervinculo de capa con imagen en Internet Explorer...!!!

Estas en el tema de No funciona hipervinculo de capa con imagen en Internet Explorer...!!! en el foro de HTML en Foros del Web. Que tal amigos, ahora molestando en HTML. Lo busque en las FAQ's pero no encontre nada parecido, este es el problema: Dentro de una capa ...
  #1 (permalink)  
Antiguo 24/05/2008, 00:41
 
Fecha de Ingreso: mayo-2008
Mensajes: 26
Antigüedad: 9 años, 7 meses
Puntos: 1
No funciona hipervinculo de capa con imagen en Internet Explorer...!!!

Que tal amigos, ahora molestando en HTML. Lo busque en las FAQ's pero no encontre nada parecido, este es el problema:

Dentro de una capa he colocado 3 capas mas y en una de ella hay una imagen. Ahora a esa capa contenedora la hice hipervinculo, cosa que al ubicarse sobre la capa contenedora me lleve a la dirección indicada.

La idea es que al ubicar el puntero y hacer clic sobre la capa o su contenido active el hipervínculo, en Firefox me funciona correctamente, el problema es en IE al ubicarme sobre la imagen cambia el puntero pero no funciona el hipervinculo.

El codigo:

Código HTML:
<a href="profile.php">
   <div id="contenedor" style="padding:5px; cursor:pointer;">
       <div style="padding:2px">Texto</div>
       <div style="padding:2px">Otro Texto</div>
       <div style="padding:2px"><img src="photos/foto.jpg"></div>
</div>
</a> 
Espero me puedan ayudar

Saludos...
  #2 (permalink)  
Antiguo 24/05/2008, 01:09
Avatar de pateketrueke
Modernizr
 
Fecha de Ingreso: abril-2008
Ubicación: Mexihco-Tenochtitlan
Mensajes: 26.399
Antigüedad: 9 años, 8 meses
Puntos: 2526
Respuesta: No funciona hipervinculo de capa con imagen en Internet Explorer...!!!

te digo algo... esto es inconcebible....

<a> es un elemento inline, osea... de linea y NO puedes (no deberias) meter dentro un elemento block, de bloque.... (ya sea div/p/etc..)

es urgente que estudies de nuevo el manual de HTML, porque quiza... si te funcione, pero NO deberias hacer esto... al menos no, hasta que sepas lo que haces

EDITO: puse tu ejemplo al validador y arrojo en esto, no lo traduzco pero que quede claro... sobre advertencia NO hay engaño

Document type does not allow element ... here; missing one of ... start-tag

...

There are 2 types of elements in the body of a HTML file, inline and block elements. One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "<a>", "<span>", or "<font>").
__________________
Y U NO RTFM? щ(ºдºщ)

No atiendo por MP nada que no sea personal.
  #3 (permalink)  
Antiguo 24/05/2008, 13:41
(Desactivado)
 
Fecha de Ingreso: febrero-2008
Ubicación: Argentina, Santa Fe, Rosario
Mensajes: 350
Antigüedad: 9 años, 9 meses
Puntos: 5
Respuesta: No funciona hipervinculo de capa con imagen en Internet Explorer...!!!

Yo creo que el vínculo no puede ser un "DIV"

Podrías corregir el código de la siguientes maneras:

Código HTML:
 <div id="contenedor" style="padding:5px; cursor:pointer;">
       <div style="padding:2px"><a href="profile.php">Texto</a></div>
       <div style="padding:2px"><a href="profile.php">Otro Texto</a></div>
       <div style="padding:2px"><a href="profile.php"><img src="photos/foto.jpg"></a></div>
</div> 
Salu2
  #4 (permalink)  
Antiguo 24/05/2008, 21:50
 
Fecha de Ingreso: mayo-2008
Mensajes: 26
Antigüedad: 9 años, 7 meses
Puntos: 1
Respuesta: No funciona hipervinculo de capa con imagen en Internet Explorer...!!!

Gracias, amigos....

Ahora nose si alguien me podria explicar porque si funciona en Firefox ya que en IE ya esta dicho cual es la causa.


Cita:
Iniciado por MRB08 Ver Mensaje
Yo creo que el vínculo no puede ser un "DIV"

Podrías corregir el código de la siguientes maneras:

Código HTML:
 <div id="contenedor" style="padding:5px; cursor:pointer;">
       <div style="padding:2px"><a href="profile.php">Texto</a></div>
       <div style="padding:2px"><a href="profile.php">Otro Texto</a></div>
       <div style="padding:2px"><a href="profile.php"><img src="photos/foto.jpg"></a></div>
</div> 
Salu2
Al probar esto no sucede lo que deseo, que al ubicar el puntero sobre cualquier zona de la capa contenedora (incluso si esta vacio), y hacer clic se active el hipervinculo hacia la pagina indicada.

Alguien sabe como se pueda solucionar este problemam, tomando en cuenta las apreciaciones de panteketrueque.

Saludos..

Última edición por rivahuevino; 24/05/2008 a las 22:04 Razón: Citar a MRB08
  #5 (permalink)  
Antiguo 25/05/2008, 16:14
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: No funciona hipervinculo de capa con imagen en Internet Explorer...!!!

Prueba con esto:

Cita:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="es-es">
<head>
<title></title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<style type="text/css">
#contenedor {padding:5px; cursor:pointer;display:block;}
.enlace {padding:2px;display:block;}
</style>
</head>
<body>
<a href="profile.php">
<span id="contenedor">
<span class="enlace">Texto</span>
<span class="enlace">Otro Texto</span>
<span class="enlace"><img src="photos/foto.jpg" /></span>
</span>
</a>
</body>
</html>
Mikel.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:22.