Foros del Web » Creando para Internet » HTML »

no me funciona un href en una función

Estas en el tema de no me funciona un href en una función en el foro de HTML en Foros del Web. hola, a ver si alguien me puede decir dónde está el fallo: Tengo el siguiente código: <a href="javascript :void(null)" onclick="javascript :validar_formulario()"><img src="imagenes/enviar.gif" border="0" align="right" onclick=""></a> ...
  #1 (permalink)  
Antiguo 21/05/2003, 10:53
 
Fecha de Ingreso: diciembre-2002
Mensajes: 17
Antigüedad: 15 años
Puntos: 0
no me funciona un href en una función

hola, a ver si alguien me puede decir dónde está el fallo:

Tengo el siguiente código:

<a href="javascript:void(null)" onclick="javascript:validar_formulario()"><img src="imagenes/enviar.gif" border="0" align="right" onclick=""></a>

y la función contiene lo siguiente:

function validar_formulario(){
//Aqui tengo la validación de los campos del formulario
window.location.href="otrapagina.html";
}

El caso es que no me funciona el href de la función, y necesito por otros temas que no se llame a la página en el href original.
También he probado con :
document.formulario.action=otrapagina.html'; pero tampoco funciona.
Gracias
  #2 (permalink)  
Antiguo 21/05/2003, 11:06
Avatar de Cain  
Fecha de Ingreso: enero-2002
Ubicación: Catalunya
Mensajes: 6.459
Antigüedad: 15 años, 11 meses
Puntos: 17
document.formulario.action='otrapagina.html'

Debería funcionar, siempre que el formulario se llame formulario.

Esto: window.location.href="otrapagina.html";

Sustitúyelo por esto:
document.location.replace('otrapagina.html');
__________________
M a l d i t o F r i k i
  #3 (permalink)  
Antiguo 21/05/2003, 11:17
 
Fecha de Ingreso: diciembre-2002
Mensajes: 17
Antigüedad: 15 años
Puntos: 0
NO ME FUNCIONA UN HREF!!!

Sigue sin funcionar!!! a ver, he cortado la casi toda la página y he dejado sólo esto:

En la página:

<html>
<head>
<title>Untitled</title>
<SCRIPT LANGUAGE="JavaScript" TYPE="text/javascript" src="estonufunciona.js"></SCRIPT>
</head>
<body>
<table cellspacing="0" cellpadding="0" border="0" align="center" width="480">
<tr>
<td><img src="imagenes/shim.gif" border="0" height="1" width="14"></td>
<td><a href="javascript:void(null)" onclick="javascript:validar_formulario()"><img src="imagenes/enviar.gif" border="0" align="right"></a></td>
</tr>
</table>

En el js:

function validar_formulario(){
document.location.replace("vercomentarios.html");
}
</body>
</html>

A ver si el código os dice algo, porque lo que es a mí, no me dice ni mu
POR QUÉ NO FUNCIONA????
  #4 (permalink)  
Antiguo 21/05/2003, 11:23
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.547
Antigüedad: 15 años, 8 meses
Puntos: 1262
Hola lgcarrasco:

Cuando usas "eventos" no debes poner javascript...

onclick="javascript:validar_formulario()" mal

onclick="validar_formulario()" bien

También puedes poner un action en un formulario, pero seguidamente debes hacer el submit...

location.href="vercomentarios.html"...

Espero que te sirva.

Saludos
  #5 (permalink)  
Antiguo 21/05/2003, 11:47
 
Fecha de Ingreso: diciembre-2002
Mensajes: 17
Antigüedad: 15 años
Puntos: 0
NO FUNCIONA!

Nada de nada, ni con formulario ni sin él, ni con submit ni sin él, nada de nada, NO FUNCIONA!!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:55.