Foros del Web » Creando para Internet » HTML »

No funciona el include virtual ni el file

Estas en el tema de No funciona el include virtual ni el file en el foro de HTML en Foros del Web. Tengo un problema estoy intentado incluir una plantilla a mi web con include virtual o file cualquiera de los dos, el archivo que quiero incluir ...
  #1 (permalink)  
Antiguo 20/09/2006, 09:27
Avatar de mousi  
Fecha de Ingreso: septiembre-2006
Mensajes: 94
Antigüedad: 11 años, 3 meses
Puntos: 1
No funciona el include virtual ni el file

Tengo un problema estoy intentado incluir una plantilla a mi web con include virtual o file cualquiera de los dos, el archivo que quiero incluir es html, pongo el codigo <!--#include virtual="/enlaces/enlaces.html" --> y en tiempo de diseño veo que si la inserta pero a la hora que lo veo en el explorador no aparece.. pueden ayudarme que puedo hacer?
  #2 (permalink)  
Antiguo 20/09/2006, 09:48
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Lo que estás usando no es PHP sino SSI (Server Side Include) ..

No ha foro exclusivo para SSI .. pero voy a mover el tema al foro de HTML para empezar (aunque tal vez en el de CGI te puedan asesorar también).

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 20/09/2006, 12:11
Avatar de Rafael
Modegráfico
 
Fecha de Ingreso: marzo-2003
Mensajes: 8.954
Antigüedad: 14 años, 9 meses
Puntos: 1802
Un SSI no lo puedes ver en el navegador simplemente. Tienes que tener instalado el apache y configurado para interpretar SSI.

Después activas el apache y lo lees como localhost, no haciendole click.

Si lo subes a tu host, y lo soporta simplemente configura bien la ruta.

Otra cosa, confirma que tu extensión sea archivo.shtml
  #4 (permalink)  
Antiguo 22/09/2006, 06:35
 
Fecha de Ingreso: junio-2004
Mensajes: 616
Antigüedad: 13 años, 6 meses
Puntos: 25
prueba a grabarlo como shtml

jeje... La mayoría de los servidores web tienen activado el módulo de SSI

Pero sólo lo preprocesan cuando la extensión es shtml.

Prueba si cambiandole la extensión te funciona.

Un saludo de,
eContento
__________________
eContento
- Mis artículos, tutoriales y labs
- Mis jsfiddles
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:30.