Foros del Web » Creando para Internet » HTML »

No me funciona que sera??????

Estas en el tema de No me funciona que sera?????? en el foro de HTML en Foros del Web. Hola amigos subi una imagen con extencion "png" la coloque en el directorio "menu" en mi servidor web y en el codigo html coloco la ...
  #1 (permalink)  
Antiguo 28/06/2003, 16:46
 
Fecha de Ingreso: junio-2003
Ubicación: Boston USA
Mensajes: 226
Antigüedad: 14 años, 6 meses
Puntos: 0
Exclamación [Resuelto] No me funciona que sera??????

Hola amigos subi una imagen con extencion "png" la coloque en el directorio "menu" en mi servidor web y en el codigo html coloco la siguiente instrucciojn pero no me sale la imagen que sera?
apesar de que le cambio la extension pesnado que no me reconoce el formato "png" renombro el archivo y lo coloco como "gif" o "jpg" solo estoy colocando una parte del codigo que creo es la parte en donde radica el problema.

esta es la linea de codigo que tengo en mi web

<TD align=left>
<font size="1" face="arial">
<a href="http://www.lycos.com/joss/pagina2.html" target="pagina2"><img border="0" src="http://www.lycos.com/joss/menu/Home.gif" width="120" height="19"></a><br></TD></TR>

ayuda please!!!!!
__________________
Pandobox

Última edición por KarlanKas; 30/06/2003 a las 04:25
  #2 (permalink)  
Antiguo 28/06/2003, 16:51
 
Fecha de Ingreso: abril-2002
Ubicación: Medellín, Colombia
Mensajes: 436
Antigüedad: 15 años, 8 meses
Puntos: 0
Será la imagen... http://www.lycos.com/joss/menu/Home.gif << La imagen no existe en el servidor...

Mira que esté bien toda la ruta que eso debe ser.

Saludos
__________________
juanej
  #3 (permalink)  
Antiguo 28/06/2003, 19:03
Avatar de Bravenap  
Fecha de Ingreso: noviembre-2002
Ubicación: Los Arroyos, El Escorial, Madrid
Mensajes: 2.084
Antigüedad: 15 años, 1 mes
Puntos: 4
Vamos a ver pandobox, dices que primero tenías la imagen como PNG pero que como no te reconocía el archivo lo renombraste a JPG o GIF. No se trata de renombrar el archivo sino de guardar la imagen con un nuevo formato. Pero bueno, supongo que será eso lo que has hecho.

En segundo lugar veo que tienes puesta una ruta absoluta para tu imagen. ¿Por qué no pruebas con una ruta relativa?

Si la página está en el directorio principal y la imagen en una subcarpeta llamada menu, simplemente has de hacer esto:

<a href="pagina2.html" target="pagina2">
<img border="0" src="menu/Home.gif" width="120" height="19">
</a>

Si te acostumbras a poner direcciones absolutas, el día que tengas que cambiar la página de servidor o meterla en una nueva carpeta te tocará cambiar todas las rutas de imágenes, enlaces, archivos relacionados, ....

Veo también que la imagen se llama Home.gif y, aunque no tenga porqué influir en nada, yo no suelo poner mayúsculas en el nombre de los archivos.

Finalmente, y ya por incordiar un poco , tienes una etiqueta <font> abierta pero no está cerrada y además no hay ningún texto por lo que no la necesitarías.

Y ya que estamos para tener un código más limpio acostumbro a poner todas las etiquetas HTML o bien en mayúsculas o bien en minúsculas, pero no las dos a la vez.

Espero haberte ayudado en algo.

Hala, un saludo.
__________________
¡¡NO A LA GUERRA!!
Si ponemos a nuestros mensajes títulos adecuados, la gente se animará más a abrirlos y resultarán más útiles en las busquedas. ¡No a los ayuuudaaa, urgenteee y similares!
  #4 (permalink)  
Antiguo 29/06/2003, 23:57
 
Fecha de Ingreso: junio-2003
Ubicación: Boston USA
Mensajes: 226
Antigüedad: 14 años, 6 meses
Puntos: 0
Gracias!!!!

Gracias amigos por sus sugerencias todo quedo resuelto y andando al pelo!!!!

Un para todos!!

Hasta la proxima
__________________
Pandobox
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:46.