Foros del Web » Creando para Internet » HTML »

No mostrar paso de variables

Estas en el tema de No mostrar paso de variables en el foro de HTML en Foros del Web. Hola, Es algo muy sencillo, que seguro que se puede controlar. Tengo una pagina como esta: Código PHP: <! DOCTYPE HTML  PUBLIC  "-//W3C//DTD HTML 4.01 Transitional//EN" > < html ...
  #1 (permalink)  
Antiguo 09/09/2003, 11:02
 
Fecha de Ingreso: mayo-2003
Mensajes: 125
Antigüedad: 14 años, 7 meses
Puntos: 0
Sonrisa No mostrar paso de variables

Hola,

Es algo muy sencillo, que seguro que se puede controlar.

Tengo una pagina como esta:

Código PHP:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<
html>
<
head>
    <
title>Untitled</title>
</
head>

<
body>
<
form action="http://www.pagina.com/control.php" enctype="multipart/form-data" name="prueba" id="prueba" target="_blank">
<
table cellspacing="0" cellpadding="0" border="0" align="center" style="background-color:#F4F4F4;">
    <
tr>
        <
td style="vertical-align:middle; padding-left:8px;"><strong>Usuario:</strong></td>
        <
td><input type="text" name="usuario" style="width:120px;" /></td>
    </
tr>
    <
tr>
        <
td style="vertical-align:middle; padding-left:8px;"><strong>Clave:</strong></td>
        <
td><input type="password" name="clave" value="" style="width:120px;" /></td>
    </
tr>
    <
tr>
        <
td colspan="2" align="right" style="padding:7px; padding-right:10px;">
        <
input type="image" src="../img/enviar.gif" width="42" height="15" alt="" border="0" /></td>
    </
tr>
</
table>
</
form>


</
body>
</
html
Como veis es una página sencilla, con un formulario que recoge usuario y contraseña y se lo pasa por post a otra página abriendola en una ventana nueva del navegador.

Lo curioso es que abre la pagina bien pero mostrando los parametros de usuario y clave en la url, cosa que no quiero que ocurra.

Código PHP:
http://www.pagina.com/control.php?usuario=nombre_usuario&clave=clave&x=17&y=8 
Dos preguntas:

1.- ¿Por qué los muestra si los paso por post?
2.- ¿Cómo puedo evitarlo o enmascararlo?

Muchas gracias,
__________________
Lailuluelo
El error está en lo obvio
  #2 (permalink)  
Antiguo 10/09/2003, 02:37
Avatar de KarlanKas
Moderador extraterrestre
 
Fecha de Ingreso: diciembre-2001
Ubicación: Madrid
Mensajes: 6.987
Antigüedad: 16 años
Puntos: 60
Hola lailuluelo!!
Me temo que no los pasas por POST. El método por defecto es GET y si no dices nada (como veo uqe haces en el código que nos facilitas) pues lo envía por ese método. Prueba a poner en tu etiqueta FORM:

<FORM METHOD="post"...

Un saludo!!
__________________
Cómo escribir

No hay pregunta tonta, sino tonto que quiere seguir en la ignorancia.
  #3 (permalink)  
Antiguo 10/09/2003, 02:52
 
Fecha de Ingreso: mayo-2003
Mensajes: 125
Antigüedad: 14 años, 7 meses
Puntos: 0
El error está en lo obvio

Pues tienes toda la razón. Estaba convencido de que lo pasaba por "post" y así lo decia en el mensaje pero una de dos:

1.- O lo borre por error.
2.- Estoy ciego.

Muchas gracias amigo,
__________________
Lailuluelo
El error está en lo obvio
  #4 (permalink)  
Antiguo 10/09/2003, 11:58
Avatar de acervantes  
Fecha de Ingreso: agosto-2003
Ubicación: Madrid
Mensajes: 311
Antigüedad: 14 años, 4 meses
Puntos: 1
por eso muchas veces, resulta tal vez hasta tedioso poner los defaults, pero como que al final nos ahorra tiempo no?
__________________
ACervantes

[El éxito dura hasta que alguien las caga; los errores son eternos]
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:04.