Foros del Web » Creando para Internet » HTML »

no se por que no me valida el 3w.org

Estas en el tema de no se por que no me valida el 3w.org en el foro de HTML en Foros del Web. tengo esta web www.motoralbet.com/motoralbet (esta en catalan) pero cuando intento validar www.motoralbet.com/motoralbet/ofertes.asp no me valida bien me pone http://validator.w3.org/check?uri=ht...Inline&group=0 no se que puede fallar alguien ...
  #1 (permalink)  
Antiguo 20/08/2007, 03:09
Avatar de engonga  
Fecha de Ingreso: marzo-2002
Ubicación: Córdoba
Mensajes: 1.299
Antigüedad: 15 años, 8 meses
Puntos: 8
no se por que no me valida el 3w.org

tengo esta web

www.motoralbet.com/motoralbet (esta en catalan)

pero cuando intento validar

www.motoralbet.com/motoralbet/ofertes.asp


no me valida bien me pone

http://validator.w3.org/check?uri=ht...Inline&group=0

no se que puede fallar


alguien sebe porque?


gracias de antemano
__________________
joan blanch
  #2 (permalink)  
Antiguo 20/08/2007, 03:37
 
Fecha de Ingreso: abril-2007
Mensajes: 232
Antigüedad: 10 años, 7 meses
Puntos: 2
Re: no se por que no me valida el 3w.org

Hola:
el total validator de firefox indica estos problemas, el número es la línea en el que aparece (la línea en el código de la página descargada del servidor):




67 The 'bgcolor' attribute does not have a valid value: It must be a recognised color or color definition:
<td width="600" height="300" valign="top" bgcolor="#FFFFFF" class="borde_1px_menus_v">




81 Found '&' within 'href'. You should use '&amp;' instead:
<a href="ofertes.asp?detall=si&oferta=14" class="normal">
81 TALLAGESPA HONDA




88 next problemprevious problemE007 Found '&' within 'href'. You should use '&amp;' instead:
<a href="ofertes.asp?detall=si&oferta=22" class="normal">
88 STIHL MS 200 T




95 Found '&' within 'href'. You should use '&amp;' instead:
<a href="ofertes.asp?detall=si&oferta=23" class="normal">
95 oferta de prova




128 Problem with link: Not Found
<a class="text_peu" href="[email protected]">
128 [email protected]



Suerte. Jorge H.
  #3 (permalink)  
Antiguo 20/08/2007, 16:38
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Re: no se por que no me valida el 3w.org

^Engonga^

Hay entidades que validan W3C (por ejemplo) y herramientas que validan. Que son cosas bien diferentes. Si se usa la segunda hay que cerciorase siempre de que funcione correctamente y que esté debidamente configurada.

Siempre es recomendable (aunque no niego que herramientas con la extensión Web Developer de Firefox son excelentes!!!) validar desde la página de la W3C, en este caso en particular

a la 18.26 de buenos aires/argentina, si utilizas
http://validator.w3.org/check?uri=ht...Inline&group=0

y

http://validator.w3.org/check?uri=ht...Inline&group=0

arrojan ambas un
This Page Is Valid XHTML 1.0 Transitional!

Te recuerdo que al validar el validador de W3C controla los ERRORES y no las ADVERTENCIAS. En tu caso estas páginas tienen varias advertencias, en su mayoría por la falta del atributo "summary" en las tablas. (estás advertencias aparecen al utilizar el validador interno que incluye la extension WD de firefox 2)

en definitiva, TUS PAGINAS SON 100% válidas
ah, para terminar, en algunos casos, generalmente por problemas temporales en la red, hasta el validador puede fallar.

saludos
  #4 (permalink)  
Antiguo 20/08/2007, 17:06
Avatar de engonga  
Fecha de Ingreso: marzo-2002
Ubicación: Córdoba
Mensajes: 1.299
Antigüedad: 15 años, 8 meses
Puntos: 8
Re: no se por que no me valida el 3w.org

graciaspero ya encontre el error.

era que en las variables ponia ofertes.as?mostra=si&oferta=123

y tenia que poner el &amp;


solucionado
__________________
joan blanch
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:23.