Foros del Web » Creando para Internet » HTML »

No veo las imagenes en mi HTML

Estas en el tema de No veo las imagenes en mi HTML en el foro de HTML en Foros del Web. Hola a todos/as, aprendiendo html, programación web y todo lo relacionado. Para eso, me subscrbi a un servicio de hosting gratuito. Ahora bien, estuve leyendo ...
  #1 (permalink)  
Antiguo 10/11/2005, 12:22
 
Fecha de Ingreso: enero-2004
Ubicación: Montevideo
Mensajes: 58
Antigüedad: 13 años, 10 meses
Puntos: 0
Pregunta No veo las imagenes en mi HTML

Hola a todos/as, aprendiendo html, programación web y todo lo relacionado. Para eso, me subscrbi a un servicio de hosting gratuito. Ahora bien, estuve leyendo como insertar imagenes u otros html, en mi index.html.
Estuve buscando dentro del foro, sobre esta pregunta específica, pero no encontré nada. El asunto es el siguiente: si pongo la ruta relativa donde están los archivo de imagen, no salen, debo poner la ruta absoluta, ahí sí se ven. Lo mismo pasa para las referencias a otros archivos htm que quiero 'enlazar'. No tengo idea de cual puede ser el motivo, porque si entendí bien, con la ruta relativa sería suficiente.
Por ahora uso el composer del Mozilla, word, o OpenOffice para crear los archivos, luego iré a lo visual.
Les agradezco cualquier sugerencia, saludos
  #2 (permalink)  
Antiguo 10/11/2005, 12:45
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.544
Antigüedad: 15 años, 8 meses
Puntos: 1262
Hola:

Pueden pasarte muchas cosas... y tendrás que hacer algunas pruebas hasta encontrar la solución.

Si estás acostumbrado a windows puede que tengas que invertir las barras en las rutas (cambiar \ por /)...

¿Tienes instalado un servidor en tu máquina?

Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
  #3 (permalink)  
Antiguo 10/11/2005, 13:12
 
Fecha de Ingreso: enero-2004
Ubicación: Montevideo
Mensajes: 58
Antigüedad: 13 años, 10 meses
Puntos: 0
Hola gracias por tu pronta respuesta. No tengo un servidor en mi máquina, uso un servidor de alojamiento gratuito, no se si eso responde tu pregunta. En cuanto a lo de las barras, las pongo / , (manejo linux tb), no probé hacerlo de la otra forma \.

Ejemplo: tengo las imagenes en una subcarpeta imagenes.
Lo puse de las 2 formas: imagenes/imag.jpeg o /imagenes/imag.jpeg, y ninguna anduvo. Solo funciona con http://nombredeMiSitio/imagenes/imag.jpeg
(Lo mismo para enlazar los archivos html), no se que otras cosas investigar.

saludos, kovi
  #4 (permalink)  
Antiguo 10/11/2005, 13:15
Avatar de leoj90
Usuario baneado!
 
Fecha de Ingreso: agosto-2005
Mensajes: 1.365
Antigüedad: 12 años, 4 meses
Puntos: 0
Jpeg? Será x eso... formatos de imágenes son: Jpg, Gif y Png... Jpeg no se usa, se usa la extension jpg.
  #5 (permalink)  
Antiguo 10/11/2005, 13:20
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Hola kovicic

¿Puedes poner un enlace a tu página para echarle un ojo (o dos)?

Saludos,
  #6 (permalink)  
Antiguo 10/11/2005, 13:40
Avatar de webosiris
Moderador egiptólogo
 
Fecha de Ingreso: febrero-2002
Ubicación: Luxor, Egipto
Mensajes: 10.727
Antigüedad: 15 años, 9 meses
Puntos: 997
Sin duda que FdW está saturado... escribí un mensaje y salió 4º veces, fuí a borrar los otros 3 y me borró todos de un saque, perdiendo la info... bufff, aquí vamos de nuevo:

Cita:
Iniciado por leoj90
Jpeg? Será x eso... formatos de imágenes son: Jpg, Gif y Png... Jpeg no se usa, se usa la extension jpg.
jpEg es totalmente válido, es más, si me apurás te diría que es hasta más correcto que .jpg... de igual manera que es "más mejor" html que htm... además la uta absoluta funciona, así que como ves no tiene nada que ver con la extensión.

kovicic, por lo que contás llegué a esta conclusión:
tu problema está en las rutas relativas

2 cosas:
¿qué extructura tiene el sitio?
copiá aquí la parte de código problemático...

aunque lo mejor sería verlo "en acción"...

PD: que bueno que hay otro montevideano en el foro...
__________________
Pasamos tus PSD a HTML

Pobre del que lo sabe todo, porque no tiene nada más que aprender ni razón para vivir. -

Última edición por webosiris; 10/11/2005 a las 13:51
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:06.