Foros del Web » Creando para Internet » HTML »

Php y CSS

Estas en el tema de Php y CSS en el foro de HTML en Foros del Web. Buenas, tengo un problemas al combinar la potencia de php, con la de los CSS, Resumiendo, he creado una pagina formada por una serie de ...
  #1 (permalink)  
Antiguo 31/05/2004, 03:59
 
Fecha de Ingreso: abril-2003
Mensajes: 260
Antigüedad: 14 años, 7 meses
Puntos: 0
Php y CSS

Buenas, tengo un problemas al combinar la potencia de php, con la de los CSS,

Resumiendo, he creado una pagina formada por una serie de capas, las capas se posicionan y se alinean perfectamente, tanto para Iexplorer, como para mozilla...

hasta aqui, todo genial...para reutilizar codigo, y hacer la programacion mas sencilla, tipo "Frames", he eliminado la capas de la pagina principal y las he definido en fichero a parte, q incluyo con "require_once("menu/menu2.php");"

El problema es, q con mozilla, el poscionamieno de las capas es correcto, igual q antes de definir las capas, en el otro fichero, pero en IExplorer se mueven las capas, y no quedan bien alineadas....
Gracias de antemano..
__________________
Salut i Força al Canut
  #2 (permalink)  
Antiguo 31/05/2004, 08:11
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Justamente PHP no define nada sobre tus CSS ni HTML ni javascript que puedas usar (entre otros) lenguajes/propiedades del lado del "cliente" (en tu navegador) ..

Si tienes problemas de "visualización" o "compatibilidad" de esos CSS empleados o similar .. debes resolverlos en esos foros (pon el código que generas con tus páginas "PHP" cuando preguntes en el foro HTML al cual muevo tu pregunta (y de ahí si usas campas desde CSS ya lo moveran si corresponde)

Un saludo,
  #3 (permalink)  
Antiguo 01/06/2004, 02:35
 
Fecha de Ingreso: abril-2003
Mensajes: 260
Antigüedad: 14 años, 7 meses
Puntos: 0
ok, muchas gracias

Ya tengo la solucion y si no me equivoco, es un pequeño problema de PHP, aunque mas que un problema, ha sido un desconocimiento mio...
En realidad, bastaba con colocar la llamada "require_once("cabecera/cabecera.php");" en el lugar exacto donde se deberia colocar la correspondiente Capa. Mi fallo, era que hacia todas las llamadas, require_once(""); al principio de mi php, y entonces las capas no estaban alineadas correctamente....
Muchs gracias de todas formas
__________________
Salut i Força al Canut
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:45.