Foros del Web » Creando para Internet » HTML »

php windows <> php mac/os x?

Estas en el tema de php windows <> php mac/os x? en el foro de HTML en Foros del Web. ola tios, e creado una web en php q se ve de puta madre en windows, pero en mac/os x se ve mal, alguien podria ...
  #1 (permalink)  
Antiguo 08/10/2003, 05:19
Avatar de sith  
Fecha de Ingreso: julio-2003
Ubicación: Sevilla
Mensajes: 333
Antigüedad: 14 años, 4 meses
Puntos: 0
php windows <> php mac/os x?

ola tios, e creado una web en php q se ve de puta madre en windows, pero en mac/os x se ve mal, alguien podria decirme xq?
  #2 (permalink)  
Antiguo 08/10/2003, 05:31
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 6 meses
Puntos: 16
Hola,

¿Se ve mal? Si solo se ve mal, puede ser simplemente que el HTML se ve distinto en el navegador de Mac que en el de windows. Hay paginas que se ven distinto en distintos navegadores en el mismo sistema operativo.

Mira, compara el HTML generado en ambos navegadores. Si el codigo HTML es el mismo, es que PHP esta generando la misma salida, y la culpa de que se vean distinto es de cada navegador (¡Viva los standardes!).

Por cierto, si lo que dices es solo ver desde ese sistema operativo, y no tener el servidor en distintos sistemas operativos, entonces seguro que es culpa de los navegadores. PHP es culpable. Si el fichero PHP esta en el mismo servidor en los dos casos, es culpa de que el HTML (o Javascript) generado no es interpretado igual por los disitntos navegadores.

Y si ese es el caso, lo mejor seria mover este mensaje al foro de HTML.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 08/10/2003, 15:25
Avatar de sith  
Fecha de Ingreso: julio-2003
Ubicación: Sevilla
Mensajes: 333
Antigüedad: 14 años, 4 meses
Puntos: 0
ola tio, pues si la web esta en un servidor, lunux red hat, x si interesa, y en win la pag se ve puta madre, pero en mac/os x se ve movida las cosas, creo q puede ser por el uso de capas, aunq se ven movida asta las cosas de dentro de la capa, x cierto las animaciones en flash se ven + lentas, y los power pc q tenemos son la leche, tienen incluso 1 gb de ram, y no se tio man pedio una explicación y no se que decirles, ya les dije q debia ser del navegador, pero ntonces me dijeron q lo configurara para q se viese bien
  #4 (permalink)  
Antiguo 08/10/2003, 15:37
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 6 meses
Puntos: 16
Bueno, esta claro que es "culpa" de los navegadores.

Entonces te lo muevo a HTML, a ver si alli te pueden decir como "unificar" el HTML para que se vea "decentemente" en ambos. Por cierto, seria mejor que dijeses que versiones de navegadores usas y un link a la pagina para que vean el HTML.

Saludos desde PHP.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 10/10/2003, 04:32
Avatar de sith  
Fecha de Ingreso: julio-2003
Ubicación: Sevilla
Mensajes: 333
Antigüedad: 14 años, 4 meses
Puntos: 0
pues si, en windows usamos internet explorer 6 y en mac/os X usamos sobre todo internet explorer 5.2, aunque de vez n cuandao veo q alguno usa netscape, safari y opera
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:47.