Foros del Web » Creando para Internet » HTML »

porque en firefox esto y en IE otra cosa???

Estas en el tema de porque en firefox esto y en IE otra cosa??? en el foro de HTML en Foros del Web. Hola a todos!!! bueno tengo una pregunta que me está llevando a impulzar cualquier navegador que muestre las cosas como son y no como se ...
  #1 (permalink)  
Antiguo 27/09/2005, 14:59
Avatar de JALF  
Fecha de Ingreso: septiembre-2004
Ubicación: Cali - Colombia
Mensajes: 634
Antigüedad: 13 años, 3 meses
Puntos: 2
porque en firefox esto y en IE otra cosa???

Hola a todos!!!
bueno tengo una pregunta que me está llevando a impulzar cualquier navegador que muestre las cosas como son y no como se le dé la gana!!!!

Bueno estoy haciendo un diseño y resulta y acontece que en PhotoShop saque un color en Hexadedimal un verdesito #ABBC73 y pues resulta que en FireFox, Mozila, Netscape 7 y 8 e incluso en Opera me muestran el color que en realidad es, tal cual como yo lo he indicado, pero en el MALDITO Internet Explorer me muestra un verde más claro????

Alguien sabe porque pasa esto??? será que hay alguna forma de evitar que esto pase y que no sea sustituyendo el color por una imagen????
__________________
Ubuntu User # 15554
http://dubaiphp.wordpress.com/ -Mi vida de desarrollo, juegos y algo más en un Blog-
  #2 (permalink)  
Antiguo 27/09/2005, 15:46
 
Fecha de Ingreso: febrero-2004
Ubicación: santiago
Mensajes: 24
Antigüedad: 13 años, 9 meses
Puntos: 0
puedes poner el codigo por que yo lo probe y se ve igual en ambos casos
  #3 (permalink)  
Antiguo 28/09/2005, 20:07
Avatar de JALF  
Fecha de Ingreso: septiembre-2004
Ubicación: Cali - Colombia
Mensajes: 634
Antigüedad: 13 años, 3 meses
Puntos: 2
Cita:
Iniciado por josepena
puedes poner el codigo por que yo lo probe y se ve igual en ambos casos
hola que tal!!!!
bueno ya encontré el verdadero fallo!!!

La cosa es que en cuestión de colores está bien la cosa fue que la imagen en firefox es del tono que la tengo en PhotoShop, en Corel, en GIMP pero cuando abro la página en Internet Explorer, ahi está el chasco, pues los tonos en el IE son más oscuros y hacen parecer que el color elegido es diferente!!!

Bueno ahora la pregunta es.... ¿¿porque IE muestra llas imagenes un poco más oscuras que los demás navegadores??
__________________
Ubuntu User # 15554
http://dubaiphp.wordpress.com/ -Mi vida de desarrollo, juegos y algo más en un Blog-
  #4 (permalink)  
Antiguo 29/09/2005, 15:11
 
Fecha de Ingreso: febrero-2004
Ubicación: santiago
Mensajes: 24
Antigüedad: 13 años, 9 meses
Puntos: 0
Mensaje Colores

puede variar el color pero se vera la imagen y el fondo de la tabla parejos asi que no debes preocuparte



Tambien puede depender del monitor video etc...
  #5 (permalink)  
Antiguo 29/09/2005, 15:33
 
Fecha de Ingreso: agosto-2005
Mensajes: 35
Antigüedad: 12 años, 4 meses
Puntos: 0
por eso es recomendable usar colores WebSafe... ya que IE muestra los jpgs en otros tonos por los plug-ins con los que cuentan...seria bueno que veas que tal salen las imagenes con PNG..aunque IE no soporte transparencias, la imagen es bien mostrada...
salu2
__________________
Saludos
Erik©
(Antes loco_erik ... por reflexion de lo feo que suena me cambie de nick ;) ) :si:
  #6 (permalink)  
Antiguo 29/09/2005, 22:44
Avatar de JALF  
Fecha de Ingreso: septiembre-2004
Ubicación: Cali - Colombia
Mensajes: 634
Antigüedad: 13 años, 3 meses
Puntos: 2
gracias josepena y Erik©, buen efectivamente estoy utilizando imagenes en png aunque se que IE no soporta las trasparencias, pero lo que pasa es que hay un cuadro grandote del color que tiene josepena!!!!

y lo que pasa es que utilizo solo una parte del cuadro en imagen y el resto son tablas con el mismo color de fondo y he ahi el dilema en firefox se ve como si fuera la imagen original, mientras que en IE se ve el color de la imagen en un tono y los colores que les pongo a las tablas en otro,

pero en cuestión de los tonos de los colores de las tablas, no tengo problema porque se ven iguales en cualquier navegador, el problema es que IE a las imagenes le les da tonos más oscuros, entonces lo que hago queda como un parche muy raro.

Pero bueno estoy buscandole una solución y en cuanto la encuentre la publico

¿¿ok?? chaos que esten bien y muchas gracias por la ayuda

PD: quien tenga más ideas bienvenidas sean!!!
__________________
Ubuntu User # 15554
http://dubaiphp.wordpress.com/ -Mi vida de desarrollo, juegos y algo más en un Blog-
  #7 (permalink)  
Antiguo 01/10/2005, 17:56
 
Fecha de Ingreso: agosto-2005
Mensajes: 35
Antigüedad: 12 años, 4 meses
Puntos: 0
Has probado con imagenes en GIF?...
ya que si es un solo color solido...no entinedo por que estarias usando PNG...

Salu2
__________________
Saludos
Erik©
(Antes loco_erik ... por reflexion de lo feo que suena me cambie de nick ;) ) :si:
  #8 (permalink)  
Antiguo 01/10/2005, 18:29
 
Fecha de Ingreso: octubre-2004
Mensajes: 751
Antigüedad: 13 años, 2 meses
Puntos: 4
Bueno solo decir que a veces a mi también me pasa, creo una imágen con el mismo color de fondo que la página y luego en IE se nota la diferencia.
Lo que hago es en el photoshop en save for web, cambiar el tipo de imágen y las calidades. Voy probando y al final encuentro la que funcina correctamente.

Se que no es una solución muy "digna" pero a mi me funciona.

Pruebalo a ver que tal te va.

Saludos,
__________________
sergiold
  #9 (permalink)  
Antiguo 02/10/2005, 08:34
Avatar de JALF  
Fecha de Ingreso: septiembre-2004
Ubicación: Cali - Colombia
Mensajes: 634
Antigüedad: 13 años, 3 meses
Puntos: 2
Bueno lo que pasa es que yo hago los diseños en PhotoShop y luego los gravo en PNG pero gravado para Web, y ahi es donde me susede eso con el IE!!!!

Utilizo el PNG porque es el unico que me da las trasparencias bien bonitas!! mientras que las trasparencias del gif son muy pobre y las de los PNG a 8bits son las mismas de los gif, por eso utilizo PNG a 24bits!!!

Pero bueno segun estoy investigando ya estoy encontrando una solución para el IE y afortunadamente el IE7 ya trae esos problemas resueltos!!!

En cuanto tenga la solución definitiva, la publica aqui!!!
__________________
Ubuntu User # 15554
http://dubaiphp.wordpress.com/ -Mi vida de desarrollo, juegos y algo más en un Blog-
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:52.