Foros del Web » Creando para Internet » HTML »

porque pasa..??

Estas en el tema de porque pasa..?? en el foro de HTML en Foros del Web. Hola... alguien sabe porque cuando aplico algunos estilos para los enlaces.. algo como ésto: Código: <head> a:link{ text-decoration:none; color:orange } a:hover{ text-decoration:underline; color:orange } a:visited{ ...
  #1 (permalink)  
Antiguo 23/07/2002, 23:31
Avatar de RootK
Moderador
 
Fecha de Ingreso: febrero-2002
Ubicación: México D.F
Mensajes: 8.004
Antigüedad: 15 años, 9 meses
Puntos: 50
porque pasa..??

Hola... alguien sabe porque cuando aplico algunos estilos para los enlaces.. algo como ésto:
Código:
<head>
a:link{ text-decoration:none; color:orange }
a:hover{ text-decoration:underline; color:orange }
a:visited{ text-decoration:none; color:orange }
</head>
blabla...
<a href="algo.html">Uno</a>
<a href="algo2.html">Dos</a>
<a href="algo3.html">Tres</a>
...
..
Me acepta el estilo para "Dos" y "Tres", pero no me acepta para "Uno", es decir.. si me acepta el tamaño, color, pero el hover no me hace nada.. no subraya... o veces lo hace pero no lo hace con "Dos" o "Tres" o algun otro.. porque pasa esto..??

Porque a ves si me acepta el estilo con algunos enlaces y con otros no..?? tienes acaso que ver el orden...?? hay alguna regla cual va primero..??

link
hover
visited
.... o eso no importa...??

Gracias y saludos..! :P



<html><center><embed src="http://www.angelfire.com/on/cobainss/Movie1.swf" height=80 width=200><BR></embed></center></html>
  #2 (permalink)  
Antiguo 24/07/2002, 00:42
itatpc
Invitado
 
Mensajes: n/a
Puntos:
Re: porque pasa..??



No sé si será por esto, pero por si acaso, pon los estilos entre las siguientes etiquetas:

Código:
&lt;STYLE type=&quot;text/css&quot;&gt;
A:link { text-decoration:none; color:orange }
A:visited { text-decoration:none; color:orange }
A:hover { text-decoration:underline; color:orange }
&lt;/STYLE&gt;
A ver si es eso... ;)

  #3 (permalink)  
Antiguo 24/07/2002, 00:51
 
Fecha de Ingreso: julio-2001
Mensajes: 766
Antigüedad: 16 años, 4 meses
Puntos: 0
Re: porque pasa..??

curioso a mi no me pasa eso ni con tu ejemplo

<center><hr size="1" width="100%" noshade><a href=javascript:MsgrApp.LaunchIMUI('[email protected] com')>
<strong><font face="courier new" color="#666666" size="2">Contact Me?[/CODE]</strong>
<IMG SRC="http://woertman.org:8080/msn/gpa36" border="0"></A></ce
  #4 (permalink)  
Antiguo 24/07/2002, 01:16
Avatar de RootK
Moderador
 
Fecha de Ingreso: febrero-2002
Ubicación: México D.F
Mensajes: 8.004
Antigüedad: 15 años, 9 meses
Puntos: 50
Re: porque pasa..??

MMM... pues no mas no me sale... no se que esté pasando.. miren.. mas o menos les explicaré lo que tengo.. en mi página principal es donde declaro mis estilos:
Código:
&lt;HTML&gt;
&lt;HEAD&gt;
&lt;TITLE&gt;PECGMMER&lt;/TITLE&gt;
&lt;script language=&quot;javascript&quot; src=&quot;mijava.js&quot;&gt;

&lt;/script&gt;
inicio.asp
&lt;STYLE type=&quot;text/css&quot;&gt;
a:link{ text-decoration:none; color:orange }
a:hover{ text-decoration:underline; color:orange }
a:visited{ text-decoration:none; color:orange }
&lt;/style&gt;
&lt;/head&gt;
&lt;body&gt;
..
..
&lt;!-- mando a llamar mi archivo --&gt;
&lt;!-- #include file=&quot;plantilla.asp&quot; --&gt;
..
..
&lt;/body&gt;
&lt;/html&gt;
y ahí tengo algo como esto:

plantilla.asp
Código:
..
..
blabla
&lt;IMG src=&quot;images/indice.gif&quot;&gt;
&lt;a href=&quot;inicio.asp&quot;&gt;
Inicio&lt;/a&gt; |
&lt;IMG src=&quot;images/quien.gif&quot;&gt;
&lt;a href=&quot;info.asp&quot;&gt;
Autor &lt;/a&gt; | 
&lt;IMG src=&quot;images/proyectos.gif&quot;&gt;
&lt;a href=&quot;proy/redes.asp&quot;&gt;
Proyectos&lt;/a&gt; | 
&lt;IMG src=&quot;images/resul.gif&quot;&gt;
&lt;a href=&quot;resultados.asp&quot;&gt;
Resultados&lt;/a&gt; |
&lt;IMG src=&quot;images/comentarios.gif&quot;&gt;
&lt;a href=&quot;comentarios.asp&quot;&gt;
Comentarios&lt;/a&gt;
y me subraya solo: autor.. resultado y comentarios, pero inicio y proyectos no me los subraya cuando pasa el mouse... pero si me aplica el color...!!

POrque será que pasa esto..??

Gracias
  #5 (permalink)  
Antiguo 24/07/2002, 01:18
Avatar de RootK
Moderador
 
Fecha de Ingreso: febrero-2002
Ubicación: México D.F
Mensajes: 8.004
Antigüedad: 15 años, 9 meses
Puntos: 50
Re: porque pasa..??

Por cierto.. algo mas curioso.. es que si le cambio la extension al archivo de redes.asp por redes.html..así como inicio.asp por inicio.html si me aplica el estilo..!!

que pasa... no creo que esté alucinando..o si..??
  #6 (permalink)  
Antiguo 25/07/2002, 14:20
Avatar de RootK
Moderador
 
Fecha de Ingreso: febrero-2002
Ubicación: México D.F
Mensajes: 8.004
Antigüedad: 15 años, 9 meses
Puntos: 50
Re: porque pasa..??

Hola.???? nadie podría darme alguna respuesta lógica..???

Gracias..
  #7 (permalink)  
Antiguo 28/07/2002, 23:47
Avatar de RootK
Moderador
 
Fecha de Ingreso: febrero-2002
Ubicación: México D.F
Mensajes: 8.004
Antigüedad: 15 años, 9 meses
Puntos: 50
Re: porque pasa..??

mmm... creo que de plano.. ahora nadie me pudo ayudar..¡¡¡

En fin.. gracias de todas formas.. :(
  #8 (permalink)  
Antiguo 29/07/2002, 01:28
Avatar de Aleph  
Fecha de Ingreso: agosto-2001
Ubicación: Kenolandia
Mensajes: 1.061
Antigüedad: 16 años, 3 meses
Puntos: 3
Re: porque pasa..??

Es un problema comun, pero muy sencillo, solamente tenes que cambiar el orden de las seudoclases. Asi:

a:link
a:visited
a:hover

Si visited esta despues de hover le tapa el estilo, es por eso que se llaman estilos en cascada.

Saludos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:35.