Foros del Web » Creando para Internet » HTML »

Problema con acentos :s

Estas en el tema de Problema con acentos :s en el foro de HTML en Foros del Web. Buenas!! Estoy con un nuevo sitio web pero estoy teniendo problemas con los acentos, ñ, y demás caracteres del español. Sólo me da problema cuando ...
  #1 (permalink)  
Antiguo 09/01/2008, 09:31
 
Fecha de Ingreso: octubre-2006
Ubicación: Quart de Poblet, Valencia
Mensajes: 767
Antigüedad: 11 años, 1 mes
Puntos: 8
Problema con acentos :s

Buenas!!

Estoy con un nuevo sitio web pero estoy teniendo problemas con los acentos, ñ, y demás caracteres del español.

Sólo me da problema cuando hago includes con php (o requires), si escribo el texto en el mismo index no da ningún problema y si cojo los datos desde la BD tampoco.

He buscado en google y a algunas personas también le ha pasado, pero no pone ninguna solución concluyente, espero vuestra ayuda.

Un saludo!
  #2 (permalink)  
Antiguo 09/01/2008, 10:10
 
Fecha de Ingreso: octubre-2006
Ubicación: Quart de Poblet, Valencia
Mensajes: 767
Antigüedad: 11 años, 1 mes
Puntos: 8
Re: Problema con acentos :s

Ahora que me estoy fijando no me da problema con todos los includes que hago :s

Esto es muy raro.

Por ejemplo, en el index hago un include al header, pues sí que salen bien todos los acentos, pero en cambio, en otros como el menú lateral no me aparecen bien :|

Un saludo!
  #3 (permalink)  
Antiguo 10/01/2008, 06:16
 
Fecha de Ingreso: septiembre-2007
Mensajes: 184
Antigüedad: 10 años, 2 meses
Puntos: 4
Re: Problema con acentos :s

Todas las paginas tienen que ser UTF-8 (o la iso occidental si prefieres), y a la vez todas las paginas tienen que estar declaradas como tal en el marcado html.
Si una de estas dos condiciones no se cumple puede dar fallos.
  #4 (permalink)  
Antiguo 16/01/2008, 18:19
 
Fecha de Ingreso: octubre-2006
Ubicación: Quart de Poblet, Valencia
Mensajes: 767
Antigüedad: 11 años, 1 mes
Puntos: 8
Re: Problema con acentos :s

Cita:
Iniciado por feral Ver Mensaje
Todas las paginas tienen que ser UTF-8 (o la iso occidental si prefieres), y a la vez todas las paginas tienen que estar declaradas como tal en el marcado html.
Si una de estas dos condiciones no se cumple puede dar fallos.
Bueno, al parecer es que estaba guardando con UTF-8 (CON BOM) y me fastidiaba. Pero bueno, he bajado el notepad++ y va de lujo.

Un saludo!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:48.