Foros del Web

Foros del Web (http://www.forosdelweb.com/)
-   HTML (http://www.forosdelweb.com/f4/)
-   -   Problema con carga de recurso de video/mp4 (http://www.forosdelweb.com/f4/problema-con-carga-recurso-video-mp4-1009819/)

lobo_php 24/08/2012 16:19

Problema con carga de recurso de video/mp4
 
Compañeros, feliz tarde.

Tengo un problema con un <video> en HTML5, es algo dinámico y cuando consulto cierta información me trae un URL con el video en formato MP4 que debe cargar, el problema es que me está saliendo el siguiente error:

Código:

El "Content-Type" HTTP de "video/mp4" no es compatible. Ha fallado la carga del recurso de medios http://urldelmp4.mp4.
No sé que debo organizarle o agregarle, ya probé poniendo
Código:

type='video/mp4'
y
Código:

<meta http-equiv="Content-Type" content="video/mp4;" />
pero sigue sin funcionar.

PD: No carga el video en firefox ni safari, en chrome funciona bien.

Triby 24/08/2012 16:36

Respuesta: Problema con carga de recurso de video/mp4
 
No todos los navegadores tienen soporte para MP4, al menos no de forma nativa: http://en.wikipedia.org/wiki/HTML5_v...rowser_support

Me extraña que Safari no lo reproduzca, pero, al parecer la version probada en Windows 7 tiene algún problema con HTML 5.

Ho hice un sitio de videos y tuve que convertir a 5 formatos para "tratar" de garantizar que se vea en todos los navegadores y estoy seguro que más de uno se nos escapó.

Formatos que usamos: 3gp (móviles por rtsp://), ogv, mp4, webm y flv

lobo_php 25/08/2012 07:25

Respuesta: Problema con carga de recurso de video/mp4
 
Gracias por la respuesta compañero, estoy probandolo en un iPad también pero ya quedó solucionado tras mucho intentar. Ahora el problema que poseo es que si ejecuto un evento simulado (con un trigger en jQuery) no ejecuta la el $("#video")[0].play(); y pasa por ahí encima porque le pongo alerts pero simplemente lo ignora, en cambio cuando se ejecuta el evento porque de verdad el usuario interactúa con el programa (es cuando le presiono en play) ahí sí hace play, pero el evento simulado no.

elnoidelkargol 19/09/2012 18:14

Respuesta: Problema con carga de recurso de video/mp4
 
puedes poner la solucion !! gracias !!

emprear 24/09/2012 12:29

Respuesta: Problema con carga de recurso de video/mp4
 
Cita:

Iniciado por elnoidelkargol (Mensaje 4274853)
puedes poner la solucion !! gracias !!

Para compatibilidad con todos los navegadores necesitás de sto
http://foros.emprear.com/html5/video_local/video.html

Saludos

tutorias 22/10/2012 21:47

Respuesta: Problema con carga de recurso de video/mp4
 
Yo utilizo type con h264

Código HTML:

<source src="nombreVideo.mp4" type="video/h264" />


La zona horaria es GMT -6. Ahora son las 09:53.

Desarrollado por vBulletin® Versión 3.8.7
Derechos de Autor ©2000 - 2014, Jelsoft Enterprises Ltd.

SEO by vBSEO 3.3.2