Foros del Web » Creando para Internet » HTML »

Problema con la codificación de caracteres

Estas en el tema de Problema con la codificación de caracteres en el foro de HTML en Foros del Web. Hola, buenas tardes. Tengo una web con la siguiente codificación de caracteres: Código HTML: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns= "http://www.w3.org/1999/xhtml" ...
  #1 (permalink)  
Antiguo 03/02/2008, 11:46
Avatar de Nietzsche  
Fecha de Ingreso: enero-2005
Ubicación: MALAGA-ESPAÑA
Mensajes: 228
Antigüedad: 12 años, 11 meses
Puntos: 0
Problema con la codificación de caracteres

Hola, buenas tardes. Tengo una web con la siguiente codificación de caracteres:

Código HTML:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
    <html><head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/> 
Me pasa algo muy extraño, se me muestran correctamente los caracteres en toda la web excepto en el Index, donde no me salen acentos. (Todas las páginas tienen el mismo encabezado).

¿Alguna idea sobre qque puede ser?.

Un saludo.
__________________
Salud y libertad
  #2 (permalink)  
Antiguo 03/02/2008, 11:54
Avatar de [HH]KaoS  
Fecha de Ingreso: diciembre-2004
Ubicación: Nerja, Málaga (España)
Mensajes: 216
Antigüedad: 13 años
Puntos: 6
Re: Problema con la codificación de caracteres

Están codificados en sus correspondientes HTML?
__________________
Más información sobre mi: Raúl Jiménez
  #3 (permalink)  
Antiguo 03/02/2008, 12:40
Avatar de pitufoweb  
Fecha de Ingreso: enero-2008
Ubicación: Un Mundo Raro
Mensajes: 1.148
Antigüedad: 9 años, 10 meses
Puntos: 181
Re: Problema con la codificación de caracteres

usa
Código HTML:
charset=utf-8
tal ves con eso se arregle el problema
  #4 (permalink)  
Antiguo 03/02/2008, 12:44
Avatar de pitufoweb  
Fecha de Ingreso: enero-2008
Ubicación: Un Mundo Raro
Mensajes: 1.148
Antigüedad: 9 años, 10 meses
Puntos: 181
Re: Problema con la codificación de caracteres

y también quita el <html> que esta al lado del <head> por que ya esta arriba y lo tienes rrepetido

<html><head>
  #5 (permalink)  
Antiguo 03/02/2008, 12:55
Avatar de [HH]KaoS  
Fecha de Ingreso: diciembre-2004
Ubicación: Nerja, Málaga (España)
Mensajes: 216
Antigüedad: 13 años
Puntos: 6
Re: Problema con la codificación de caracteres

Cita:
Iniciado por pitufoweb Ver Mensaje
y también quita el <html> que esta al lado del <head> por que ya esta arriba y lo tienes rrepetido

<html><head>
Cierto xD, no me percaté
__________________
Más información sobre mi: Raúl Jiménez
  #6 (permalink)  
Antiguo 03/02/2008, 14:31
Avatar de Nietzsche  
Fecha de Ingreso: enero-2005
Ubicación: MALAGA-ESPAÑA
Mensajes: 228
Antigüedad: 12 años, 11 meses
Puntos: 0
Re: Problema con la codificación de caracteres

Muchas gracias, he hecho los cambios que me decís y se ha resuelto.

__________________
Salud y libertad
  #7 (permalink)  
Antiguo 03/02/2008, 15:12
Avatar de [HH]KaoS  
Fecha de Ingreso: diciembre-2004
Ubicación: Nerja, Málaga (España)
Mensajes: 216
Antigüedad: 13 años
Puntos: 6
Re: Problema con la codificación de caracteres

Perfecto, me alegro que ya lo solucionaras
__________________
Más información sobre mi: Raúl Jiménez
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:14.