Foros del Web » Creando para Internet » HTML »

Problema con codificacion UTF8

Estas en el tema de Problema con codificacion UTF8 en el foro de HTML en Foros del Web. Saludos a todos aquellos que se intersan por ayudar siempre a otras personas. mi escenario es el siguiente: tengo una pagina alojada en un servidor ...
  #1 (permalink)  
Antiguo 15/09/2010, 12:16
 
Fecha de Ingreso: agosto-2010
Ubicación: Lima, Los Olivos
Mensajes: 7
Antigüedad: 7 años, 3 meses
Puntos: 0
Problema con codificacion UTF8

Saludos a todos aquellos que se intersan por ayudar siempre a otras personas.

mi escenario es el siguiente:

tengo una pagina alojada en un servidor con PHP, Mysql y Apache.

esta es una pagina de pruebas ya que estoy implementando un nuevo template para una biblioteca virtual --> http://www.multimedios.org

el tema es que en esta web de prueba, que obviamente no esta asociada a un dominio por ser de prueba (solo ingreso a ella por medio de ip modificando el archivo hosts del windows).

pues tengo problemas para mostrar las "ñ", las vocales con tildes y otros caracteres como ">,<......".

De hecho la primera respuesta es colocar la etiqueta:
Código HTML:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
Pero el resultado sigue siendo el mismo.

Había revisado documentación de este foro, pero todo apunta a resultados desde una base de datos donde si es normal que pase este problema, pero en mi caso es solo algo estático, aun no implemento la funcionalidad dinámica en la pagina.

Solo por si es nescesario, el motor de plantillas con el que se desea fusionar el código PHP con el HTML es Smarty.

dejo el link --> http://biblos.info/juancarloz/becMal.jpg de como se ve la pagina actualmente (es una captura, pues como mencioné antes ingreso a ella por el artificio este del hosts)

De antemano muchas gracias por colaborar con su ayuda.
  #2 (permalink)  
Antiguo 15/09/2010, 13:22
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Problema con codificacion UTF8

juankarloz:
Hay muchos post en el foro referidos a este problema, yo escribí una guia práctica que por ahi te oriente

http://foros.emprear.com/codificar/

mirá las pruebas, y "juga" cambiando la codificación del navegador

Saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.
  #3 (permalink)  
Antiguo 15/09/2010, 13:28
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Problema con codificacion UTF8

perdon, duplique el post
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.
  #4 (permalink)  
Antiguo 20/09/2010, 17:23
 
Fecha de Ingreso: agosto-2010
Ubicación: Lima, Los Olivos
Mensajes: 7
Antigüedad: 7 años, 3 meses
Puntos: 0
Respuesta: Problema con codificacion UTF8

Hallé la respuesta, era solo el hecho de no poner las tildes habituales, ya que el servidor estaba configurado para reconocer estos símbolos:
Código HTML:
Ver original
  1. &aacute;

gracias por las respueta de todas maneras.
Slds!

Etiquetas: codificacion, utf
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:50.