Foros del Web » Creando para Internet » HTML »

Problema con DOCTYPE HTML PUBLIC y Navegador

Estas en el tema de Problema con DOCTYPE HTML PUBLIC y Navegador en el foro de HTML en Foros del Web. Hola, he instalado una galería que utiliza para los thumbnails el OnMouseOver para aumentar un poco su tamaño. Pues bien, al principio tenía en la ...
  #1 (permalink)  
Antiguo 25/07/2008, 12:23
 
Fecha de Ingreso: mayo-2005
Ubicación: Vimianzo. A Coruña
Mensajes: 230
Antigüedad: 12 años, 6 meses
Puntos: 1
Problema con DOCTYPE HTML PUBLIC y Navegador

Hola, he instalado una galería que utiliza para los thumbnails el OnMouseOver para aumentar un poco su tamaño.
Pues bien, al principio tenía en la página:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Y no funcionaba el OnMouseOver, ni con Firefox 2 ni con IE7.
Luego, leí en un post de estos foros que cambiara eso por:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

Y efectivamente, ya fucionó pefectamente el OnMouseOver.
Cual es ahora el problema....que Firefox 2 me visualiza pefectamente la página, pero IE7 me descuadra la cabecera y me mueve toda la página hacia la derecha....
Página vista con Firefox2
Página vista con IE7

Sabeis como puedo solucionar esto???

La verdad es que yo nunca he usado lo del DOCTYPE, pero como uso el dreamwaver porque me facilita mucho el escribir código, y este lo pone al crear la página...

Espero que me podais ayudar.....

Muchas gracias por todo y un Saludo!

Última edición por Baldur; 25/07/2008 a las 14:01
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:45.