Foros del Web » Creando para Internet » HTML »

Problema con DOCTYPE - malogra mi diseño

Estas en el tema de Problema con DOCTYPE - malogra mi diseño en el foro de HTML en Foros del Web. Hola, tengo el siguiente problema con este tag, resulta que tengo un formulario que funciona con php este es http://www.andesperu.com/c-solicitud.php ahora bien cuando saco ese ...
  #1 (permalink)  
Antiguo 20/01/2010, 15:30
Avatar de salvador86  
Fecha de Ingreso: enero-2008
Ubicación: Guadalajara- Mexico
Mensajes: 467
Antigüedad: 9 años, 11 meses
Puntos: 2
Problema con DOCTYPE - malogra mi diseño

Hola, tengo el siguiente problema con este tag, resulta que tengo un formulario que funciona con php este es http://www.andesperu.com/c-solicitud.php ahora bien cuando saco ese tag
Código PHP:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"
Empieza a funcionar un javascript que me permite colocar la fecha en el formulario pero esto hace que en Explorer se vea mal distorcionado,

Pero cuando no lo saco en Firefox ya no funciona esta js que me a acompañado por mucho tiempo.

En conclusión si lo tengo el tag funciona correcto en Explorer pero ya no en Mozilla Firefox

Pero si lo saco funcione bacan en Firefox pero se ve mal el diseño en Explorer.

Ayudenme a resolver este dilema gracias
  #2 (permalink)  
Antiguo 20/01/2010, 15:50
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: Problema con DOCTYPE - malogra mi diseño

En el script, cambia datos.Fecha.value por document.getElementById('datos').Fecha.value
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #3 (permalink)  
Antiguo 21/01/2010, 08:50
Avatar de salvador86  
Fecha de Ingreso: enero-2008
Ubicación: Guadalajara- Mexico
Mensajes: 467
Antigüedad: 9 años, 11 meses
Puntos: 2
Respuesta: Problema con DOCTYPE - malogra mi diseño

Muchas Muchas gracias no me percate que el problema estaba en borrado, como en el explorer me salia sin error no se me ocurrio, gracias

Etiquetas: diseño, doctype
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:09.