Foros del Web » Creando para Internet » HTML »

Problema con fondo de una fila.

Estas en el tema de Problema con fondo de una fila. en el foro de HTML en Foros del Web. Holas bueno primero saludarles a todos, este es mi primer post. El problema es que tengo una tabla con 3 filas, la primera y la ...
  #1 (permalink)  
Antiguo 30/01/2007, 09:31
 
Fecha de Ingreso: enero-2007
Mensajes: 4
Antigüedad: 10 años, 10 meses
Puntos: 0
Problema con fondo de una fila.

Holas bueno primero saludarles a todos, este es mi primer post.

El problema es que tengo una tabla con 3 filas, la primera y la tercera las tengo con height a 0 (luego las modifico con javascript, segun lo necesite), bueno el caso es que en esas filas tengo un background-image con una imagen de fondo. Este fondo no deberia de verse pero en iexplorer se ve algo asi como una linea de un pixel de alto, en firefox va perfecto.
Aqui os pego el codigo:
Código HTML:
<table width="540" height="298" border="0" cellpadding="0" cellspacing="0" id="Marcos">
		<tbody>
		<tr>
		    <td width="0" height="0"  style="background-image:url(./images/marco_esq_1.gif)"></td>
    		<td width="540" height="0" style="background-image:url(./images/marco_sup.gif)"></td>
		    <td width="0" height="0" style="background-image:url(./images/marco_esq_2.gif)"></td>
	   </tr>
	   <tr>
	  	    <td width="0" height="298" style="background-image:url(./images/marco_izq.gif)"></td>
		 <td width="540" height="298"></td>
	        <td width="0" height="298" style="background-image:url(./images/marco_der.gif)"></td>
	   </tr>
       <tr>
		    <td width="0" height="0"  style="background-image:url(./images/marco_esq_3.gif)"></td>
		    <td width="540" height="0"  style="background-image:url(./images/marco_inf.gif)"></td>
		    <td width="0" height="0"  style="background-image:url(./images/marco_esq_4.gif)"></td>
	   </tr>
	   </tbody>
</table> 
Una captura de la salida:
ya_sabeis_k_va_aki:\\img262.imageshack.us/img262/7350/pruebanf3.gif

No puedo poner la imagen hasta los 30 posts, asi que os dejo la url.


Un saludo y gracias de antemano...
  #2 (permalink)  
Antiguo 01/02/2007, 05:35
 
Fecha de Ingreso: enero-2007
Mensajes: 4
Antigüedad: 10 años, 10 meses
Puntos: 0
Re: Problema con fondo de una fila.

Nadie sabe mas o menos de que puede ser. Es que estoy atascao en esto y no tengo ni idea de como puedo solucionarlo.

Un saludo...
  #3 (permalink)  
Antiguo 01/02/2007, 08:23
Avatar de yournightmare86  
Fecha de Ingreso: abril-2006
Ubicación: Madrid
Mensajes: 875
Antigüedad: 11 años, 7 meses
Puntos: 9
Re: Problema con fondo de una fila.

Prueba quitando la etiqueta <tbody> que no es estándar.
  #4 (permalink)  
Antiguo 01/02/2007, 09:32
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Re: Problema con fondo de una fila.

lo probé en los dos browser IExplorer y FireFox y en los dos me anda bien, en ninguno veo esa linita que vos decis...

Código HTML:
<table width="540" style="height: 298" border="0" cellpadding="0" cellspacing="0" id="Marcos">
<tbody>
<tr>
<td width="0" height="0" style="background-image:url(./images/marco_esq_1.gif)"></td>
<td width="540" height="0" style="background-image:url(./images/marco_sup.gif)"></td>
<td width="0" height="0" style="background-image:url(./images/marco_esq_2.gif)"></td>
</tr>
<tr>
<td width="0" height="298" style="background-image:url(./images/marco_izq.gif)"></td>
<td width="540" height="298"></td>
<td width="0" height="298" style="background-image:url(./images/marco_der.gif)"></td>
</tr>
<tr>
<td width="0" height="0" style="background-image:url(./images/marco_esq_3.gif)"></td>
<td width="540" height="0" style="background-image:url(./images/marco_inf.gif)"></td>
<td width="0" height="0" style="background-image:url(./images/marco_esq_4.gif)"></td>
</tr>
</tbody>
</table> 
Probalo y fijate.....
  #5 (permalink)  
Antiguo 01/02/2007, 11:35
 
Fecha de Ingreso: enero-2007
Mensajes: 4
Antigüedad: 10 años, 10 meses
Puntos: 0
Re: Problema con fondo de una fila.

Pues na que no hay manera le he quitado lo de tbody y na sigue igual.
DragonX a mi me siguen saliendo esas dos lineas, las de la imagen que puse, a lo mejor no te salieron por que no tenias las imagenes de los fondos.

La verdad no lo entiendo

Saludos..
  #6 (permalink)  
Antiguo 01/02/2007, 11:52
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Re: Problema con fondo de una fila.

Cita:
Iniciado por holahola2 Ver Mensaje
Pues na que no hay manera le he quitado lo de tbody y na sigue igual.
DragonX a mi me siguen saliendo esas dos lineas, las de la imagen que puse, a lo mejor no te salieron por que no tenias las imagenes de los fondos.

La verdad no lo entiendo

Saludos..
Ups! que boludon......cuando tenés razón, tenés razón.....
  #7 (permalink)  
Antiguo 05/02/2007, 10:51
 
Fecha de Ingreso: enero-2007
Mensajes: 4
Antigüedad: 10 años, 10 meses
Puntos: 0
Re: Problema con fondo de una fila.

Bueno pues por mucho que busco no encuentro nada para solucionar esto, lo dejo y al que le moleste que se joda y que ponga firefox :D:D
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:00.