Foros del Web » Creando para Internet » HTML »

problema con iframe

Estas en el tema de problema con iframe en el foro de HTML en Foros del Web. Hola amigos: Estoy desarrollando una web en la cual tengo dos iframes, desde el iframe superior cargo en el inferior, una web donde solicito que ...
  #1 (permalink)  
Antiguo 25/10/2004, 16:07
 
Fecha de Ingreso: abril-2004
Ubicación: Chiclayo
Mensajes: 14
Antigüedad: 13 años, 7 meses
Puntos: 0
problema con iframe

Hola amigos:
Estoy desarrollando una web en la cual tengo dos iframes, desde el iframe superior cargo en el inferior, una web donde solicito que se ingrese unos datos de usuario ¿porque al estar dijitando en los campos me aparece el menu de ayuda más abajo de cada campo ?.

Es decir cuando ingresamos datos en una pagina simple, al digitar sobre un campo, nos aparece automaticamente un menu JUSTO DEBAJO DEL MISMO CAMPO con los datos que antes hemos digitado con el fin de pode seleccionar esos datos. ¿a que se debe que si cargo esta misma pagina dentro de un iframe el menu que me aparece por cada campo, aparece mucho más abajo de la localizacion del campo que estoy digitando? ¿como puedo solucionar esto?. Espero haberme explicado bien.

Gracias

Lube
  #2 (permalink)  
Antiguo 26/10/2004, 04:21
Avatar de kemie  
Fecha de Ingreso: junio-2003
Ubicación: estocolmo<-->mexico
Mensajes: 1.627
Antigüedad: 14 años, 5 meses
Puntos: 1
lube... nos puedes mostrar la pagina para ver que codigo estas usando y cual puede ser el problema?
__________________
::::::::::::::::::::::::::::: WebHostNinja | diseñorama.com::::::::::::::::::::::::::::::
  #3 (permalink)  
Antiguo 26/10/2004, 08:18
 
Fecha de Ingreso: abril-2004
Ubicación: Chiclayo
Mensajes: 14
Antigüedad: 13 años, 7 meses
Puntos: 0
problema con iframe

Aun no la tengo colgada.... pero es bastante simple. mi pagina principal tiene lo siguiente:

<html>
<head>
<title></title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<style type="text/css">
body {
margin-top: 0px;
background-image: url(fondo.jpg);
}
</style></head>
<body>
<center>
<table width="740" border="0" cellpadding="0" cellspacing="0">
<tr>
<td>
<iframe name="ifSuperior" src="superiorblank.php" height="100" width="740" scrolling="no" frameborder="0">
</iframe>
</td>
</tr>
<tr>
<td>
<iframe name="ifSubSuperior" src="subsuperiorblank.php" height="50" width="740" scrolling="no" frameborder="0">
</iframe>
</td>
</tr>
<tr>
<td>
<iframe name="ifCuerpo" src="login.php" height="400" width="740" scrolling="no" frameborder="0">
</iframe>
</td>
</tr>
</table>
</center>
</body>
</html>



Cuando, cargo la pagina login.php SOLA, funciona excelente, pero cuando la cargo dentro del iframe, el menu que aparece conforme voy digitando en los cuadros de texto, aparece muy abajo de la pagina fuera del cuadro de texto.

Muchas gracias por tu interes.
  #4 (permalink)  
Antiguo 26/10/2004, 11:03
Avatar de kemie  
Fecha de Ingreso: junio-2003
Ubicación: estocolmo<-->mexico
Mensajes: 1.627
Antigüedad: 14 años, 5 meses
Puntos: 1
como tienes posicionado el menu que aparece?
__________________
::::::::::::::::::::::::::::: WebHostNinja | diseñorama.com::::::::::::::::::::::::::::::
  #5 (permalink)  
Antiguo 26/10/2004, 15:48
 
Fecha de Ingreso: abril-2004
Ubicación: Chiclayo
Mensajes: 14
Antigüedad: 13 años, 7 meses
Puntos: 0
problema con iframe

Cita:
Iniciado por kemie
como tienes posicionado el menu que aparece?
te envio el codigo de la pagina login.php, no tengo ningun menu (cuando menciono menu me refiero al que aparece automaticamente cuando se está ingresando datos a un campo)

<html>
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<style type="text/css">
<!--
.Estilo1 {color: #FFFFFF}
-->
</style>
</head>

<body>
<form action="login_valida.php" method="post" name="form1" onSubmit="return ObligaCampos(this)">
<table width="332" border="1" align="center" cellspacing="0" bordercolor="#B6CEFB">
<tr bgcolor="#7495E2">
<td height="32" colspan="2"><div align="center" class="Estilo1"><strong><strong>Sistema Integrado de Gesti&oacute;n Administrativa </strong></strong></div></td>
</tr>
<tr bgcolor="#D6DFF7">
<td width="124"><div align="right">Usuario</div></td>
<td width="192"><input name="srtxtusuario" type="text" id="Usuario"></td>
</tr>
<tr bgcolor="#D6DFF7">
<td><div align="right">Password</div></td>
<td><input name="srtxtpassword" type="password" id="Password"></td>
</tr>
<tr bgcolor="#D6DFF7">
<td>&nbsp;</td>
<td><input type="submit" name="Submit" value="Aceptar"></td>
</tr>
<tr bgcolor="#7495E2">
<td height="32" colspan="2"><div align="center" class="Estilo1"><strong>Seguridad</strong></div></td>
</tr>
</table>
</form>
</body>
</html>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:14.