Foros del Web » Creando para Internet » HTML »

Problema con links

Estas en el tema de Problema con links en el foro de HTML en Foros del Web. Hola amigos, paso a poneros este problemilla que tengo y no se como resolver. Si accedeis a mi web http://www.nuevaera3d.es vereis que debajo del menu ...
  #1 (permalink)  
Antiguo 28/02/2011, 16:48
 
Fecha de Ingreso: diciembre-2008
Mensajes: 76
Antigüedad: 9 años
Puntos: 1
Problema con links

Hola amigos, paso a poneros este problemilla que tengo y no se como resolver.

Si accedeis a mi web http://www.nuevaera3d.es vereis que debajo del menu de navegación tengo puestas 3 enlaces con imágenes "rift", "fear 3", "infamous 2". Pues bien no se que pasa pero al intentar pinchar con el boton izquierdo del raton sobre ellas no dirije hacia la página en cuestion.
Pero lo raro viene aquí si pulsas con el boton derecho del raton y en el menú desplegable eliges "abrir vinculo en una nueva ventana o pestaña" si que me dirije hacia la página.

El código que tengo puesto es este:

Código:
<div id="faded">
        <ul>
          <li><img src="images/gallery-1.jpg" alt="" /></li>
          <li><img src="images/gallery-2.jpg" alt="" /></li>
          <li><img src="images/gallery-3.jpg" alt="" /></li>
        </ul>
        <ul class="pagination">
          <li> <a href="previews/previews_pc/rift/rift.html" rel="0"> <img src="images/gallery-pic-1.jpg" alt="" /> <b>Preview PC</b> <em>Rift <br>
            </em> </a> </li>
          <li> <a href="previews/previews_xbox360/fear_3/fear_3.html" rel="1"> <img src="images/gallery-pic-2.jpg" alt="" /> <b>Preview Xbox 360</b> <em>F.E.A.R. 3 <br>
            </em>  </a> </li>
          <li> <a href="previews/previews_ps3/infamous_2/infamous_2.html" rel="2"> <img src="images/gallery-pic-3.jpg" alt="" /> <b>Preview PS3</b> <em>Infamous 2 <br>
            </em> </a> </li>
        </ul>
      </div>
Si sabeís la solución para que se abra directamente con el botón izq del raton os lo agradecería enormemente.
__________________
crearunBLOGfacil :: Aprende a crear tu propio blog
  #2 (permalink)  
Antiguo 28/02/2011, 17:31
Avatar de ArturoGallegos
Moderador
 
Fecha de Ingreso: febrero-2008
Ubicación: Morelia, México
Mensajes: 5.823
Antigüedad: 9 años, 9 meses
Puntos: 951
Respuesta: Problema con links

aquí es problema con el ajax que utilizas seguramente es el jquery ya que si deshabilitas el javacripts del explorador tus enlaces funcionan correctamente

prueba ir eliminando cada ajax y/o javascript por separado y haciendo pruebas para identificar cual es el del conflicto
__________________
Toda ayuda se proporciona exclusivamente en el foro, no skype, no mensajes privados u otro medio....
  #3 (permalink)  
Antiguo 01/03/2011, 06:09
 
Fecha de Ingreso: diciembre-2008
Mensajes: 76
Antigüedad: 9 años
Puntos: 1
Respuesta: Problema con links

Bueno pues aqui si que tengo un problema por que yo de ajax no tengo ni idea.
Si es el jquery porque curioseando por los archivos de la web encontre estos archivos... jquery.faded y jquery-1.4.2.min además en el código html hace referencia a estos y otros archivos:

Código:
<script type="text/javascript" src="js/jquery-1.4.2.min.js"></script>
<script type="text/javascript" src="js/cufon-yui.js"></script>
<script type="text/javascript" src="js/Myriad_Pro_700.font.js"></script>
<script type="text/javascript" src="js/cufon-replace.js"></script>
<script type="text/javascript" src="js/jquery.faded.js"></script>
La web es una plantilla que compre prefabricada con lo que yo tengo conocimientos de html y css pero no de ajax asi que no se como solucionarlo.

Si me podeis ayudar puedo colgar el codigo de la página o de los archivos jquery haber si vosotros podeis dar con la solucion.

Gracias.
__________________
crearunBLOGfacil :: Aprende a crear tu propio blog
  #4 (permalink)  
Antiguo 01/03/2011, 14:26
Avatar de ArturoGallegos
Moderador
 
Fecha de Ingreso: febrero-2008
Ubicación: Morelia, México
Mensajes: 5.823
Antigüedad: 9 años, 9 meses
Puntos: 951
Respuesta: Problema con links

pues vas a perder la funcionalidad de esos botones, ya que fueron pensados como navegación del slideshow no como links a otras paginas.

la verdad necesitaría meterme un rato a revisar el código, para decirte que modifiques exactamente... pero algo provisional y funcional es agregarles el evento onclick del javascript

los links quedarían mas o menos así:

si deseas se abra en una nueva pagina
Código HTML:
Ver original
  1. <a rel="0" href="previews/previews_pc/rift/rift.html" onclick="window.open(this.href,'child'); return false;">
si deseas que se abra en la misma pagina
Código HTML:
Ver original
  1. <a rel="0" href="previews/previews_pc/rift/rift.html" onclick="location.href=this.href">
__________________
Toda ayuda se proporciona exclusivamente en el foro, no skype, no mensajes privados u otro medio....
  #5 (permalink)  
Antiguo 01/03/2011, 15:59
 
Fecha de Ingreso: diciembre-2008
Mensajes: 76
Antigüedad: 9 años
Puntos: 1
Respuesta: Problema con links

Muchas gracias Ag666!!! ahora funciona perfectamente, por fin se soluciono el problema con el código que me has puesto.
De nuevo muchas gracias
__________________
crearunBLOGfacil :: Aprende a crear tu propio blog

Etiquetas: links
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:39.