Foros del Web » Creando para Internet » HTML »

Problema con mi formulario

Estas en el tema de Problema con mi formulario en el foro de HTML en Foros del Web. Hola! vi un tutorial de como hacer un formulario de envio automatico con html, y un script en php El codigo de mi formulario.html es ...
  #1 (permalink)  
Antiguo 11/05/2010, 13:32
Avatar de xarmagedonx  
Fecha de Ingreso: marzo-2009
Mensajes: 360
Antigüedad: 8 años, 9 meses
Puntos: 29
Problema con mi formulario

Hola! vi un tutorial de como hacer un formulario de envio automatico con html, y un script en php

El codigo de mi formulario.html es este:
Código:
<form id="Aportar" name="Aportar" method="post" action="send.php">
                                <p>
                                  <label>Nombre
                                    <input name="nombre" type="text" id="nombre" size="30" />
                                  </label>
                                </p>
                                <p>
                                  <label>Email
                                    <input name="mail" type="text" id="mail" size="30" />
                                  </label>
                                </p>
                                <p>
                                  <label>Mensaje<br />
<textarea name="mensaje" id="mensaje" cols="45" rows="5"></textarea>
                                  </label>
                                </p>
                                <p>
                                  <label>
                                    <input type="submit" name="Submit" value="Enviar" />
                                  </label>
                                </p>
                              </form>
Y me decia que cree un archivo llamado send.php y le puse este codigo:
Código:
< ?php 
$nombre = $_POST['nombre'];
$mail = $_POST['mail'];

$header = 'From: ' . $mail . " \r\n";
$header .= "X-Mailer: PHP/" . phpversion() . " \r\n";
$header .= "Mime-Version: 1.0 \r\n";
$header .= "Content-Type: text/plain";

$mensaje = "Este mensaje fue enviado por " . $nombre . " \r\n";
$mensaje .= "Su e-mail es: " . $mail . " \r\n";
$mensaje .= "Mensaje: " . $_POST['mensaje'] . " \r\n";
$mensaje .= "Enviado el " . date('d/m/Y', time());

$para = '[email protected];
$asunto = 'Mensaje';

mail($para, $asunto, utf8_decode($mensaje), $header);

echo '&estatus=ok&';

?>
Pero cuando voy a probar si funciona, relleno el formulario y envio, pero cuando pongo enviar, me aparece el archvio send.php osea http://www.miweb.com.ar/send.php y todo el codigo php que puse en este archivo.

¿¿Que es lo que hice mal??

Gracias
  #2 (permalink)  
Antiguo 11/05/2010, 14:32
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 9.741
Antigüedad: 9 años, 4 meses
Puntos: 2113
Respuesta: Problema con mi formulario

Cita:
Iniciado por xarmagedonx
¿¿Que es lo que hice mal??
< ?php no debe llevar espacio, solo <?php
__________________
- León, Guanajuato
- GV-Foto
  #3 (permalink)  
Antiguo 11/05/2010, 14:41
Avatar de xarmagedonx  
Fecha de Ingreso: marzo-2009
Mensajes: 360
Antigüedad: 8 años, 9 meses
Puntos: 29
Respuesta: Problema con mi formulario

jajaj gracias....

no me habia dado cuenta de eso, recien empiezo con php :P

Etiquetas: formulario
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:33.