Foros del Web » Creando para Internet » HTML »

Problema con mi web

Estas en el tema de Problema con mi web en el foro de HTML en Foros del Web. Hola buenas, a ver si me podeis ayudar, hace poco que he empezado en esto del html,php,etc... y me ha salido un problema con la ...
  #1 (permalink)  
Antiguo 17/07/2010, 10:41
 
Fecha de Ingreso: julio-2010
Mensajes: 2
Antigüedad: 7 años, 4 meses
Puntos: 0
Problema con mi web

Hola buenas, a ver si me podeis ayudar, hace poco que he empezado en esto del html,php,etc... y me ha salido un problema con la pagina web que estoy haciendo, la web ya esta acabada y en localhost la pagina se me ve bien, como yo queria, pero el problema viene cuando la he subido a mi servidor gratuito y entonces en la mayoria de paginas no se me ven las imagenes... mirar:

Asi es como se ven ya subidas

http://img341.imageshack.us/i/webah.jpg/
[URL="http://img202.imageshack.us/i/web3u.jpg/"][noparse]http://img202.imageshack.us/i/web3u.jpg/"]httprse][/URL]
Asi es como se ven en localhost y como se deberian ver
[URL="http://img59.imageshack.us/i/web2tw.jpg"][noparse]http://img59.imageshack.us/i/web2tw.jpg/"]httprse][/URL]
[URL="http://img683.imageshack.us/i/web4l.jpg"][noparse]http://img683.imageshack.us/i/web4l.jpg/"]httpse][/URL]

Este es el trozo de código de lo que no se ve

[CODE]
<div id="csoon">
<div class="heading2"><a href="partidos.html">Pr&oacute;ximo pratido</a> </div>
<p><img src="images/partido.jpg" alt="ScreenShot" width="99" height="65" /></p>
<p><a href="partidos.hmtl">FINAL DE TEMPORADA</a></p>
</div>
<a href="imagenes.html"><div id="imagenes">
</div></a>
<a href="videos.html"><div id="videos">
</div></a>
<a href="enlaces.html"><div id="enlaces">
</div></a>


#csoon {
background: url(images/c-soon-bg.jpg) no-repeat;
color: #B7B7B7;
float: left;
display: block;
height: 157px;
margin-left: 15px;
margin-top: 60px;
padding-left: 35px;
padding-top: 15px;
width: 134px;
}
#imagenes {
background: url(images/galeria.jpg) no-repeat;
color: #B7B7B7;
float: left;
display: block;
height: 157px;
margin-left: 40px;
margin-top: 60px;
padding-left: 35px;
padding-top: 15px;
width: 134px;
}
#videos {
background: url(images/videos.jpg) no-repeat;
color: #B7B7B7;
float: left;
display: block;
height: 157px;
margin-left: 40px;
margin-top: 60px;
padding-left: 35px;
padding-top: 15px;
width: 134px;
}
#enlaces {
background: url(images/enlaces.jpg) no-repeat;
color: #B7B7B7;
float: left;
display: block;
height: 157px;
margin-left: 40px;
margin-top: 60px;
padding-left: 35px;
padding-top: 15px;
width: 134px;
}
[/CODE]

y de la otra pagina

[CODE]
<form action="ampliar.php" method="get"><div class="contenedorfoto"><a href="#"><img src="images/galeria/foto112.jpg" border="0" alt="" width="138" height="105"/></a><br />
<span>Plantilla 2010</span><br />
<input name="foto1" type="hidden" value="1" />
<input name="ampliar" type="submit" value="Ampliar" class="fotogal"/></div> </form>

<form action="ampliar.php" method="get"><div class="contenedorfoto"><a href="#"><img src="images/galeria/foto2.jpg" border="0" alt="" width="138" height="105"/></a><br /><span>Partido</span><br />
<input name="foto2" type="hidden" value="2" />
<input name="ampliar" type="submit" value="Ampliar" class="fotogal"/></div> </form>

<form action="ampliar.php" method="get"><div class="contenedorfoto"><a href="#"><img src="images/galeria/foto3.jpg" border="0" alt="" width="138" height="105"/></a><br /><span>Partido</span><br />
<input name="foto3" type="hidden" value="3" />
<input name="ampliar" type="submit" value="Ampliar" class="fotogal"/></div> </form><br />

<form action="ampliar.php" method="get"><div class="contenedorfoto"><a href="#"><img src="images/galeria/foto4.jpg" border="0" alt="" width="138" height="105"/></a><br /><span>Partido</span><br />
<input name="foto4" type="hidden" value="4" />
<input name="ampliar" type="submit" value="Ampliar" class="fotogal"/></div> </form>

<form action="ampliar.php" method="get"><div class="contenedorfoto"><a href="#"><img src="images/galeria/foto5.jpg" border="0" alt="" width="138" height="105"/></a><br /><span>Partido</span><br />
<input name="foto5" type="hidden" value="5" />
<input name="ampliar" type="submit" value="Ampliar" class="fotogal"/></div> </form>

<form action="ampliar.php" method="get"><div class="contenedorfoto"><a href="#"><img src="images/galeria/foto6.jpg" border="0" alt="" width="138" height="105"/></a><br /><span>Partido</span><br />
<input name="foto6" type="hidden" value="6" />
<input name="ampliar" type="submit" value="Ampliar" class="fotogal"/></div> </form>
<p><br />



.contenedorfoto {
float:left;
width:150px;
height:140px;
margin: 10px;
padding:5px;
background-color:#050306;
border-right: #a5a7aa solid 1px;
border-bottom: #a5a7aa solid 1px;
text-align:center;
}
[/CODE]

Bueno no se si me he explicado bien, pero bueno si no lo intentare explicar mejor
bueno gracias anticipadas, espero vuestras respuestas

Última edición por julian_vcf; 17/07/2010 a las 10:47
  #2 (permalink)  
Antiguo 17/07/2010, 11:03
 
Fecha de Ingreso: noviembre-2009
Ubicación: Barcelona
Mensajes: 214
Antigüedad: 8 años
Puntos: 6
Respuesta: Problema con mi web

Bueno 2 sugerencias.
Encierra el contenido en donde van, en la barra de respuestas hay un menu desplegable que dice "Highlight" ahi escojes si es PHP, HTML, CSS, etc!!

asi se nos facilitara mas leerlos.

2) danos la url de tu pagina =D
una vez hgas esto, con gusto y con comodidas te ayudaremos =D

saludos!!
  #3 (permalink)  
Antiguo 17/07/2010, 16:49
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: Problema con mi web

Hola:

Lo más probable es que el problema sea de rutas, confirma que has subido todos los elementos en su carpeta correspondiente.

Comprueba también que los nombres de las imágenes no tengan espacios en blanco y coincidan perfectamente, es decir, mayúsculas y minúsculas.

Saludos.

  #4 (permalink)  
Antiguo 17/07/2010, 17:41
Avatar de Omura
Colaborador
 
Fecha de Ingreso: julio-2006
Ubicación: Peru
Mensajes: 3.491
Antigüedad: 11 años, 5 meses
Puntos: 185
Respuesta: Problema con mi web

en una mirada rápida a tu web encontré 2 errores...

lo que te dice jomauro, cuida el tema de las mayúsculas minúsculas, tienes en tu web...

images/galeria.jpg

pero en realidad es:

images/galeria.JPG

y este error...

<p><a href="partidos.hmtl">FINAL DE TEMPORADA</a></p>

lo primero lo solucionas fijándote en el explorador de windows - herramientas - opciones de carpeta - ver

[x] ocultar las extensiones de archivos para tipos de archivos conocidos. (quitar marca).

lo segundo, usando algún editor tipo NotePad++.
__________________
Mi error era de código... pero de código genético.
  #5 (permalink)  
Antiguo 18/07/2010, 07:54
 
Fecha de Ingreso: julio-2010
Mensajes: 2
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Problema con mi web

Gracias por responder, las rutas y nombres los tengo correctamente.
Omura ya he cambiado lo de la extension, sigo igual, lo que no entiendo es porque en local se me ve perfecto y cuando subo la pagina no, pero bueno gracias por vuestra ayuda ire probando a ver si lo soluciono, si no cambiare de servidor a ver si funciona
¡GRACIAS!
  #6 (permalink)  
Antiguo 18/07/2010, 09:45
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema con mi web

si muestras la URL probablemente adquieras una respuesta a tu problema.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #7 (permalink)  
Antiguo 18/07/2010, 18:19
 
Fecha de Ingreso: enero-2009
Ubicación: Uruguay
Mensajes: 121
Antigüedad: 8 años, 11 meses
Puntos: 4
Respuesta: Problema con mi web

nose si ya solucionaste tu error pero yo las veo las imagenes.
dejo la url que la vi en el screenshoot

http://drinkteam.zobyhost.com/

una cosa que te queria comentar en los botones de arriba porque en vez de usar imagenes que solo pongan blanco el texto lo haces con css.
es decir pones la imagen de fondo que seria el boton verde pero sin texto y luego en el html le pones la frase a cada boton y con css en el :hover del enlace le cambias el color a blanco.
__________________
www.sandant.com - Blog de Programacion y mucho mas

WWW.SPEDEVIGNER.COM SE DEJARA DE USAR EN UN MES

Etiquetas: imagenes
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:03.