Foros del Web » Creando para Internet » HTML »

Problema con tildes y la solucion que me ha dado el host

Estas en el tema de Problema con tildes y la solucion que me ha dado el host en el foro de HTML en Foros del Web. La verdad es que ahora mismo no se si estoy sorprendido o cabreado... os cuento... Tengo contratado un año de dominio y alojamiento con MBI ...
  #1 (permalink)  
Antiguo 20/09/2010, 10:22
Avatar de zornak  
Fecha de Ingreso: septiembre-2008
Ubicación: Toledo
Mensajes: 96
Antigüedad: 9 años, 2 meses
Puntos: 3
Problema con tildes y la solucion que me ha dado el host

La verdad es que ahora mismo no se si estoy sorprendido o cabreado... os cuento...

Tengo contratado un año de dominio y alojamiento con MBI (Mas Barato Imposible)...

He subido mi web, con los archivos guardados como UTF-8 y el siguiente charset:

<meta charset="UTF-8">

Al comprobar si todo estaba bien, he visto que los símbolos y las tildes no se veían bien...

La he subido a mi otro alojamiento (Bluehost) y se veía perfecta así que he contactado con MBI preguntando que era lo que sucedía, me han dicho que guardase los archivos en UTF-8, cosa que ya había hecho y se lo había dicho, pero bueno... a los 20 o 30 minutos, recibo un mensaje diciendo que estaba solucionado, pero no me habían dicho cual era el problema, asi que les he enviado otro mensaje para que me dijesen cual era el problema a lo que me han contestado:

"He modificado el charset del index.php para que funcione correctamente."

He ido corriendo a mirarlo, y me lo habian cambiado por:

<meta charset="ISO-8859-1">

Así que ahora mismo estoy flipándolo un poco...

¿Alguien sabe por que sucede lo de las tildes? ¿Qué opináis del soporte recibido por MBI?
  #2 (permalink)  
Antiguo 20/09/2010, 10:38
 
Fecha de Ingreso: abril-2003
Mensajes: 1.129
Antigüedad: 14 años, 8 meses
Puntos: 34
Respuesta: Problema con tildes y la solucion que me ha dado el host

Nunca tuve en claro lo de los charset y sus diferentes resultados.

Lo que si se, es que uno te interpretará los acentos sin más. Y en otros para verlos, debes escribirlos como

á -> &aacute;
é -> &eacute;

Etc, etc.

La respuesta del host, no se, pero un servicio de hosting que se llama MBI Más Barato Imposible. Cuanto menos me despierta una "risita".

:P
__________________
elGastronomo
  #3 (permalink)  
Antiguo 20/09/2010, 11:44
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Problema con tildes y la solucion que me ha dado el host

zornak:


Hace un tiempo escribí esto, quizás te pueda ayudar

http://foros.emprear.com/codificar/

Quizás te pueda orientar, en cuanto a la actitud, no ceo porque tengan ellos que modificar tus archivos, y si vos insistis en que guardaste como utf-8, pasarle iso-8859-1 no debería arreglarte nada, si viste el link que te deje lo podes comprobar. fijate por las dudas como te guardaron el archivo que te editaron.

saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.
  #4 (permalink)  
Antiguo 20/09/2010, 13:15
Avatar de zornak  
Fecha de Ingreso: septiembre-2008
Ubicación: Toledo
Mensajes: 96
Antigüedad: 9 años, 2 meses
Puntos: 3
Respuesta: Problema con tildes y la solucion que me ha dado el host

El archivo lo dejaron como UTF-8 con BOM, y el charset en iso-8859-1...

Lo que no entiendo es por qué la web en un host se ve bien y en el otro no...

Bueno, mientras escribía el mensaje, se me ha ocurrido probar lo que dices de guardarlo sin BOM y funciona perfecto... ya se ven todas las tildes y símbolos y esta en UTF-8 que es lo que quería... no una mezcla como me han hecho los del host, que como bien dices no se para que tocan mis cosas...

También acabo de ver si me validaba la web y si, 0 errores =)

Muchísimas gracias emprear =)
  #5 (permalink)  
Antiguo 20/09/2010, 15:05
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Problema con tildes y la solucion que me ha dado el host

zornak:

Te agrego dos detalles,

Justamente por eso, en la guia que te pasé insisto en que no es necesario usar las entidades html para acentos y tildes por que puede llevara que veramos bien lo que estas mal.

a veces he comprobado que el problema corrompe el CSS y /o javascript, sobre todo en internet explorer.

Bueno, lo importante es que lo arreglaste

Saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.
  #6 (permalink)  
Antiguo 20/09/2010, 16:06
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema con tildes y la solucion que me ha dado el host

¿en cual navegador estas haciendo las comprobaciones? lo que pude notar es que por ejemplo en iexplorer8 si no indicas el atributo http-equiv del elemento <meta>, el navegador utiliza el charset predeterminado independientemente la codificacion utilizada para el documento. ¿no habra sido ese tu problema? si interesa, aca te dejo un tema donde se discutio acerca de los charset, el cual tambien contiene unos buenos articulos.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #7 (permalink)  
Antiguo 20/09/2010, 21:35
 
Fecha de Ingreso: abril-2009
Mensajes: 75
Antigüedad: 8 años, 8 meses
Puntos: 0
Respuesta: Problema con tildes y la solucion que me ha dado el host

este es el que yo uso y me salen las tildes y todo sin problemas

<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />
  #8 (permalink)  
Antiguo 21/09/2010, 09:45
Avatar de Rubenqlc  
Fecha de Ingreso: agosto-2009
Ubicación: Las Palmas (Islas Canarias-España)
Mensajes: 191
Antigüedad: 8 años, 3 meses
Puntos: 5
Respuesta: Problema con tildes y la solucion que me ha dado el host

Buenas amigos. Yo uso este:

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" lang="es" />

Pero cuidado, porque por ejemplo yo uso Dreamweaver para programar, y otras veces si he tenido problemas con las tíldes. En las propiedades de página, lo dejo así:
En el aprtado de Título/Modificación:
Tipo de Documento (DTD): XHTML 1.0 Strict
Codificación: Unicode (UTF-8)
Formulario de normas de Unicode: Ninguna
La casilla de: Incluir firma Unicode BOM - marcada

Pero tener todo esto hecho desde el primer documento, porque cuando creas más documentos, algo hace el Dreamweaver que lo deja mal, por eso os aconsejo esa configuración.

Espero que os sirva.

Saludos amigos.
  #9 (permalink)  
Antiguo 21/09/2010, 12:33
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Problema con tildes y la solucion que me ha dado el host

Rubenqlc

Cita:
Incluir firma Unicode BOM - marcada
Sería conveniente que la desmarques.

saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.
  #10 (permalink)  
Antiguo 22/09/2010, 06:13
Avatar de zornak  
Fecha de Ingreso: septiembre-2008
Ubicación: Toledo
Mensajes: 96
Antigüedad: 9 años, 2 meses
Puntos: 3
Respuesta: Problema con tildes y la solucion que me ha dado el host

Cita:
Iniciado por emprear Ver Mensaje
Rubenqlc



Sería conveniente que la desmarques.

saludos
Creo que lleva razon emprear, todos mis problemas venían por el BOM, ha sido quitarlo y se ve perfecto...

Lo gracioso, es que los del host me "obligasen" a usar ISO-8859-1... ya veremos lo que tardo en cambiarme de empresa....
  #11 (permalink)  
Antiguo 22/09/2010, 11:02
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Problema con tildes y la solucion que me ha dado el host

Zornak:

Si podés editar tu .htaccess

Podrías poner
AddDefaultCharset off
o bien
AddDefaultCharset utf-8

Detalles
http://httpd.apache.org/docs/2.0/mod...defaultcharset


Saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.

Etiquetas: dado, solucion, tildes, hosts
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:39.