Foros del Web » Creando para Internet » HTML »

Problema con validacion de Web

Estas en el tema de Problema con validacion de Web en el foro de HTML en Foros del Web. Buenas noches, Tengo una Web realizada, sin embargo a la hora de validarla me sale 1 warning que no se como solucionarlo: Character Encoding mismatch! ...
  #1 (permalink)  
Antiguo 11/01/2010, 14:26
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 2 meses
Puntos: 265
Problema con validacion de Web

Buenas noches,

Tengo una Web realizada, sin embargo a la hora de validarla me sale 1 warning que no se como solucionarlo:

Character Encoding mismatch!

The character encoding specified in the HTTP header (iso-8859-1) is different from the value in the <meta> element (utf-8). I will use the value from the HTTP header (iso-8859-1) for this validation.


Aca tienen el link a la validacion: http://validator.w3.org/check?uri=ht...Inline&group=0

Alguien me ayudaria a solucionar mi problema? Porque no se a que se refiere con mi header, y tengo toda la web validada pero con ese Warning que no se pq sale.

Desde ya muchas gracias.

Saludos.
  #2 (permalink)  
Antiguo 11/01/2010, 14:47
Avatar de pilsenero  
Fecha de Ingreso: septiembre-2006
Ubicación: Montevideo-Uruguay
Mensajes: 42
Antigüedad: 11 años, 3 meses
Puntos: 2
Respuesta: Problema con validacion de Web

no te preocupes por un warning la pagina igual es valida, y supongo que cambiando la codificacion a utf-8 se arregla el problema.

Saludos
__________________
www.casasyautomoviles.com
clasificados de casas, autos y motos
  #3 (permalink)  
Antiguo 11/01/2010, 14:47
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: Problema con validacion de Web

No te preocupes, no es un error. Es sólo una advertencia, significa que el servidor envía una cabecera que indica que el documento está codificado en ISO, pero la etiqueta <meta /> indica que la codificación es UTF-8. El validador usa el valor de la cabecera e interpreta el documento como ISO.
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #4 (permalink)  
Antiguo 11/01/2010, 15:13
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 2 meses
Puntos: 265
Respuesta: Problema con validacion de Web

Yo tengo la etiqueta meta con utf-8, y el archivo css tambien con esa codificacion.

En muchas webs vi que eso no aparece. Entonces no tengo que preocuparme de nada? Que bueno!

La validacion de este link no me sale correcta, y es por culpa del mapa de google que agregue, es muyy extraño!

http://validator.w3.org/check?uri=ht...Inline&group=0

A ustedes tambien les pasa?

Saludos.
  #5 (permalink)  
Antiguo 11/01/2010, 15:27
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: Problema con validacion de Web

El problema es que el DOCTYPE que estás usando (XHTML Strict) no permite usar iframe.
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #6 (permalink)  
Antiguo 11/01/2010, 15:31
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 2 meses
Puntos: 265
Respuesta: Problema con validacion de Web

Y cual le pongo? Solo tengo que cambiar ese. Lamentablemente no tengo muchos conocimientos de DOCTYPE, ni cual poner, se me pone automaticamente el que tengo.

Con eso creo que tendria todo solucionado.

Saludos.
  #7 (permalink)  
Antiguo 11/01/2010, 15:56
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: Problema con validacion de Web

XHTML Transitional permite el uso de iframe.
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #8 (permalink)  
Antiguo 11/01/2010, 17:45
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 2 meses
Puntos: 265
Respuesta: Problema con validacion de Web

Le puse este DOCTYPE

Código HTML:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
Y mira, funciono!!

http://validator.w3.org/check?uri=ht...Inline&group=0

Muchas gracias por todo, de verdad.

Saludos.

Etiquetas: Ninguno
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:31.