Foros del Web » Creando para Internet » HTML »

Problema con video de youtube y su codigo

Estas en el tema de Problema con video de youtube y su codigo en el foro de HTML en Foros del Web. Tengo mi web y enlazo videos de youtube, pero su codigo generado no esvalido para w3c.org @import url("http://static.forosdelweb.com/clientscript/vbulletin_css/geshi.css"); Código HTML: Ver original Line 79, Column ...
  #1 (permalink)  
Antiguo 10/02/2010, 17:08
Avatar de mark_ant0n  
Fecha de Ingreso: enero-2009
Ubicación: Comitan, Chiapas mx
Mensajes: 388
Antigüedad: 8 años, 10 meses
Puntos: 6
Problema con video de youtube y su codigo

Tengo mi web y enlazo videos de youtube, pero su codigo generado no esvalido para w3c.org
Código HTML:
Ver original
  1. Line 79, Column 143: cannot generate system identifier for general entity "hl"
  2. …ttp://www.youtube.com/v/Yzro8Bow4z4&hl=es_ES&fs=1&color1=0x3a3a3a&color2=0x99

Lo mas facil seria quitar los enlaces a los videos de youtube, pero me sirven que puedo hacer?.
__________________
"Diseño de software a la medida"

http://www.sadhoc.com
  #2 (permalink)  
Antiguo 10/02/2010, 18:11
Avatar de danneg  
Fecha de Ingreso: agosto-2009
Ubicación: Todo un mundo de posibilidades
Mensajes: 856
Antigüedad: 8 años, 3 meses
Puntos: 48
Respuesta: Problema con video de youtube y su codigo

Que html usas para maquetar?

Puede que de ahi venga el problema

Unas verciones no admiten el amp como simbolo en imagenes

Una alternativa al codigo de youtube seria utilizando swfobject para incrustar tus videos

Youtube lo utiliza
__________________
- Daniel García (@dannegm)
- [follow me | fork me on github...]
  #3 (permalink)  
Antiguo 10/02/2010, 19:06
Avatar de mark_ant0n  
Fecha de Ingreso: enero-2009
Ubicación: Comitan, Chiapas mx
Mensajes: 388
Antigüedad: 8 años, 10 meses
Puntos: 6
Respuesta: Problema con video de youtube y su codigo

swfobject, el normal pues mira el html que utilizo pues en partes es xhtml aun tengo erroers pero la mayoria son del codigo de que proporciona youtube, y por culpa de esos errores no puedo utilizar las imagenes de codigo correcto xhtml.
estas con mis cabeceras
Código HTML:
Ver original
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml">
__________________
"Diseño de software a la medida"

http://www.sadhoc.com
  #4 (permalink)  
Antiguo 10/02/2010, 20:18
Avatar de danneg  
Fecha de Ingreso: agosto-2009
Ubicación: Todo un mundo de posibilidades
Mensajes: 856
Antigüedad: 8 años, 3 meses
Puntos: 48
Respuesta: Problema con video de youtube y su codigo

Pues el error que muestras dice

Cannot entitie generate

En español

No se pueden generar tildes

Osea acentos, eñes, etc

En este caso el amperseing

El cual puedes sustituir por

&amp;

Por lo regular un error genera varios
__________________
- Daniel García (@dannegm)
- [follow me | fork me on github...]
  #5 (permalink)  
Antiguo 11/02/2010, 09:48
Avatar de mark_ant0n  
Fecha de Ingreso: enero-2009
Ubicación: Comitan, Chiapas mx
Mensajes: 388
Antigüedad: 8 años, 10 meses
Puntos: 6
Respuesta: Problema con video de youtube y su codigo

Entonces significa que puede quedar asi¿?
Código HTML:
Ver original
  1. ttp://www.youtube.com/v/Yzro8Bow4z4&amp;hl
__________________
"Diseño de software a la medida"

http://www.sadhoc.com
  #6 (permalink)  
Antiguo 11/02/2010, 11:42
Avatar de Willy_N  
Fecha de Ingreso: diciembre-2009
Ubicación: Cádiz
Mensajes: 334
Antigüedad: 8 años
Puntos: 18
Respuesta: Problema con video de youtube y su codigo

Pues si.

Aunque si lo hubieras probado también hubieras encontrado la respuesta.
  #7 (permalink)  
Antiguo 11/02/2010, 15:24
Avatar de mark_ant0n  
Fecha de Ingreso: enero-2009
Ubicación: Comitan, Chiapas mx
Mensajes: 388
Antigüedad: 8 años, 10 meses
Puntos: 6
Respuesta: Problema con video de youtube y su codigo

Willy_N, gracias por tu sugerencia pero no tenia mi compu, y en la escuela no tienen instalado el servidor apache, pero bueno, gracias danneg por tu sugerencia y de echo lo hice y funciona perfecto, pero el problema es que lo demas del codigo sigue marcando error, por ejemplo:
Código HTML:
Ver original
  1. Line 89, Column 143: general entity "hl" not defined and no default entity
  2.  
  3. ttp://www.youtube.com/v/Yzro8Bow4z4&hl=es_ES&fs=1&color1=0x3a3a3a&color2=0x99
  4.  
  5. Line 89, Column 315: Attribute "src" exists, but can not be used for this element.
  6.  
  7. ' value='always'></param><embed src='http://www.youtube.com/v/Yzro8Bow4z4&hl=
Estos dos son unos de tantos, y voy investigando pero son demasiados
__________________
"Diseño de software a la medida"

http://www.sadhoc.com
  #8 (permalink)  
Antiguo 11/02/2010, 15:31
Avatar de Willy_N  
Fecha de Ingreso: diciembre-2009
Ubicación: Cádiz
Mensajes: 334
Antigüedad: 8 años
Puntos: 18
Respuesta: Problema con video de youtube y su codigo

Hace no mucho estuve con lo que supongo que es el mismo problema que no me validaba el código que te da youtube.

Al final rehíce todo y lo dejé así:
Código HTML:
Ver original
  1. <object type="application/x-shockwave-flash"
  2. data="http://www.youtube.com/v/gVLtRe_B4pk&amp;hl=es&amp;fs=1&amp;rel=0&amp;color1=0x234900&amp;color2=0x4e9e00&amp;border=1"
  3. width="445" height="364">
  4. <param name="movie"
  5. value="http://www.youtube.com/v/gVLtRe_B4pk&amp;hl=es&amp;fs=1&amp;rel=0&amp;color1=0x234900&amp;color2=0x4e9e00&amp;border=1" />
Así valida.

Ten en cuenta que tendrás que cambiar los colores etc. por los tuyos pero el código en sí te da una idea, espero.
  #9 (permalink)  
Antiguo 11/02/2010, 15:42
Avatar de mark_ant0n  
Fecha de Ingreso: enero-2009
Ubicación: Comitan, Chiapas mx
Mensajes: 388
Antigüedad: 8 años, 10 meses
Puntos: 6
Respuesta: Problema con video de youtube y su codigo

Gracias Willy_N, se ve que trabajastes bastante en ello, ahora bien e probado el codigo en algu muy sencillo y funciona, pero el problema es que para w3c.org nomas no:S, sigue marcando errores. algo tengo mal¿?
Código HTML:
Ver original
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml">
  3.  
  4.  
  5. <title>Pagina nueva 1</title>
  6. </head>
  7.  
  8. <object type="application/x-shockwave-flash"
  9. data="gVLtRe_B4pk&hl=es&fs=1&rel=0&color1=0x234900&color2=0x4e9e00&border=1"
  10. width="445" height="364">
  11. <param name="movie"
  12. value="http://www.youtube.com/v/gVLtRe_B4pk&amp;hl=es&amp;fs=1&amp;rel=0&amp;color1=0x234900&amp;color2=0x4e9e00&amp;border=1" />
  13.  
  14. </body>
  15.  
  16. </html>
en total 18 errores y varios warning.

Código HTML:
Ver original
  1. #  Error  Line 11, Column 52: general entity "color2" not defined and no default entity
  2.  
  3. data="gVLtRe_B4pk&hl=es&fs=1&rel=0&color1=0x234900&color2=0x4e9e00&border=1"
  4.  
  5.  
  6. This is usually a cascading error caused by a an undefined entity reference or use of an unencoded ampersand (&) in an URL or body text. See the previous message for further details.

Y por cierto el video que tiene el enlace que video, que video jejej saludos
__________________
"Diseño de software a la medida"

http://www.sadhoc.com
  #10 (permalink)  
Antiguo 11/02/2010, 15:51
Avatar de Willy_N  
Fecha de Ingreso: diciembre-2009
Ubicación: Cádiz
Mensajes: 334
Antigüedad: 8 años
Puntos: 18
Respuesta: Problema con video de youtube y su codigo

Si que me costó un buen rato de comedura de coco para quitar todos los errores.

Sigues teniendo algunos & que debes sustituir por &amp;
  #11 (permalink)  
Antiguo 11/02/2010, 16:05
Avatar de mark_ant0n  
Fecha de Ingreso: enero-2009
Ubicación: Comitan, Chiapas mx
Mensajes: 388
Antigüedad: 8 años, 10 meses
Puntos: 6
Respuesta: Problema con video de youtube y su codigo

ok, gracias, si tengo dudas ahorita regreso a postear
__________________
"Diseño de software a la medida"

http://www.sadhoc.com

Etiquetas: video, youtube
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:15.