Foros del Web » Creando para Internet » HTML »

Problema en Firfox: en html no me lee el xml

Estas en el tema de Problema en Firfox: en html no me lee el xml en el foro de HTML en Foros del Web. Estoy haciendo un simple ejercicio en html , para leer un archivo xml . En IExplorer se ve a la perfección, pero en Firefox no ...
  #1 (permalink)  
Antiguo 11/03/2010, 10:07
 
Fecha de Ingreso: octubre-2008
Mensajes: 30
Antigüedad: 9 años, 1 mes
Puntos: 0
Problema en Firfox: en html no me lee el xml

Estoy haciendo un simple ejercicio en html, para leer un archivo xml.

En IExplorer se ve a la perfección, pero en Firefox no me lo lee en absoluto.

Quisiera saber si existe alguna línea, algún código, algo para garantizarme su correcta lectura en todos los navegadores.

Gracias y pido, especial detalle en la respuesta, dado que no soy un experto en dicha cuestión.

Escucho sugerencias sobre sistemas más seguros pero de la misma complejidad para llamar, en un archivo html, datos desde un xml.

Muchas gracias y un saludo.

Última edición por gjherrerac; 11/03/2010 a las 10:21
  #2 (permalink)  
Antiguo 11/03/2010, 17:48
Avatar de jmdz  
Fecha de Ingreso: marzo-2010
Ubicación: ¿Acá?
Mensajes: 54
Antigüedad: 7 años, 9 meses
Puntos: 2
Respuesta: Problema en Firfox: en html no me lee el xml

Podrías mostrarnos el código?
  #3 (permalink)  
Antiguo 12/03/2010, 15:29
 
Fecha de Ingreso: octubre-2008
Mensajes: 30
Antigüedad: 9 años, 1 mes
Puntos: 0
Respuesta: Problema en Firfox: en html no me lee el xml

Gracias por interesarte, jmdz.
El código, como te decía, es muy simple:

Código HTML:
Ver original
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml">
  3.  
  4. <xml id="cdcat" src="cd_catalog.xml"></xml>
  5.  
  6. <table border="1" datasrc="#cdcat">
  7. <tr>
  8. <td><span datafld="ARTIST"></span></td>
  9. <td><span datafld="TITLE"></span></td>
  10. </tr>
  11.  
  12. </body>
  13. </html>

Y el XML en cuestión

Código XML:
Ver original
  1. <?xml version="1.0" encoding="ISO-8859-1"?>
  2. <!-- Edited by XMLSpy® -->
  3. <CATALOG>
  4.     <CD>
  5.         <TITLE>Unchain my heart</TITLE>
  6.         <ARTIST>Joe Cocker</ARTIST>
  7.         <COUNTRY>USA</COUNTRY>
  8.         <COMPANY>EMI</COMPANY>
  9.         <PRICE>8.20</PRICE>
  10.         <YEAR>1987</YEAR>
  11.     </CD>
  12. </CATALOG>

En IExplorer se ve perfecto, pero en Firefox nada. No entiendo por qué.

Gracias nuevamente.
  #4 (permalink)  
Antiguo 12/03/2010, 16:12
 
Fecha de Ingreso: marzo-2010
Mensajes: 2
Antigüedad: 7 años, 8 meses
Puntos: 0
Respuesta: Problema en Firfox: en html no me lee el xml

Soy nuevo por aqui, pero hace poco estuve haciendo xml para un feed RSS, en internet explorer le aplicaba un estilo automaticamente, y se veia perfectamente, pero al no tener un estilo .css o .xsl, en firefox solo me mostraba el codigo del xml.

No se si es este el problema que tienes, saludos!
  #5 (permalink)  
Antiguo 12/03/2010, 16:48
Avatar de jmdz  
Fecha de Ingreso: marzo-2010
Ubicación: ¿Acá?
Mensajes: 54
Antigüedad: 7 años, 9 meses
Puntos: 2
Desacuerdo Respuesta: Problema en Firfox: en html no me lee el xml

Supongo que sin querer has ido a caer en uno de los grandes huecos de la web. Estas intentando usar algo llamado "XML Data Islands", un invento de hace algunos años de MS que no cuajo y por lo tanto solo lo reconoce Internet Explorer. Aunque MS dice: "This feature was implemented for MSXML 3.0. Later versions of MSXML might not support it." (1).

Hay formas de hacer algo similar a lo que queres hacer y que funcione en todos los navegadores (o al menos en la mayoría) pero es usando algo más que HTML (JavaScript/JScript (2), XSLT (3) o incluso CSS (4)) y lamentablemente no es tan simple como lo que proponía MS con las islas de datos.

Saludos.

Referencias:
1: http://msdn.microsoft.com/en-us/library/ms766512(VS.85).aspx
2: http://www.w3schools.com/xml/xml_http.asp
3: http://www.w3schools.com/xml/xml_xsl.asp
4: http://www.w3schools.com/xml/xml_display.asp
  #6 (permalink)  
Antiguo 14/03/2010, 11:52
 
Fecha de Ingreso: octubre-2008
Mensajes: 30
Antigüedad: 9 años, 1 mes
Puntos: 0
Respuesta: Problema en Firfox: en html no me lee el xml

Antes que nada, muchas gracias draco_jcs y jmdz por contestar.

Muchas gracias por las respuestas, investigaré las dos vías.

Si encuentro alguna novedad al respecto, la cuelgo en el foro.

Gracias de vuelta.

Etiquetas: firefox, xml
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 20:50.