Foros del Web » Creando para Internet » HTML »

Problema fuentes HTML

Estas en el tema de Problema fuentes HTML en el foro de HTML en Foros del Web. Hola! Estoy modificando una plantilla con el DW CS5 y la plantilla es HTML5, el tema es que estoy trabajando con la letra LUCIDA SANS, ...
  #1 (permalink)  
Antiguo 13/11/2010, 11:21
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Problema fuentes HTML

Hola!

Estoy modificando una plantilla con el DW CS5 y la plantilla es HTML5, el tema es que estoy trabajando con la letra LUCIDA SANS, y en el word me aparece las tildes y las ñ, pero al cargar la pagina no me salen,

Que puedo estar haciendo mal?
  #2 (permalink)  
Antiguo 13/11/2010, 11:57
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

busca por codificacion de documentos html, de eso es lo que trata tu consulta. en el foro html, al igual que otros subforos, es un tema bien recurrente. si por alguna razon no puedes hacerlo a codigos, entonces busque en el foro de editores web, de seguro ahi tambien se ha discutido.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #3 (permalink)  
Antiguo 14/11/2010, 15:13
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

Si el problema es que ya habia estado mirando, y no si hago algo mal, porque al inicio de mi archivo es:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />


Edito: Uso CSS, pero hay no he encontrado nada de codificación en esos archivos. Sobre la web son 4 HTML y los 4 empiezan igual.

Última edición por Vcnt; 14/11/2010 a las 15:27
  #4 (permalink)  
Antiguo 14/11/2010, 15:47
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

si continuas buscando y leyendo, debes encontrar que tambien se indica que no solo hay que indicar la codificacion en el documento sino tambien hay que guardar el documento con dicha codificacion. sobre los archivos externos (js, css, u otros) la codificacion se indica como atributo en el elemento que carga el archivo. en mi experiencia, este atributo es solo necesario cuando el archivo externo tiene una codificacion distinta al documento que lo carga.

un articulo que debe serte de utilidad para el tema de la codificacion... http://www.w3.org/International/O-ch...?changelang=es
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #5 (permalink)  
Antiguo 15/11/2010, 01:50
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

Tambien habia tenido en cuenta eso, guarda como UTF-8, con el formato de unicode C y algo de "sin bon" que leí que era recomendable si el editor lo permitia!
  #6 (permalink)  
Antiguo 17/11/2010, 02:41
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

He cambiado los encabezamientos por una pagina que usaba esa letra y no tenia problemas.
Ademas he abierto los archivos con bloc de notas y guardado con la codificacion.

Y nada de nada!
  #7 (permalink)  
Antiguo 17/11/2010, 11:30
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

te recomiendo que subas el documento a un servidor e indiques la url. NO te recomiendo que copies el codigo aqui porque se pierde la gracia de la codificacion y entonces deja de tener sentido.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #8 (permalink)  
Antiguo 18/11/2010, 13:20
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

Ok! La he subido entera, espero noticias!
ENLACE
  #9 (permalink)  
Antiguo 18/11/2010, 13:59
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

no le veo nada mal, de hecho me muestra bien el documento. ¿no sera que tu navegador esta configurado para utilizar un codificador en especifico? probablemente iso-8859-1.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #10 (permalink)  
Antiguo 18/11/2010, 18:03
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

al principio, abajo del todo en vez de técnico pone tcnico y en la parte de trabjos, donde pone Castellón pone Castelln, ¿no?

He preguntado a varios amigos y a ninguno les salia bien....
  #11 (permalink)  
Antiguo 18/11/2010, 18:16
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

tienes razon, lo que pasa que navego sin javascript. en fin, debe ser lo mismo como un tema reciente. sucede que la fuente que estas integrando no tiene un juego completo de caracteres (glyphs). aparentemente solo tiene los caracteres latinos que se usan en ingles. para determinarlo, revisalo con un editor de texto, escribe caracteres latinos del español y cambia la tipografia. o sino, en un visor de fuentes revisa la existencia de dicho caracteres.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #12 (permalink)  
Antiguo 19/11/2010, 03:47
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

Uis, me he liado no se si te refieres a una de estas dos cosas:


- Cambiar técnico y españa por t&eacute;cnico espa&ntilde;a , lo he cambiado y lo he subido y nada.


- Cambiar Lucida Sans por Arial, pero por ejemplo en el word, si pongo técnico españa con esa letra se ve perfectamente, igual en excel, photoshop (por supuesto) etc...

Se que me queda como ultima opción antes de cambiar de tipo de letra poner un imagenes, pero me gustaria poder arreglarlo.... si se puede...
  #13 (permalink)  
Antiguo 19/11/2010, 03:52
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

me refiero a la tipografia que has usado en cufon.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #14 (permalink)  
Antiguo 19/11/2010, 07:01
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

Me rindo!
He añadido el enlace ese cufon, y generado la fuente Lucida.font.js y nada de nada, y eso que he probado mil cosas ya!


Lo he subido todo de nuevo!
  #15 (permalink)  
Antiguo 19/11/2010, 16:26
 
Fecha de Ingreso: noviembre-2010
Ubicación: Madrid
Mensajes: 7
Antigüedad: 7 años
Puntos: 0
Respuesta: Problema fuentes HTML

Perdon si estoy ciego, pero a ver, el problema está en que las tildes no aparecen, o en que no aparece una determinada fuente?

Si es lo primero, sólo tienes que cambiar en la vista de html de tu documento (o abriéndolo con el bloq de notas) las letras con tilde por &eacute; (sin espacios antes ni detras) la e es la letra que quieres que lleve la tilde.
  #16 (permalink)  
Antiguo 19/11/2010, 16:54
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

@manuestaire,
te digo lo mismo que le he dicho a otros miembros,

Cita:
Iniciado por zerokilled Ver Mensaje
considero que deberias actualizarte. te recomiendo que leas los siguientes articulos:
http://www.w3.org/International/ques...ngelang=es#not
http://www.w3.org/International/O-ch...?changelang=es

no digo que esta mal utilizar entidades, pues siguen siendo totalmente valido. solo que basarse explicitamente en entidades trae otras complicaciones.
en fin, el problema debe ser que la fuente utilizada no tiene un amplio juego de caracteres latinos. si desactivas javascript y cargas la pagina del autor, veras que los caracteres se muestran correctamente. por tanto, no es tema de codificacion ni identidades. de ahi que asumo que debe ser la fuente cargada en cufon.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.

Última edición por zerokilled; 19/11/2010 a las 17:10 Razón: correccion
  #17 (permalink)  
Antiguo 19/11/2010, 19:52
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Problema fuentes HTML

Quiero confirmar la teoría de ZeroKilled, tus fuentes cufon.js están mal construidos para caracteres latinos extendidos.

Aqui te dejo una prueba. que tendrás que verificar con cualquier navegador menos IE

Código HTML:
Ver original
  1. Agente de usuario: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; FDM)
  2. Fecha: Sat, 20 Nov 2010 01:39:51 UTC
  3. Mensaje: 'firstChild' es nulo o no es un objeto
  4. Línea: 2
  5. Carácter: 17331
  6. Código: 0
  7. URI: http://foros.emprear.com/jsdemo/cufon/js/cufon-yui.js

y tampoco con Opera
y no tengo intención de analizar por que.

http://foros.emprear.com/jsdemo/cufon/

cufon.html usa selectores mientras cufon2.html reemplaza la fuente en un tag <h1>

Además te sugeriría que utilices @fontface, es compatible con todo y a mi juicio mucho mas sencillo de implementar


Saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.
  #18 (permalink)  
Antiguo 20/11/2010, 12:13
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

Bueno... creo que lo voy pillando!

Varias dudas! En archivos como TitilliumText22L_100.font.js lo que existe en una fuente, ¿cierto? ¿y ese archivo esta defectuoso xq las tildes y las ñ no las convierte bien ¿cierto? ¿Que pagina me recomendais para pasar fuentes a .js?

Última edición por Vcnt; 20/11/2010 a las 12:28
  #19 (permalink)  
Antiguo 20/11/2010, 12:47
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

personalmente no te puedo confirmar la duda si el archivo js esta defectuoso porque no utilizo cufon ni nada similar. sin embargo, te contesto por lo muy poquito que alguna vez habia leido y segun mi forma de analisis. el archivo js no esta corrupto. lo que sucede es que el programa que genera el documento js no encuentra el caracter en la tipografia. al no encontrarlo, segun sean las caracteristicas del programa y de la tipografia, puede ser que recibas un caracter distinto o que simplemente el programa no genera los datos para el caracter no encontrado en la tipografia. en resumen, como ya vengo mencionando, el problema debe ser la tipografia, no es cufon ni tema de codificacion. yo lo que te recomiendo es que busques otra tipografia y sobre todo que te asegures que dicha tipografia tenga un juego mas completo de caracteres latinos.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.

Última edición por zerokilled; 20/11/2010 a las 13:07
  #20 (permalink)  
Antiguo 20/11/2010, 12:58
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Problema fuentes HTML

Vcnt:

yo construi las fuentes en http://www.fontsquirrel.com/fontface/generator
le puse avanzado y agregue cosas como subset "español", latin extended y cosas asi, al igual que ZeroKilled, no uso cufon, pero hice eso y ya has visto los resultados.
es cuestion de experimentar un poco, pero insisto, @font-face me parece mucho más práctico (pero de todos modos deberás verificar que tu TTf soporte los caracterse que necesitas, lo cual es bastante sencillo de saber desde el Windows)


Zerokilled:
tienes razón, fue un poco precipitado de mi parte calificar de "corruptos" al los js. de Vcnt , como se lo señale, al ahora de construirlos, no utilizó las configuraciones apropiadas.

Saludos a ambos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.

Última edición por emprear; 20/11/2010 a las 13:03
  #21 (permalink)  
Antiguo 20/11/2010, 13:07
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema fuentes HTML

@Vcnt,

¿es posible que puedas indicar donde has descargado la fuente? o en su defecto si puedes proveer una copia. me dio curiosidad por revisar la fuente y al menos la que descargue tiene gran parte de los caracteres Latin-1, incluido las tildes y eñe.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #22 (permalink)  
Antiguo 21/11/2010, 04:40
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: Problema fuentes HTML

Hola:

Quizá este artículo te pueda ayudar: Uso de tipografías en la web.

Saludos.

  #23 (permalink)  
Antiguo 21/11/2010, 04:52
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

Gracias por vuestras respuestas!

He estado buscando y no recuerdo exactamente en que pagina la descarge, pero fue poner el nombre descargar y salia perfecto, con Ñ, acentos y todo.

Yo decia lo de que estuviera corrupto porque es una plantilla que descarge por internet, y es posible que cuando hicieran el archivo no tuvieran en cuenta los caracteres latinos, por eso voy a intentar volver a hacer el js y luego os cuento a ver como ha ido.

Zerokilled, una pregunta, cuando dices que yo lo que te recomiendo es que busques otra tipografia te refieres a cambiar a Arial por ejemplo? Con tanto termino me pierdo, y yo se un poco de html y poco mas.
  #24 (permalink)  
Antiguo 21/11/2010, 05:28
 
Fecha de Ingreso: octubre-2009
Mensajes: 299
Antigüedad: 8 años, 1 mes
Puntos: 2
Respuesta: Problema fuentes HTML

YA FUNCIONA!!!!

He generado el archivo js de nuevo con el link de emprear y ya esta!!!! Por lo visto si que es lo ultimo que yo decia!

Me ha pasado algo curioso, a ver si sabeis q puede ser. He cambiado el vinculo que habia al nuevo js y me daba error, en cambio despues de muchos intentos y comprobar que estaba todo bien le he sustituido por el nombre que viene en la plantilla y ya funciona!
Es raro, porque la unica referencia a esa fuente o arquivo es la del cufon, no aparece en ningun css ni nada!

La pena es que en el js solo hay un tipo de letra, no se puede hacer en mas fina, negrita, cursiva, etc...

Etiquetas: fuentes
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:55.