Foros del Web » Creando para Internet » HTML »

Problema en tablas redondeadas

Estas en el tema de Problema en tablas redondeadas en el foro de HTML en Foros del Web. Quise hacer tablas con los bordes redondeados y casi me salen bien. En Firefox se ven perfectas y en Explorer aparecen unos bordes extraños justo ...
  #1 (permalink)  
Antiguo 21/11/2006, 23:20
 
Fecha de Ingreso: octubre-2005
Mensajes: 42
Antigüedad: 12 años, 1 mes
Puntos: 0
Problema en tablas redondeadas

Quise hacer tablas con los bordes redondeados y casi me salen bien.
En Firefox se ven perfectas y en Explorer aparecen unos bordes extraños justo en las celdas donde tengo las imágenes redondeadas.Es como si la imagen no ocupara todo el espacio de la celda.
Cómo los saco?

Este es el código:
Código:
<table width=192 cellspacing=0 cellpadding=0 border=0>
         <tr>
            <td bgcolor=#000000><img src=imagenes/si.gif>
            </td>
            <td width=100% align=center bgcolor=#000000><font size=1 color=#ffffff face=verdana><b>Tiendas</b></font>
            </td>
            <td align=right bgcolor=#000000><img src=imagenes/sd.gif>
            </td>
         </tr>
         <tr>
            <td bgcolor=#0099ff><img src=transparente.gif width=1 height=1>
            </td><td align=center bgcolor=#0099ff><font size=1 color=ffffff face=verdana><a href=Madrid.php target=central>Madrid &raquo;</a></font>
            </td><td bgcolor=#0099ff><img src=transparente.gif width=1 height=1>
            </td>
         </tr>
         <tr>
            <td bgcolor=#0099ff><img src=transparente.gif width=1 height=1>
            </td><td align=center bgcolor=#0099ff><font size=1 color=ffffff face=verdana><a href=Barcelona.php target=centralFrame>Barcelona &raquo;</a>
            </td><td bgcolor=#0099ff><img src=transparente.gif width=1 height=1>
            </td>
         </tr>
         <tr>
            <td bgcolor=#0099ff><img src=transparente.gif width=1 height=1>
            </td>
            <td align=center bgcolor=#0099ff><font size=1 color=ffffff face=verdana><a href=Valencia.php target=centralFrame>Valencia &raquo;</a>
            </td>
            <td bgcolor=#0099ff><img src=transparente.gif width=1 height=1>
            </td>
         </tr>
         <tr>
            <td bgcolor=#0099ff><img src=transparente.gif width=1 height=1>
            </td>
            <td align=center bgcolor=#0099ff><font size=1 color=ffffff face=verdana><a href=Zaragoza.php target=centralFrame>Zaragoza &raquo;</a>
            </td>
            <td bgcolor=#0099ff><img src=transparente.gif width=1 height=1>
            </td>
         </tr>
         <tr>
            <td bgcolor=#0099ff><img src=imagenes/ii.gif height=14>
            </td>
            <td width=100% align=center bgcolor=#0099ff><font size=1 color=ffffff face=verdana><a href=Bilbao.php target=centralFrame>Bilbao &raquo;</a>
            </td>
            <td align=right bgcolor=#0099ff><img src=imagenes/id.gif height=14>
            </td>
         </tr>
      </table>

Última edición por jokin82; 21/11/2006 a las 23:21 Razón: error
  #2 (permalink)  
Antiguo 22/11/2006, 15:26
 
Fecha de Ingreso: octubre-2006
Ubicación: Quart de Poblet, Valencia
Mensajes: 767
Antigüedad: 11 años, 1 mes
Puntos: 8
Yo no veo ningún problema en sí, igual el problema está con las imágenes.

Postéalas y ya te informo.

Saludos.
  #3 (permalink)  
Antiguo 22/11/2006, 15:35
 
Fecha de Ingreso: octubre-2005
Mensajes: 42
Antigüedad: 12 años, 1 mes
Puntos: 0
Hay alguien que me eche una manilla.
La imagen es esta hxxp://img79.imageshack.us/img79/2777/explorerhh1.gif (sustituir las dos equis por dos tes)
  #4 (permalink)  
Antiguo 22/11/2006, 16:32
 
Fecha de Ingreso: octubre-2006
Ubicación: Quart de Poblet, Valencia
Mensajes: 767
Antigüedad: 11 años, 1 mes
Puntos: 8
Sí, eso te pasa porque la imagen es más pequeña que la celda, entonces se repite.
Tienes que poner la misma altura a la celda que la imagen.

Si sigue sin funcionarte ya nos comentas.
Saludos.
  #5 (permalink)  
Antiguo 22/11/2006, 17:12
 
Fecha de Ingreso: octubre-2005
Mensajes: 42
Antigüedad: 12 años, 1 mes
Puntos: 0
Gracias por responder
Es raro porque he igualado la altura de las celdas con la altura de las imagenes y sigue pasando lo mismo (aunque sólo en Explorer).
  #6 (permalink)  
Antiguo 22/11/2006, 17:32
 
Fecha de Ingreso: octubre-2006
Ubicación: Quart de Poblet, Valencia
Mensajes: 767
Antigüedad: 11 años, 1 mes
Puntos: 8
Yo lo qeu te recomendaría es usar css
con poner
background-image: url('direccionDeLaImagen.gif') no-repeat;
pero con HTML no sé como se podría

Puedes subir las imágenes "transparente.gif", "sd.gif" y las demás ?

Saludos!
  #7 (permalink)  
Antiguo 23/11/2006, 15:48
 
Fecha de Ingreso: octubre-2005
Mensajes: 42
Antigüedad: 12 años, 1 mes
Puntos: 0
Pues ya se arregló y resulta que era un tontería. Al estar trabajando con php, la posición de las etiquetas </td> no era la correcta. Moví cada una al final de la fila anterior y ya se ve como se tiene que ver. Para estar más seguro también modifiqué un poco la hoja de estilos.
De todas formas gracias por tu ayuda.
  #8 (permalink)  
Antiguo 23/11/2006, 17:20
 
Fecha de Ingreso: octubre-2006
Ubicación: Quart de Poblet, Valencia
Mensajes: 767
Antigüedad: 11 años, 1 mes
Puntos: 8
Me alegro mucho ;)

Saludos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:34.