Foros del Web » Creando para Internet » HTML »

Problema al usar un <label for='NombreID'> para marcar un Radio Button en iExplorer

Estas en el tema de Problema al usar un <label for='NombreID'> para marcar un Radio Button en iExplorer en el foro de HTML en Foros del Web. Hola, tengo un código que me funciona tanto en FireFox como en Opera, pero no en Internet Explorer, y la empresa esta me dice que ...
  #1 (permalink)  
Antiguo 02/06/2008, 03:17
 
Fecha de Ingreso: mayo-2008
Mensajes: 18
Antigüedad: 9 años, 6 meses
Puntos: 0
Problema al usar un <label for='NombreID'> para marcar un Radio Button en iExplorer

Hola, tengo un código que me funciona tanto en FireFox como en Opera, pero no en Internet Explorer, y la empresa esta me dice que tienen que utilizarlo en iExplorer...

Tengo un Radio Button con un id definido, para crearle un Label en el que meter un texto y una imagen, para que, al pulsar estos, el Radio Button se marque y poder tenerlo oculto. Todo ha ido perfecto hasta que les ha dado por probarlo en el Internet Explorer y este hombre se empeña en que tienen que utilizar este programa no sé por qué, pero así son los jefes...

Os paso el código:
Código HTML:
<td colspan='2' class="Estilo1">
        <label for='opPracoviste1'><img src='images/button_radio.gif' name='Branch1' width='112' height='112' border='0' id='Branch1' onclick='ToogleButtons(1)'/></label>
        <label for='opPracoviste1' onclick='ToogleButtons(1)'>prueba<input type='radio' name='pracoviste' id='opPracoviste1' value='1' />
        </label>
</input></td> 
Gracias por vuestro tiempo.

Última edición por Kandorf; 02/06/2008 a las 03:32
  #2 (permalink)  
Antiguo 02/06/2008, 12:47
Avatar de pateketrueke
Modernizr
 
Fecha de Ingreso: abril-2008
Ubicación: Mexihco-Tenochtitlan
Mensajes: 26.399
Antigüedad: 9 años, 8 meses
Puntos: 2526
Respuesta: Problema al usar un <label for='NombreID'> para marcar un Radio Button en

porque no revisas la documentacion que tiene Microsoft con respecto a su DOM ..... deveras, deberias.... es que cada cosa que hace, que wrap, que border.... foo, suerte!

NOTA: quiza solo es porke no usas comillas dobles... porke yo siempre he usado labels con for... y hasta en IE me funciona.... pero hay que usar bien las comillas (como debe ser)
__________________
Y U NO RTFM? щ(ºдºщ)

No atiendo por MP nada que no sea personal.
  #3 (permalink)  
Antiguo 02/06/2008, 17:07
 
Fecha de Ingreso: mayo-2008
Mensajes: 18
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Problema al usar un <label for='NombreID'> para marcar un Radio Button en

Hola, muchas gracias por tu respuesta.

Ahora mismo no estoy en la empresa, así que comprobaré mañana lo de las comillas.

No sé lo que es el DOM, ¿Te importaría decirme lo que es y cómo consultarlo?

Un saludo.
  #4 (permalink)  
Antiguo 02/06/2008, 20:17
Avatar de pateketrueke
Modernizr
 
Fecha de Ingreso: abril-2008
Ubicación: Mexihco-Tenochtitlan
Mensajes: 26.399
Antigüedad: 9 años, 8 meses
Puntos: 2526
Respuesta: Problema al usar un <label for='NombreID'> para marcar un Radio Button en

siginifica.... Document Object Model

facilmente lo puedes consultar en la Wikipedia en español

http://es.wikipedia.org/wiki/DOM

de ahí en fuera.... gracias, sigue investigando... :P
__________________
Y U NO RTFM? щ(ºдºщ)

No atiendo por MP nada que no sea personal.
  #5 (permalink)  
Antiguo 03/06/2008, 10:11
 
Fecha de Ingreso: mayo-2008
Mensajes: 18
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Problema al usar un <label for='NombreID'> para marcar un Radio Button en

Ok, gracias :)

Ya tengo solucionado el problema del Radio Button, al final lo he hecho con javascript, con el evento onclick de la imagen, haciendo que se marque el Radio Button que quería.

Saludos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:37.