Foros del Web » Creando para Internet » HTML »

Problema al Validar Elementos de Formulario

Estas en el tema de Problema al Validar Elementos de Formulario en el foro de HTML en Foros del Web. Hola, Quiero dejar mi web perfecta por completo. Incluyendo páginas muy accesorias, como las de enviar formularios de solicitud de enlaces, etc. Pero, en este ...
  #1 (permalink)  
Antiguo 28/09/2007, 07:19
 
Fecha de Ingreso: noviembre-2005
Mensajes: 825
Antigüedad: 12 años, 1 mes
Puntos: 8
Problema al Validar Elementos de Formulario

Hola,

Quiero dejar mi web perfecta por completo. Incluyendo páginas muy accesorias, como las de enviar formularios de solicitud de enlaces, etc.

Pero, en este caso, me encuentro con que el validador de xhtml no me funciona, dando este fallo:

<Form method="post" action="http://cgi.formulario.com/FormMail.pl"/>

Bajo la primera comilla (") del post hay un signo en rojo con la explicación previa:

There is no attribute "method".

Más abajo figura:

You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.

Seguro que es algo sencillo, pero a mí no me sale.

Espero algún tipo de asesoramiento, agradeciendo de antemano cualquier ayuda al respecto.

Un saludo
  #2 (permalink)  
Antiguo 28/09/2007, 09:33
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.544
Antigüedad: 15 años, 8 meses
Puntos: 1262
Re: Problema al Validar Elementos de Formulario

Hola:

No me suelo enterar de las parrafadas en inglés, pero a simple vista veo 2 cosas mal hechas... si usas el método post debes definir el atributo enctype (aunque si no me equivoco, por defecto es application/x-www-form-urlencoded...

Las etiquetas hay que escribirlas en minúsculas, o sea que debe ser "form"... esto último es fundamental.

Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:35.