Foros del Web » Creando para Internet » HTML »

problemas codigo html con xml

Estas en el tema de problemas codigo html con xml en el foro de HTML en Foros del Web. - <Balance> - <BalanceSituacion Anio="2005"> - <Activo> <Accionistas>0</Accionistas> -</Activo> </BalanceSituacion> </Balance> tengo problemas para coger el atributo anio de balanse situacion eh puesto bl=(mydoc.documentElement.childNodes(0).atrributes ) ...
  #1 (permalink)  
Antiguo 26/05/2006, 05:47
 
Fecha de Ingreso: mayo-2006
Mensajes: 5
Antigüedad: 11 años, 6 meses
Puntos: 0
problemas codigo html con xml

- <Balance>
- <BalanceSituacion Anio="2005">
- <Activo>
<Accionistas>0</Accionistas>
-</Activo>
</BalanceSituacion>
</Balance>

tengo problemas para coger el atributo anio de balanse situacion eh puesto

bl=(mydoc.documentElement.childNodes(0).atrributes )
response.write(bl)

pero no me lo coge
bl=(mydoc.documentElement.childNodes(0).nodename)
response.write(bl)
y con el nodename si me lo coge asi ke esta bien situado,alguien sabe el comando para sacarlo?

Última edición por gomjabbar; 29/05/2006 a las 02:44
  #2 (permalink)  
Antiguo 26/05/2006, 21:00
 
Fecha de Ingreso: abril-2002
Mensajes: 1.013
Antigüedad: 15 años, 7 meses
Puntos: 8
No será que no tienes cerrada la etiqueta <Activo> que la veo por ahí suelta? :

<Activo />
  #3 (permalink)  
Antiguo 29/05/2006, 02:42
 
Fecha de Ingreso: mayo-2006
Mensajes: 5
Antigüedad: 11 años, 6 meses
Puntos: 0
si no es por eso :S ,creo que he puesto mal el comando para coger al atributo y no se como es

Última edición por gomjabbar; 29/05/2006 a las 06:49
  #4 (permalink)  
Antiguo 29/05/2006, 16:07
 
Fecha de Ingreso: abril-2002
Mensajes: 1.013
Antigüedad: 15 años, 7 meses
Puntos: 8
leñes es cierto, la tienes cerrada, no se me ocurre nada sorry :(
  #5 (permalink)  
Antiguo 31/05/2006, 04:58
 
Fecha de Ingreso: mayo-2006
Mensajes: 5
Antigüedad: 11 años, 6 meses
Puntos: 0
:_ need help
  #6 (permalink)  
Antiguo 31/05/2006, 10:49
Avatar de webosiris
Moderador egiptólogo
 
Fecha de Ingreso: febrero-2002
Ubicación: Luxor, Egipto
Mensajes: 10.727
Antigüedad: 15 años, 9 meses
Puntos: 997
donde está el código html ahí? ¿estás usando xhtml o xml? ... quizás te puedan ayudar mejor en el foro de xml...
__________________
Pasamos tus PSD a HTML

Pobre del que lo sabe todo, porque no tiene nada más que aprender ni razón para vivir. -
  #7 (permalink)  
Antiguo 01/06/2006, 03:28
 
Fecha de Ingreso: mayo-2006
Mensajes: 5
Antigüedad: 11 años, 6 meses
Puntos: 0
extoy usando xhtml creo xdd:
bl=(mydoc.documentElement.childNodes(0).nodename)
response.write(bl)
y
bl=(mydoc.documentElement.childNodes(0).atrributes )
response.write(bl)

.Esta bien escrito me coge el nombre del nodo pero el atributo Anio no se como cogerlo
  #8 (permalink)  
Antiguo 01/06/2006, 03:34
 
Fecha de Ingreso: enero-2006
Mensajes: 30
Antigüedad: 11 años, 10 meses
Puntos: 1
Prueba con:

.getAttribute("Anio")

Un saludo.
  #9 (permalink)  
Antiguo 01/06/2006, 03:56
 
Fecha de Ingreso: abril-2002
Mensajes: 1.013
Antigüedad: 15 años, 7 meses
Puntos: 8
Hola, está mal escrita la última palabra , sería "attributes"

bl=(mydoc.documentElement.childNodes(0).atrributes )
  #10 (permalink)  
Antiguo 01/06/2006, 04:18
 
Fecha de Ingreso: mayo-2006
Mensajes: 5
Antigüedad: 11 años, 6 meses
Puntos: 0
con .getAttribute("Anio") funciono, gracias :)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:01.