Foros del Web » Creando para Internet » HTML »

Problemas con el boton envio de un formulario

Estas en el tema de Problemas con el boton envio de un formulario en el foro de HTML en Foros del Web. Hola a todos, soy un poco novato con el PHP y estoy dandole vueltas a la cabeza a un problema que no consigo resolver, y ...
  #1 (permalink)  
Antiguo 12/05/2009, 04:27
 
Fecha de Ingreso: noviembre-2007
Mensajes: 68
Antigüedad: 10 años
Puntos: 7
Problemas con el boton envio de un formulario

Hola a todos, soy un poco novato con el PHP y estoy dandole vueltas a la cabeza a un problema que no consigo resolver, y es que he conseguido hacer un formulario (no sin antes sudar la gota gorda) pero hay una cosa que me falla mucho a nivel de diseño, y es que no consigo hacer que el boton de enviar sea diferente al que me pone por defecto el Dreamweaver.

Pongo este post en HTML porque me parece mas apropiado que para PHP, ya que creo que la solucion debe estar en tocar algo en el campo de formulario del HTML.

El caso es que estoy haciendo una pista de aterrizaje y le falla mucho el boton de enviar, queda horrible, es muy pequeño y desentona con el resto del diseño. He probado a tocar un poco el codigo pero sin ningun resultado.

Mi pregunta es como podria modificar el tamaño del boton envio, o como poner una imagen y que cumpla la misma funcion que el submit (a mi parecer esta seria la mejor opcion)

Muchas gracias!
  #2 (permalink)  
Antiguo 12/05/2009, 04:48
 
Fecha de Ingreso: mayo-2009
Ubicación: Fuerteventura
Mensajes: 324
Antigüedad: 8 años, 7 meses
Puntos: 19
Respuesta: Problemas con el boton envio de un formulario

Hola, más apropiado aún es ponerlo en css. Al boótn le puedes darle un id y darle estilo como a cualquier otro elemento. A modo de ejemplo:

#enviar {
width: 80px;
height: 40px:
background: #color url(imagen.gif) top left no-repeat;
}

Salud!
  #3 (permalink)  
Antiguo 12/05/2009, 04:49
 
Fecha de Ingreso: noviembre-2007
Mensajes: 68
Antigüedad: 10 años
Puntos: 7
Respuesta: Problemas con el boton envio de un formulario

Ups, lo siento, habia mirado el FAQ antes de postear pero se me habia pasado por alto. Lo he vuelto a mirar para responder otras dudas y entonces he visto la solucion al problema del boton de envio cual aura celestial y musica de coro de angeles.

Solo tuve que cambiar de

<input type= "submit" name= "Submit" value= "Envoi" />

a

<input type="image" src="img/livraison%20gratuite.jpg" width="190" height="109" border="0" name= "Submit" value= "Envoi" />


Un millon de gracias para los que os habeis molestado en hacer ese FAQ tan genial

Si algun moderador quiere cerrar el tema, adelante, ya esta resuelto

gracias de nuevo!!!
  #4 (permalink)  
Antiguo 12/05/2009, 05:39
 
Fecha de Ingreso: noviembre-2007
Mensajes: 68
Antigüedad: 10 años
Puntos: 7
Respuesta: Problemas con el boton envio de un formulario

A decir verdad, todavia no me he puesto con las css, soy mas diseñador grafico que programador, pero a fuerza de tener que hacer cosas para webs estoy aprendiendo forzosamente. y si, tengo que pasarme a las css de una vez por todas.

Gracias por el dato, lo guardare para el futuro!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:26.