Foros del Web » Creando para Internet » HTML »

Problemas con Charset :(

Estas en el tema de Problemas con Charset :( en el foro de HTML en Foros del Web. Hola a todos! Se que de este tema se ha hablado mucho y hay muchas soluciones posibles si leemos las FAQs o buscamos en el ...
  #1 (permalink)  
Antiguo 03/05/2010, 12:27
Avatar de 2D6
2D6
 
Fecha de Ingreso: enero-2006
Ubicación: Posadas, Misiones
Mensajes: 60
Antigüedad: 11 años, 11 meses
Puntos: 4
Problemas con Charset :(

Hola a todos!
Se que de este tema se ha hablado mucho y hay muchas soluciones posibles si leemos las FAQs o buscamos en el foro.

Pero la verdad que me tiene cansado este tema porque no logro encontrar una solución real a este problema.

Hoy me encuentro trabajando en un sitio, basicamente es PHP + Mysql. Obviamente en mi servidor local funcionaba perfecto pero al subirlo me encontré con que los tildes y eñes no se veían, sino que eran reemplazados con caracteres extraños.

Ahora, lo que hice fue: poner en el archivo de conección a la base de datos esto:

Código PHP:
mysql_query("SET CHARACTER SET utf8");
mysql_query("SET NAMES utf8"); 
Al principio pense que era la solucion pero despues descubri que no lo era, ya que en Google Chrome se ve perfecto, lo mismo en IE (que raro, no?), pero en Opera y Firefox los caracteres con tilde o eñes se ven mal.

Por favor, alguien tiene una solucion para este tema?

Gracias de antemano
  #2 (permalink)  
Antiguo 05/05/2010, 01:08
Avatar de ipraetoriux  
Fecha de Ingreso: abril-2010
Ubicación: ipraetoriux.com
Mensajes: 1.125
Antigüedad: 7 años, 7 meses
Puntos: 154
Respuesta: Problemas con Charset :(

Si la verdad tambien estoy luchaando con este tema, seria bueno haber si alguien tienen la solucion....muchas gracias

Etiquetas: charset
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:57.