Foros del Web » Creando para Internet » HTML »

Problemas con codigo php en IE, konqueror y Firefox

Estas en el tema de Problemas con codigo php en IE, konqueror y Firefox en el foro de HTML en Foros del Web. hola a todos como estan tengo un problema con un codigo en PHP en el cual uso un "href" para pasar unos valores por GET, ...
  #1 (permalink)  
Antiguo 01/07/2008, 13:16
Avatar de Devil  
Fecha de Ingreso: agosto-2003
Ubicación: Cartagena
Mensajes: 59
Antigüedad: 14 años, 4 meses
Puntos: 0
Pregunta Problemas con codigo php en IE, konqueror y Firefox

hola a todos como estan tengo un problema con un codigo en PHP en el cual uso un "href" para pasar unos valores por GET, que me funciona bien en mi maquina utilizando Firefox3 bajo linux. pero si utilizo el IE 6 y el Konqueror bajo el mismo S.O e incluso bajo Win, no se ejecuta bien el código, que podrías ser???, e incluso en otra maquina con firefox 2 funciona pero en otras con firefox3 no funciona... quien pueda resolver el misterio porfas se los agradezco...

Código:
<td align='center'><fieldset><legend>Create Service Page </legend><a href='pdfservicios.php?eid=$eid&nomcli=$nomcli&ruta=$ruta' target='_self'><input type='submit' name='serpdf' value='Hoja de Servicio'></a></td>
__________________
Devil...La Verdad Os Hara Libres...El Conocimiento Invensible
  #2 (permalink)  
Antiguo 01/07/2008, 13:24
Avatar de Marvin
Colaborador
 
Fecha de Ingreso: febrero-2005
Ubicación: global $Chile->Santiago;
Mensajes: 1.990
Antigüedad: 12 años, 10 meses
Puntos: 80
Respuesta: Problemas con codigo php en IE, konqueror y Firefox

Trataste cerrando el fieldset antes del td para ver si es un problema de interpretacion del browser... porque el link deberia funcionar sin problemas... ahora... tambien existe la posibilidad de que las variables no se interpreten entre comillas simples... por lo que tambien recomendaria hacerlo con dobles comillas... algo asi:
Código PHP:
'<td align="center"><fieldset><legend>Create Service Page </legend><a href="pdfservicios.php?eid='.$eid.'&nomcli='.$nomcli.'&ruta='.$ruta.'" target="_self"><input type="submit" name="serpdf" value="Hoja de Servicio"></a></fieldset></td>'
Suerte!
__________________
El que dice "Solo sé que nada sé", esta asumiendo que sabe algo.
Lea las FAQ's!
  #3 (permalink)  
Antiguo 01/07/2008, 13:25
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 6 meses
Puntos: 2122
Respuesta: Problemas con codigo php en IE, konqueror y Firefox

Tema trasladado a HTML.
  #4 (permalink)  
Antiguo 01/07/2008, 13:30
Avatar de Devil  
Fecha de Ingreso: agosto-2003
Ubicación: Cartagena
Mensajes: 59
Antigüedad: 14 años, 4 meses
Puntos: 0
Respuesta: Problemas con codigo php en IE, konqueror y Firefox

gracias por tu respuesta rapida....ya cerre el fieldset y lo probe asi me lo describiste, y sigue igual en el konqueror ni siquiera me llama a la pagina en cuestión y en IE me saca y me manda a la pagina de inicio... que sera??
__________________
Devil...La Verdad Os Hara Libres...El Conocimiento Invensible
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:51.