Foros del Web » Creando para Internet » HTML »

problemas con firefox anterior al 4

Estas en el tema de problemas con firefox anterior al 4 en el foro de HTML en Foros del Web. Hola a todos, tengo un problema... estoy acabando las prácticas de ftp de informática, y el caso es que justo cuando voy a presentar una ...
  #1 (permalink)  
Antiguo 08/06/2011, 18:12
 
Fecha de Ingreso: mayo-2011
Mensajes: 9
Antigüedad: 6 años
Puntos: 0
problemas con firefox anterior al 4

Hola a todos, tengo un problema... estoy acabando las prácticas de ftp de informática, y el caso es que justo cuando voy a presentar una web que estoy haciendo... me doy cuenta que el jquery funciona mal en firefox anterior al 4...
me descuadra los css. y me gustaría saber como puedo apañarlo...porque si edito los css con los campos para el ff3, en el 4 se verán mal supongo


la única solución que se me ocurre, es como en el explorer, usar las etiquetas de


<!--[if IE]>

<![endif]-->


pero de FF no encuentro... solo el codigo universal... no para la versión que quieras.

alguien tiene alguna idea?


dejo la pagina para que veais a que me refiero, seria encima de las 3 etiquetas de la derecha, que pasando por encima se muestran sliders con jquery

www .tagediciones. es
  #2 (permalink)  
Antiguo 08/06/2011, 23:37
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 9 años, 11 meses
Puntos: 1567
Respuesta: problemas con firefox anterior al 4

Primero deberías asegurarte que el javascritp este correcto, Firefox 4 e bastante menos permisivo, utilizá la consola de errores.
Ahora si necesitas detectar el navegador y en base a eso escribir tu código, necesitas de una herramienta avanzada, yo utilizo esta clase en php, te dejo una demo y la posibilidad de descargarla en

http://foros.emprear.com/html/deteccion-browser/

Saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.
  #3 (permalink)  
Antiguo 09/06/2011, 05:02
 
Fecha de Ingreso: mayo-2011
Mensajes: 9
Antigüedad: 6 años
Puntos: 0
Respuesta: problemas con firefox anterior al 4

Cita:
Iniciado por emprear Ver Mensaje
Primero deberías asegurarte que el javascritp este correcto, Firefox 4 e bastante menos permisivo, utilizá la consola de errores.
Ahora si necesitas detectar el navegador y en base a eso escribir tu código, necesitas de una herramienta avanzada, yo utilizo esta clase en php, te dejo una demo y la posibilidad de descargarla en

[url]http://foros.emprear.com/html/deteccion-browser/[/url]

Saludos
perfecto!! muy util gracias y me lo guardo para futuros usos

al final conseguí arreglarlo simplemente poniendo los css en el html en vez de en el archivo css específico...

algun bug extraño de FF3...


si no funcionaba...me salvabas que hoy acabo y tengo que presentarla a la tarde
  #4 (permalink)  
Antiguo 09/06/2011, 07:32
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 9 años, 11 meses
Puntos: 1567
Respuesta: problemas con firefox anterior al 4

djpeck:
Simplemente para sacarnos de la duda, como lo tenias el orden antes de poner los estilos en el html...
<head>
<link rel="stylesheet" src.....
<script type="text/vavascript"......
</head>

ó al revés ?
siempre es recomendable definir los estilos 1º, si lo tenias al reves, tratá de invertirlos

Saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.

Etiquetas: firefox, anteriores
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:58.