Foros del Web » Creando para Internet » HTML »

problemas con fonts

Estas en el tema de problemas con fonts en el foro de HTML en Foros del Web. hola amigos queria ver si me podian ayudar. resulta que tengo un problema, al parecer mi servidor no tiene letras españolas digase acentos y Ñ ...
  #1 (permalink)  
Antiguo 07/01/2009, 11:15
Avatar de backend  
Fecha de Ingreso: mayo-2004
Ubicación: chile
Mensajes: 135
Antigüedad: 13 años, 6 meses
Puntos: 0
problemas con fonts

hola amigos
queria ver si me podian ayudar.
resulta que tengo un problema, al parecer mi servidor no tiene letras españolas
digase acentos y Ñ yen vez de eso me aparece � � � queria hacer funcionar las fuentes arial y otras que tenia que subi que si las tienen.
encontre esto

!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<HTML>
<HEAD>
<TITLE>Font test</TITLE>
<STYLE TYPE="text/css" MEDIA="screen, print">
@font-face {
font-family: "Robson Celtic";
src: url("http://site/fonts/rob-celt")
}
H1 { font-family: "Robson Celtic", serif }
</STYLE>
</HEAD>
<BODY>
<H1> This heading is displayed using Robson Celtic</H1>
</BODY>
</HTML>

gracias, espero una respuesta
  #2 (permalink)  
Antiguo 07/01/2009, 12:23
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: problemas con fonts

Cambia la codificación de tus archivos y coloca explícitamente esa codificación en tu código (utf, iso, etc.).

O más fácil, usa entidades html.

Saludos .
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #3 (permalink)  
Antiguo 07/01/2009, 15:19
Avatar de Omura
Colaborador
 
Fecha de Ingreso: julio-2006
Ubicación: Peru
Mensajes: 3.491
Antigüedad: 11 años, 5 meses
Puntos: 185
Respuesta: problemas con fonts

personalmente combino ambas opciones...

aunque muchos prefieren el UTF-8 (http://es.wikipedia.org/wiki/UTF-8)

yo uso el ISO-8859-1 (http://es.wikipedia.org/wiki/ISO_8859-1)

<META http-equiv=Content-Type content="text/html; charset=ISO-8859-1">

junto con las entidades html...

á = &aacute;
é = &eacute;
...

Camión = Cami&oacute;n

ñ = &ntilde;
Ñ = &Ntilde;

Piña = Pi&ntilde;a
__________________
Mi error era de código... pero de código genético.
  #4 (permalink)  
Antiguo 07/01/2009, 20:13
Avatar de backend  
Fecha de Ingreso: mayo-2004
Ubicación: chile
Mensajes: 135
Antigüedad: 13 años, 6 meses
Puntos: 0
Respuesta: problemas con fonts

GRACIAS se me soluciono gracias a sus respuestas
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:30.