Foros del Web » Creando para Internet » HTML »

problemas con un formulario

Estas en el tema de problemas con un formulario en el foro de HTML en Foros del Web. Buenas, he hecho un formulario con dos campos para seleccionar entre varias opciones y un boton. No tengo mucha idea y el caso es que ...
  #1 (permalink)  
Antiguo 13/04/2005, 14:26
 
Fecha de Ingreso: febrero-2004
Mensajes: 67
Antigüedad: 13 años, 10 meses
Puntos: 0
problemas con un formulario

Buenas, he hecho un formulario con dos campos para seleccionar entre varias opciones y un boton.
No tengo mucha idea y el caso es que funciona bien pero al mostrarlo en el Internet Explorer hace una cosa rara: debajo del formulario me mete un espacio que yo no he añadido (parecen un par de saltos de linea) y que con el Mozilla y otros navegadores no sale. Os pongo el codigo a ver si me podeis decir porque pasa eso, en este caso no me molesta mucho pero estoy haciendo otro y si es importante que no me meta el espacio.

Código HTML:
<table width="100%" border="0" cellspacing="5" cellpadding="0">
        <tr> 
          <td><form action="index.php" method="post" name="form1">
              <table width="440" border="0" align="center" cellpadding="0" cellspacing="0">
                <tr> 
                  <td width="100"> <div align="left"><img src="form_buscar.gif" width="100" height="20"></div></td>
                  <td width="35"><div align="right"><img src="form_zona.gif" width="35" height="15"></div></td>
                  <td width="145"><select style="font-size: 11px" name="zona" size="1">
                      <option selected>Todas</option>
                      <option>Comunidad Valenciana</option>
                      <option>Catalunya</option>
                      <option>Castilla Leon</option>
					  <option>Baleares</option>
					  <option>Andalucia</option>
					  <option>Madrid</option>
                      <option>USA</option>
                    </select></td>
                  <td width="35"><div align="right"><img src="form_anyo.gif" width="35" height="15"></div></td>
                  <td width="70"> <div align="left"> 
                      <select name="ano" size="1" style="font-size: 11px">
                        <option selected>Todos</option>
                        <option>2005</option>
                        <option>2004</option>
                        <option>2003</option>
                      </select>
                    </div></td>
                  <td width="55"><input name="submit" type=submit value="Enviar" style="font-size: 11px"></td>
                </tr>
              </table>
            </form></td>
        </tr>
      </table> 
  #2 (permalink)  
Antiguo 13/04/2005, 14:40
Avatar de KarlanKas
Moderador extraterrestre
 
Fecha de Ingreso: diciembre-2001
Ubicación: Madrid
Mensajes: 6.987
Antigüedad: 16 años
Puntos: 60
Prueba a cerrar el formulario justo después del botón de submit:
Esto
Código PHP:
<td width="55"><input name="submit" type=submit value="Enviar" style="font-size: 11px"></td>
                </
tr>
              </
table>
            </
form></td
cambialo por esto:
Código PHP:
<td width="55"><input name="submit" type=submit value="Enviar" style="font-size: 11px"></form></td>
                </
tr>
              </
table>
            </
td
Un saludo!!
__________________
Cómo escribir

No hay pregunta tonta, sino tonto que quiere seguir en la ignorancia.
  #3 (permalink)  
Antiguo 13/04/2005, 18:46
 
Fecha de Ingreso: abril-2003
Mensajes: 79
Antigüedad: 14 años, 7 meses
Puntos: 0
Revisa el formulario en explorer, y en mozilla , si uno de los dos sale bien y el otro mal, tendras que crear uno para cada browser o hacerlo mediante .css para que ambos lo entiendan....

saludos.-
__________________
*Tratando de Aprender de los errores.....
  #4 (permalink)  
Antiguo 14/04/2005, 04:55
 
Fecha de Ingreso: febrero-2004
Mensajes: 67
Antigüedad: 13 años, 10 meses
Puntos: 0
ya está solucionado, he probado algo parecido a lo que ha puesto KarlanKas y rula perfectamente, muchas gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:53.