Foros del Web » Creando para Internet » HTML »

Problemas con le etiqueta <bgsound>!!!

Estas en el tema de Problemas con le etiqueta <bgsound>!!! en el foro de HTML en Foros del Web. Hola Comunidad Para la reproduccion de audio en mi sitio Web uso la etiqueta BGSOUND, esta me hace todo lo que quiero pero en el ...
  #1 (permalink)  
Antiguo 01/04/2007, 12:10
 
Fecha de Ingreso: febrero-2007
Mensajes: 69
Antigüedad: 10 años, 9 meses
Puntos: 0
Problemas con le etiqueta <bgsound>!!!

Hola Comunidad
Para la reproduccion de audio en mi sitio Web uso la etiqueta BGSOUND, esta me hace todo lo que quiero pero en el Browser Internet Explorer, cuando la abro con el Moxilla Firefox no se oye el sonido....que solucion le doy a este problema????
gracias de antemanos...
  #2 (permalink)  
Antiguo 01/04/2007, 16:36
Avatar de Raulmmmm  
Fecha de Ingreso: marzo-2007
Ubicación: En otro lugar que tú
Mensajes: 1.549
Antigüedad: 10 años, 8 meses
Puntos: 36
Re: Problemas con le etiqueta <bgsound>!!!

Pon en el <body>:
Código HTML:
<embed src="fichero.mp3" loop="true" autostart="true" hidden="true"></embed> 
  #3 (permalink)  
Antiguo 01/04/2007, 19:50
 
Fecha de Ingreso: febrero-2007
Mensajes: 69
Antigüedad: 10 años, 9 meses
Puntos: 0
Re: Problemas con le etiqueta <bgsound>!!!

Gracias Raulmmm de verdad me pincha bien pero con la bgsound yo modifico la propiedad src diciendo desde una funcion JS id.src = "lo que sea";, ahora esta nueva etiqueta no me da esa posibilidad o mejor dicho, no me pincha....que me recomiendas.....
  #4 (permalink)  
Antiguo 02/04/2007, 07:37
Avatar de Raulmmmm  
Fecha de Ingreso: marzo-2007
Ubicación: En otro lugar que tú
Mensajes: 1.549
Antigüedad: 10 años, 8 meses
Puntos: 36
Re: Problemas con le etiqueta <bgsound>!!!

Pon el código de tu función bgsound y quizá te pueda ayudar.
  #5 (permalink)  
Antiguo 02/04/2007, 09:26
 
Fecha de Ingreso: febrero-2007
Mensajes: 69
Antigüedad: 10 años, 9 meses
Puntos: 0
Re: Problemas con le etiqueta <bgsound>!!!

OK Raulmmmm, mira en el codigo JS pongo esto:
function ONOFF () {
if (Link.src != "") {
Link.src="";
} else {
Link.src = "mimusica.mp3";
}
return true;
}
muy sencillo verdad??
despues esta etiqueta en el body:
<bgsound id="Link" loop="1" src="mimusica.mp3">
y un boton
<input type="submit" value="MiMusica" onclick="ONOFF()">

lo que hace es que la pagina sale con un sonido, y cuando doy click en el boton modifico los valores src de la etiqueta y así logro parar la música de forma sencilla y además activarla, pero el Firefox no lo reconoce, ni siquiera se oye, entonces puse la etiqueta EMBED que si reproduce para el browser Firefox pero no se como darle play y stop a la musica...
  #6 (permalink)  
Antiguo 04/04/2007, 09:38
Avatar de Raulmmmm  
Fecha de Ingreso: marzo-2007
Ubicación: En otro lugar que tú
Mensajes: 1.549
Antigüedad: 10 años, 8 meses
Puntos: 36
De acuerdo Re: Problemas con le etiqueta <bgsound>!!!

Pues en el código que te di pon solo esto:
<embed src="fichero.mp3"></embed>
  #7 (permalink)  
Antiguo 04/04/2007, 10:32
 
Fecha de Ingreso: febrero-2007
Mensajes: 69
Antigüedad: 10 años, 9 meses
Puntos: 0
Re: Problemas con le etiqueta <bgsound>!!!

si, pero no veo la forma de referirme a esa etiqueta....
  #8 (permalink)  
Antiguo 05/04/2007, 04:52
Avatar de Raulmmmm  
Fecha de Ingreso: marzo-2007
Ubicación: En otro lugar que tú
Mensajes: 1.549
Antigüedad: 10 años, 8 meses
Puntos: 36
Re: Problemas con le etiqueta <bgsound>!!!

Pero asi no te hace falta el javascript, te sale la consola de la música y ya está.
Es que yo tampoco sé como hacer lo que tú dices.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:03.